Well, the suggestion to upgrade to MySQL v5 was just that, a suggestion. Slashcode will work with v4 or v5 - but v4's old. If you are starting fresh, you may as well go with v5, so you won't have to up it later w/ a working server.

My laptop is a Macbook Pro, so no, Fedora {anything} isn't on it. We have a few slashcode (er lamp) servers running FC4. Never had any problems with any RH7->FC4 machines (or RHEL, but haven't tried CentOS yet) running slashcode, ever. I did have our lanmanager push down a FC5 bare install to a machine to get setup and test things out on, but I've not had time to mess with it.

If I had to guess, you still are either missing required perl modules, or one (or more) is not installed correctly. Make sure you have them all installed (from Bundle::Slash) as well as DBIx::Password and Template-toolkit.

I don't think I normally replace the Perl that comes w/ any of the above distro's.

[shane@web1 ~]$ cat /etc/redhat-release
Fedora Core release 4 (Stentz)
[shane@web1 ~]$ rpm -q perl
perl-5.8.6-24

And I run MySQL from tarball, not RPM.

Shane




On Oct 5, 2006, at 7:10 PM, Anand Nimmagadda wrote:

Shane, thank you so much for your reply.
After I got your reply, I tried different with different versions of slash code.
with same MySQl version (4.1.x),
tried R tag, T tag and tip of the code.
After upgrading the MySQL version to 5.0.x
updated thePERL modules with force and tried R tag, T tag and tip of the code
None of this solved the problem. While updating the PERL modules, I noticed following warning message,
CPAN.pm: Going to build M/MA/MARCLANG/ParallelUserAgent-2.57.tar.gz

**** WARNING: Unsupported Version of libwww found! ****
This library only supports libwww up to version 5.76. You seem to have
version 5.805 installed, which has not yet been tested by the package author
for compatibility.
not sure if I am getting this problem because of libwww version.
Also, please check my answers below..

apache 1.3.37
mod_perl-1.29
expat-1.95.8-8.2
expat-devel-1.95.8-8.2
perl v5.8.8
MySQL-server-4.1.21-0 (from rpm)
MySQL-client-4.1.21-0 (from rpm)
MySQL-devel-4.1.21-0 (from rpm)

I would use MySQL v5.x. See Slashcode's INSTALL for more information.
Anand: In the install doc it was mentioned that MySQL v4.1.x and 5.x are good and neverthought it might be the problem. I even tried after upgrading MySQL to MySQL-server-5.0.24a, and it is still giving the same warning.

I installed MySql server, client and devel rpms first and then
installed mod_perl and apache with following commands.
perl Makefile.PL APACHE_SRC=/usr/download/apache_1.3.37/src DO_HTTPD=1 \
>USE_APACI=1 PERL_MARK_WHERE=1 EVERYTHING=1 \
> APACHE_PREFIX=/usr/local/apache
make
make test
make install
Didnt notice any errors with the installation except couple of errors
with make test as described in the install doc

you should be able to apachectl configtest and have it come out w/ no
errors at that point.
you should be able to fire up httpd and get the stock
apache-is-installed page, too, at this point.

Anand: Yep. I got the default apache page and accessed the sample perl scripts (my own).


When I tried installing slash (R_2_5_0_94), received following messages

Why R_2_5_0_94?
Anand: that is the version mentioned at slashcode.com as the most recent stable version.

Writing Makefile for Slash::Apache::Banlist
Writing Makefile for Slash::Apache::Log
Writing Makefile for Slash::Apache::TemplatePages
"strip" is not defined in %Slash::Constants::EXPORT_TAGS at
/usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi/Slash/Constants.pm
line 44

Did you check Slashcode's SF bug list for this?
Anand: couldnt find any bug related to this :(
Did you grab a checkout of CVS HEAD and do a make install and see if
you still see the 'strip not defined' problem?

Anand: got the same error with the tip of the code.

You might want to grab CVS HEAD, or latest t-tag, and use that. I just
did an install on my laptop w/ the latest CVS-HEAD and it make
installs and install-slashsite's a brand new working site just fine.
Anand: I tried both head and the latest t-tag and got the same error message.
by any chance did you install Fedora core 5 on your laptop?
that is what I am using.


Talk is cheap. Use Yahoo! Messenger to make PC-to-Phone calls. Great rates starting at 1/min.
-------------------------------------------------------------------------
Take Surveys. Earn Cash. Influence the Future of IT
Join SourceForge.net's Techsay panel and you'll get the chance to share your
opinions on IT & business topics through brief surveys -- and earn cash
http://www.techsay.com/default.php?page=join.php&p=sourceforge&CID=DEVDEV_______________________________________________
Slashcode-general mailing list
Slashcode-general@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/slashcode-general