Hi All,
I am trying to install Slash on Fedora Core 5 with following versions,
apache 1.3.37
perl v5.8.8
MySQL-server-4.1.21-0 (from rpm)
MySQL-client-4.1.21-0 (from rpm)
MySQL-devel-4.1.21-0 (from rpm)
I installed MySql server, client and devel rpms first and then installed mod_perl and apache with following commands.
perl Makefile.PL APACHE_SRC=/usr/download/apache_1.3.37/src DO_HTTPD=1 \
> APACHE_PREFIX=/usr/local/apache
make test
make install
Didnt notice any errors with the installation except couple of errors with make test as described in the install doc
Then installed Bundle::Slash after installing CPAN update. Got some error with Time::Calendar and had to do a Force Install.
When I tried installing slash (R_2_5_0_94), received following messages
Writing Makefile for Slash::Apache::Banlist
Writing Makefile for Slash::Apache::Log
Writing Makefile for Slash::Apache::TemplatePages
"strip" is not defined in %Slash::Constants::EXPORT_TAGS at /usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi/Slash/Constants.pm line 44
install didnt stop here, and received a successful installation message.
When I tried creating a slash site, received following error,
# ./install-slashsite -u virtslash
"people" is not defined in %Slash::Constants::EXPORT_TAGS at /usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi/Slash/Constants.pm line 29
Can't continue after import errors at /usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi/Slash.pm line 29
BEGIN failed--compilation aborted at /usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi/Slash.pm line 29, <DATA> line 139.
Compilation failed in require at ./install-slashsite line 19, <DATA> line 139.
BEGIN failed--compilation aborted at ./install-slashsite line 19, <DATA> line 139.
I couldnt find any message in the archives with the similar problem. can some one please help me to troubleshoot this.
Thank you

Do you Yahoo!?
Next-gen email? Have it all with the all-new Yahoo! Mail.