#2658 Blob downloads not initiated properly

Other
closed-fixed
Apache (40)
5
2003-09-30
2003-09-22
No

Using the blob plugin:

If a file is attached to a document (using the BLOB
plugin) and a link to the file is created using SLASH
tags, the filename is not passed to the browser. Users
are confused when they follow links to attached files
and their browser attempts to download "blob.pl".

My Windows browser will successfully launch Acrobat for
PDF files and Word for DOC files. It will attempt to
download blob.pl for ZIP files or other files that it
doens't recognize.

I don't know enough about Apache or HTTP to fix this,
but I'm sure it is something simple.

I'm using Slash R_113.

Discussion

  • Chris Nandor

    Chris Nandor - 2003-09-22
    • assigned_to: jamiemccarthy --> pudge
     
  • Chris Nandor

    Chris Nandor - 2003-09-24
    • status: open --> open-fixed
     
  • Chris Nandor

    Chris Nandor - 2003-09-24

    Logged In: YES
    user_id=3660

    It is not simple, no, because the original design did not store the
    original filename in the DB. This has been rectified, will be
    committed soon.

     
  • Chris Nandor

    Chris Nandor - 2003-09-25

    Logged In: YES
    user_id=3660

    Committed.

     
  • Chris Nandor

    Chris Nandor - 2003-09-25
    • assigned_to: pudge --> cmdrtaco
     
  • Rob Malda

    Rob Malda - 2003-09-30
    • status: open-fixed --> closed-fixed
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks