Connecting to O365 Lync Online

Help
2014-01-04
2014-01-05
  • Eric Pullen

    Eric Pullen - 2014-01-04

    Still having issues connecting to Lync Online with latest release for Adium
    (1.17.3). I get an error of

    20:50:05: (GLib): (20:50:05) sipe: ucs_ews_autodiscover_cb: can't detect
    EWS URL, contact list operations will not work!
    20:50:05: (Libpurple: sipe) ucs_ews_autodiscover_cb: can't detect EWS URL,
    contact list operations will not work!

    Thanks,
    Eric

     
    • Stefan Becker

      Stefan Becker - 2014-01-04

      Without a debug log I can only guess that your Office 365 account name and your email address are different.

      You can specify your email address in the account options tab. Please note that you'll need to compile the latest code for this to work, because in older versions the SIPEAdiumPlugin account handling code is broken.

      Please also check if your debug log shows an EWS Autodiscover redirect response (feature request #71). I'm planning to implement support for that in 1.18.0.

       
      • Stefan Becker

        Stefan Becker - 2014-01-04

        It would be nice if you could give feedback on feature request #71.

         
      • Eric Pullen

        Eric Pullen - 2014-01-05

        Here is the logs from the connection attempt. It does get connected, but never gets the list via UCS.

         
        • Stefan Becker

          Stefan Becker - 2014-01-05

          Is this log from 1.17.3 or git HEAD compiled by yourself? Unfortunately in the Adium version this is not detectable from the debug log.

          If it is from 1.17.3 then it is no surprise that it doesn't work, because EWS responds with a <RedirectAddr> node and there is no code to handle it.

          If it is from git HEAD then for some reason the new code doesn't work, although it looks correct to me. I can't debug this myself, because I don't have an account with a different email address. A breakpoint at line 132 in sipe-ews-autodiscover.c should show why this doesn't work.

          BTW: can we please move this discussion to feature request #71 where it belongs?

           
        • Stefan Becker

          Stefan Becker - 2014-01-05

          As this happened before: please make sure to checkout the branch mob to get the latest git code.

           
  • Eric Pullen

    Eric Pullen - 2014-01-05

    Sorry, it is with 1.17.3. I will try and get HEAD and compile it for Adium and see if that works.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks