No alias set for Office Communicator contacts

Jon Ball
  • Jon Ball

    Jon Ball - 2013-10-03

    I just setup pidgin-sipe to connect to my company's Lync server. After connect, all my contacts and groups are retrieved and added to the buddy list.

    All contacts in the buddy list have no alias set. I can right click on each contact, and go to Get Info. In the Buddy Information screen, I can see the contact's display name and e-mail address. Is there a way to change the buddy list display to show the display name rather than the alias? Or is there a way to automatically set the alias based on the display name?

    pidgin 2.10.3 (from Ubuntu 12.04)
    pidgin-sipe 1.17 (compiled from source)

    Any help would be appreciated. Thanks.

  • Stefan Becker

    Stefan Becker - 2013-10-03

    If you set an empty alias then it will be replaced with the display name.

  • Austin Beam

    Austin Beam - 2014-04-10

    I know this is a bit old now, but wanted to post an additional note for the benefit of anyone encountering this issue. It might seem a bit trivial, but if someone could resolve this issue pidgin-sipe would be even more awesome.

    In my case, when a new contact is added with a blank alias, the alias must temporarily be changed to something first before an empty alias will result in the display name taking the place of the alias. In other words, my steps for adding a new contact are:
    1. Add the contact
    2. Change the contact's alias to something temporary (e.g. temp)
    3. Enter a blank alias for the contact
    -> At this point, the contact's display name replaces the blank alias.

    Hopefully my explanation is clear. In an ideal world, the contact would show up initially with the display name as its alias.


    Last edit: Austin Beam 2014-04-10
  • Andrzej Zalewski

    Hi guys, I have some input on this.

    I compared the behaviors of:
    Ubuntu 13.10 with Pidgin 2.10.7 and sipe 1.16.1
    Ubuntu 14.04 with pidgin 2-10-9 and sipe 1.17.3

    In both cases I used the official Ubuntu repositories to install the software and configured my account in the same way:
    Protocol: Office Communicator
    Login: COMPANYDOMAIN\userid
    Password:** :)

    On Ubuntu 13.10 pidgin will display a buddy name (as if taken from the Nickname property displayed when hovering over the buddy) as display name if no alias is specified.
    On Ubuntu 14.04 pidgin will display blank names for all my buddies if no alias is specified.

    Now digging a bit deeper. On first start of pidgin a hidden directory called .pidgin is created in my home directory. Within this directory one of the created files is named blist.xml and contains all buddies and groups as fetched from the MS Communicator server. There is one major difference between the file on the two systems. On Ubuntu 13.10 each buddy has a tag <alias>Lastname, Firstname</alias> (taken from Nickname I assume) where in Ubuntu 14.04 the corresponding tag is empty like so: <alias></alias>.

    When I use Get Info on a buddy on either of the two systems there is no Alias field displayed on Ubuntu 13.10 but on Ubuntu 14.04 there is an Alias field displayed with no value so from that point of view Ubuntu 14.04 pidgin behaves properly.

    If I use the proposed workaround on Ubuntu 14.04 of setting an alias to 'tmp' first and then clearing the alias i do get the Nickname to appear next to the buddy icon. However, if i now go to my Ubunty 13.10 the corresponding buddy is called 'tmp'!

    Surely the intent cant be to make us give all of our (close to hundred) buddies new aliases when this information is available in other fields?

    This is a major bug and a regression. Someone made a really bad change to the code and apparently got away with it. This need to be fixed with priority. I would expect pidgin to display the alias only if present and if not present use the nickname for display without persisting it in the blist.xml file as an alias. Perhaps even provide an account setting allowing us to specify which field we would like displayed if no alias is specified.


    Last edit: Andrzej Zalewski 2014-08-16
  • Stefan Becker

    Stefan Becker - 2014-08-16

    1.17.x is obsolete. So the first thing you should try on Ubuntu 14.04 is the latest release 1.18.3.

    If this doesn't fix your problem then I would suggest the following:

    • install 1.17.3 (or later) on Ubuntu 13.10. Does it show the problem now?
    • install 1.16.1 on Ubuntu 14.04. Does the problem go away?

    If the answer to both questions is yes then you have narrowed the problem down to SIPE. Clone the SIPE git repository and start a bisect with

     $ git bisect start 1.17.3 1.16.1

    git log --oneline 1.16.1..1.17.3 | wc -l shows 162 commits, so you should be able to narrow it down to the offending commit in 8 steps.

    Otherwise the bug must be in Pidgin or Ubuntu.

  • Andrzej Zalewski

    Thank you Stefan for the prompt response. Which PPA can/should I use to get access to 1.18.x packages? Synaptic does not allow me to select any newer version in Ubuntu 14.04 than the one I specified above.

  • Stefan Becker

    Stefan Becker - 2014-08-16

    Please follow the Opensuse Build Service link on the SIPE home page and then select Ubuntu 14.04 from the list on the right hand side.

  • Andrzej Zalewski

    Thank you very much Stefan, Using the Utopic Unicorn (active development) package pidgin-sipe 1.18.2-1 resolves the problem.


  • Stefan Becker

    Stefan Becker - 2014-08-17

    AFAIU Jakub took up the maintainer job for the Debian and Ubuntu packages. Maybe he can answer what it would take to push updates to older releases, if it is possible at all.

  • Drinyth

    Drinyth - 2014-09-11

    I'm having the same problem as others this morning. I setup my MS Communicator account via the Sipe plug-in and after successfully connecting, all of my contact names were blank. After setting an alias to a temporary name and then removing that alias, the proper contact name appeared.

    I'm running the latest version the Sipe plugin for Windows:

    pidgin 2.10.9 (Windows 7)

    • Jack

      Jack - 2014-09-25

      I had the same problem. After installing pidgin-sipe-1.18.2, the names are displaying properly.

      • Stefan Becker

        Stefan Becker - 2014-09-25

        There is nothing in the log between 1.18.2 and 1.18.3 that has anything to do with buddies:

        e95fd46 Release 1.18.3 -- Bug Fixes III
        c6cc3c1 Fix #258: V&V call gets rejected when IPv6 is enabled (III)
        728c348 media: ignore IPv6 candidates (cherry picked from commit 23b1c820a5dfdb3
        69f700c OBS: sync with latest versions
        262915b Fix #258: V&V call gets rejected when IPv6 is enabled
        c7153f8 Fix #259: HTML response to EWS autodiscover triggers libxml2 assert (II)
        717286c Fix #259: HTML response to EWS autodiscover triggers libxml2 assert
        acd8338 Fix #257: Windows 7: SIPE crashes after a minute (II)
        d52e8e1 Fix #257: Windows 7: SIPE crashes after a minute
        a604126 mingw: improve crash information reporting

        There are fixes for EWS autodiscover. If you are on Lync 2013 with contact list migrated to UCS then not being able to perform EWS autodiscover will disable your buddy list completely, i.e. all of them will show up as offline.

  • Alex G

    Alex G - 2014-09-17

    FWIW my users are seeing this as well.

  • Jason Graves

    Jason Graves - 2015-11-13

    I'm not sure if this will help anyone else but it worked for me. I installed pidgin and configured it to use the same SIP protocol/connection for Office365. I then added an alias for all my contacts listed in both offline and online mode. Next I disconnected and reconnected my account to Office365 in Empathy and the contact alias names where displayed.

  • Brian

    Brian - 2015-12-16

    I just ran across this today under Debian with a new install of pidgin 2.10.11 and pidgin-sipe 1.18.2. I found this thread first. What I did was log out and exit pidgin. I then opened the blist.xml file and completely removed all of the alias tags since they were empty. I then restarted pidgin and logged in again. All of the alias fields were properly filled in after connecting. May be some sync timing issue when logging in for the first time.

  • Theodoros Apazoglou

    Hello guys,

    i had the same problem. I wanted to do Brian's (above) solution, so i logged out from Pidgin and exit, i deleted the alias tag only for 1 contact at the blist.xml to test. When i logged in again ALL the contacts were ok, they took the alias from the dsiplay name.

    Probably what Brian said, sync timing issue...
    It's a long run migrating your company's Windows laptop into a fully function Fedora... :)

  • Rajath V S Moodithaya

    Hello all,
    Had the same problem. The solution Theodoros gave worked for me perfectly.

  • Roland

    Roland - 2016-05-12

    I had the same problem. Fix was simple, just log out, restart Pidgin, log back in. Like Theodore said likely a sync issue.
    Debian Jessie
    Pidgin 2.10.11
    SIPE 1.18.2

  • Stefan Becker

    Stefan Becker - 2016-06-22

    If I interpret commit 29fbc04 correctly then this issue is probably fixed in git HEAD.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks