Sipe 1.15 didn't work for me, but 1.14 did.

Help
2013-05-30
2013-06-05
  • Dave Godbey

    Dave Godbey - 2013-05-30

    Running Windows 7, and pidgin 2.10.7, and sipe 1.15 didn't work. What happened was it appeared that connection was made, but after a dozen seconds or so, the pidgin client reported a "Read error."

    After lots of googling and seeing discussions of users successfully rolling back to previous sipe versions, I tried rolling back to 1.14, and it worked! Installed no sspi version.

    Anyone know what might be going on? Something bad happen in version 1.15, or am I missing a configuration parameter, or ...?

     
  • Stefan Becker

    Stefan Becker - 2013-05-31

    I wonder why we waste our time maintaining a FAQ page when obviously nobody reads it...

     
    • Dave Godbey

      Dave Godbey - 2013-05-31

      Thanks Buddy. You want to point out to me what on that FAQ page addresses my issue? I read the FAQ and unfortunately there is nothing there to help me. Do you want to help me? Do you want me to help you? Or should I just keep using 1.14?

       
      Last edit: Dave Godbey 2013-05-31
  • Dave Godbey

    Dave Godbey - 2013-05-31

    Checking the internet for others sharing my problem, I find discussions of environment variable, this one, NSS_SSL_CBC_RANDOM_IV from http://linuxindetails.wordpress.com/2012/04/26/use-pidgin-sipe-plugin-on-windows-7/, and missing dlls, from this site, http://vandropratama.wordpress.com/2012/06/01/pidgin-client-installation-for-windows-and-configuration-for-lync/. Any of this relevant to me? How do I know but try them all, and I did.

    There were even discussions out there about how users had to roll back from sipe version to earlier ones. I'd provide them here but I grow weary of retracing my googling activities from yesterday. As you know, when I rolled back to version 1.14, I succeeded. And by the way, of the 4 users on my team who use Windows 7, none of them could use 1.15. And there are at least two more in my organization who tried and failed. I shared my info about 1.14, but maybe they are using two IM clients, Pidgin without SIPE for our jabber client, and M$ IM client for the Lync stuff.

    So, Stefan, I did my homework before I posted yesterday. I have to admit that I'm offended that you jumped to the conclusion that I DID NOT do my homework before posting here. I will however, give you the benefit of the doubt since perhaps most people do not do their homework before posting in these forums.

    Perhaps in the future you might want to handle your users a bit gentler since I'm sure (I think) you would rather keep them using this product that you put so much of your life into rather than throwing up their hands in frustration...

    So, what do you want me to do?

     
  • Stefan Becker

    Stefan Becker - 2013-05-31

    Oh my, somebody got out of the wrong side of the bed today.

    • You updated from SIPE 1.14.x to SIPE 1.15.x on Windows
    • That means you must have updated to Windows Pidgin 2.10.7
    • I see three sections in the FAQ which apply to your situation, of which one even has the error message in the title.

    Conclusion: you didn't read the FAQ.

    Search engine references are useless. All pages outside our project site are either out-of-date or contain false/misleading information.

     
  • Dave Godbey

    Dave Godbey - 2013-06-03

    You referring to NSS_SSL_CBC_RANDOM_IV=0? Tried that. Did not help version 1.15. 1.14 needs it, though, and that did work. Anything else you think I missed?

    Search engine references are useless? Tell you what. If it weren't for search engine references, I would not be using SIPE at all.

    Btw, thanks for creating SIPE. I appreciate the efforts of people like you who create these products at no cost to people like me, I really do! And SIPE version 1.14 works for me just fine.

    As to version 1.15 - it's too bad you just cannot respond to my questions rather than reaching the conclusion as to what I did or did not do. Good day!

    Thanks again.

     
    Last edit: Dave Godbey 2013-06-03
  • Stefan Becker

    Stefan Becker - 2013-06-03

    SIPE 1.14.x was compiled against Windows Pidgin 2.10.6, which was using NSS 3.12.x. That version doesn't have NSS_SSL_CBC_RANDOM_IV. So your statement about 1.14.x is wrong.

    Please prove with a --debug log (pastebin & post URL here) that the "Read Error" is not caused by the NSS security fix, i.e. that the log doesn't show that the SSL connection is simply dropped by the server after a few message exchanges.

     
  • Dave Godbey

    Dave Godbey - 2013-06-05

    I'm using Pidgin 2.10.7, not 2.10.6. Am I still wrong? You absolutely sure that there isn't a problem because you compiled SIPE against 2.10.6 and I'm using 2.10.7?

    In any case, don't worry about it. I have spent as much time on this issue as I can, and now it is time to move on. Cheers!

     
  • Stefan Becker

    Stefan Becker - 2013-06-05

    Windows Pidgin build changed major components between 2.10.6 and 2.10.7. SIPE 1.15.x definitely doesn't work with 2.10.6 as it has been compiled against 2.10.7. I would be surprised if SIPE 1.14.x works correctly with 2.10.7 as it has been compiled against 2.10.6.

    This is not an issue of the libpurple API, but of other components changed, e.g. NSS 3.12.x -> 3.13.x.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks