Compiled Adium SIPE 1.17

Help
2013-10-03
2014-01-06
  • Eric Pullen

    Eric Pullen - 2013-10-03

    Is there going to be a compiled version of the new version for Adium as well or do I need to build from source?

    Eric

     
  • cihusss

    cihusss - 2013-10-29

    That would be nice, maybe 1.17 fixes "read error" on Mac OSX Mavericks.

     
    Last edit: cihusss 2013-10-29
    • Stefan Becker

      Stefan Becker - 2013-10-29

      No it won't, because it is not a problem caused by SIPE.

      As for the compilation: the Adium maintainer hasn't sent me the binary. I don't have a Mac, so I can't compile it.

       
  • Stefan Becker

    Stefan Becker - 2013-11-06

    The Adium SIPE maintainer just send me the new zip file and I have uploaded it to the 1.17.0 release directory.

     
    • Shaun Burdick

      Shaun Burdick - 2013-11-11

      Downloaded the 1.17 binary and it was missing the Office Communicator account type.
      Still had the SIP/SIMPLE though.

       
      Last edit: Michael Lamb 2013-11-14
  • Michael Lamb

    Michael Lamb - 2013-11-14

    Can you send the debug log? Usually when the OCS account type doesn't show up, it means that the plugin didn't load. Without the debug log, we can't troubleshoot why.

     
    • imper

      imper - 2014-01-06

      Hi,

      I have the same issue that account type does not appear on the list with latest plugin(1.17.3) and latest Adium (1.5.9). Possibly minimum OS version is 10.8 to use the plugin. I am still on 10.7.

      Is there by chance 10.7 version available or written procedure how to compile it by myself on OS X?

      ws01:MacOS ulta$ otool -L SIPEAdiumPlugin
      SIPEAdiumPlugin:
      /System/Library/Frameworks/Cocoa.framework/Versions/A/Cocoa (compatibility version 1.0.0, current version 20.0.0)
      /System/Library/Frameworks/Kerberos.framework/Versions/A/Kerberos (compatibility version 5.0.0, current version 6.0.0)
      @rpath/libnss3.dylib (compatibility version 1.0.0, current version 1.0.0)
      @rpath/libsoftokn3.dylib (compatibility version 1.0.0, current version 1.0.0)
      @rpath/libfreebl3.dylib (compatibility version 1.0.0, current version 1.0.0)
      @rpath/libplds4.dylib (compatibility version 1.0.0, current version 1.0.0)
      @rpath/libplc4.dylib (compatibility version 1.0.0, current version 1.0.0)
      @rpath/libnssutil3.dylib (compatibility version 1.0.0, current version 1.0.0)
      @rpath/libsmime3.dylib (compatibility version 1.0.0, current version 1.0.0)
      @rpath/libnspr4.dylib (compatibility version 1.0.0, current version 1.0.0)
      /System/Library/Frameworks/Foundation.framework/Versions/C/Foundation (compatibility version 300.0.0, current version 1056.0.0)
      /usr/lib/libobjc.A.dylib (compatibility version 1.0.0, current version 228.0.0)
      /usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 1197.1.1)
      /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation (compatibility version 150.0.0, current version 855.11.0)
      /System/Library/Frameworks/AppKit.framework/Versions/C/AppKit (compatibility version 45.0.0, current version 1265.0.0)


      $ ./SIPEAdiumPlugin
      -bash: ./SIPEAdiumPlugin: cannot execute binary file
      $ file SIPEAdiumPlugin
      SIPEAdiumPlugin: Mach-O 64-bit bundle x86_64

      Binary is in:
      $HOME/Library/Application Support/Adium 2.0/PlugIns/SIPEAdiumPlugin.AdiumLibpurplePlugin/Contents/MacOS

      thanks,
      rafi

       
      • Stefan Becker

        Stefan Becker - 2014-01-06

        As the "macosx10.8" part of the release file name implies, the minimum requirement is MacOS X 10.8. That is the lowest version you can target with Xcode 5 on MacOS X 10.9.

        The build instructions can be found in src/adium/README.Adium.

         
  • Shaun Burdick

    Shaun Burdick - 2013-11-19

    Messaged you log.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks