#236 Crash when starting audio/video with pidgin-sipe

OBSOLETE_(1.17.x)
closed-fixed
nobody
None
Crash
5
2016-04-23
2014-03-07
PriceChild
No

Running debian sid, the entire application crashes when audio or audio/video is selected from a
pidgin-sipe contact's right click menu.

Backtrace is attached, output is as follows:

Pidgin 2.10.9 has segfaulted and attempted to dump a core file.
This is a bug in the software and has happened through
no fault of your own.

If you can reproduce the crash, please notify the developers
by reporting a bug at:
http://developer.pidgin.im/simpleticket/

Please make sure to specify what you were doing at the time
and post the backtrace from the core file. If you do not know
how to get the backtrace, please read the instructions at
http://developer.pidgin.im/wiki/GetABacktrace
/usr/bin/pidgin: line 10: 23284 Aborted /usr/bin/pidgin.orig $*

1 Attachments

Discussion

  • Stefan Becker

    Stefan Becker - 2014-03-07

    BTW: 1.17.x is obsolete, please don't report bugs against it.

    This crash is already fixed in git commit 5d687b4.

    You can work around this crash by installing libnice-gstreamer, gstreamer-0_10-libnice, or whatever package in your distribution provides .../gstreamer-0.10/libgstnice010.so.

    Closing as FIXED.

     
  • Stefan Becker

    Stefan Becker - 2014-03-07
    • status: open --> closed-fixed
     
  • PriceChild

    PriceChild - 2014-03-07

    Hmm ok thanks, I have gstreamer0.10-nice installed on debian sid but no dice.

     
  • PriceChild

    PriceChild - 2014-03-07

    I've just built 1.18 and tried again, I seem to hit the same issue though the backtrace is subtly different...

     
  • Stefan Becker

    Stefan Becker - 2014-03-07
    1. you have to build git HEAD, because the fix hit the git repo after 1.18.0
    2. please make sure that your gstreamer-0.10 is correctly configured by executing gst-inspect-0.10 nice (see also this forum discussion)
     
  • PriceChild

    PriceChild - 2014-03-07

    Reverted back to sid's .17 and indeed, moving ~/.gstreamer-0.10/registry.x86_64.bin resolved the issue for me! (gst-inspect previously reported '0 features' but now shows 2.)

    It's now reporting "Encryption settings of peer are incompatible with ours." so now I have a new problem as they say.

    Thank you very much for you assistance and speedy replies, it has been very much appreciated.

     

Log in to post a comment.