#165 Cannot compile pidgin sipe 1.12.0

closed-invalid
nobody
5
2011-10-08
2011-10-07
Anonymous
No

Hello,

Im working on a fresly installed ubuntu 11.04 system, i followed the install directions on the install page but everytime i run the ./configure command i get following error.

checking that sizeof(uuid_t) is 16... configure: error: in `/home/jens/Downloads/pidgin-sipe-1.12.0':
configure: error: sizeof(uuid_t) is not 16

Please notify the SIPE developers.

Anyone has any idea? I attached the config.log

Thank you

Kr,

Discussion

  • Comment has been marked as spam. 
    Undo

    You can see all pending comments posted by this user  here

    Anonymous - 2011-10-07

    Cofig.log of error trying to run ./configure

     
  • Jakub Adam

    Jakub Adam - 2011-10-07

    Hello,

    configure:12913: gcc -o conftest -I/usr/local/include/glib-2.0 -I/usr/local/lib/glib-2.0/include ...
    conftest.c:23:18: fatal error: glib.h: No such file or directory

    There is a problem finding GLib header files. It is weird that compiler uses /usr/local/include as a search path instead of /usr/include where distro headers are normally located. Did you compile glib from sources yourself? If so, installation probably did not place the headers to /usr/local/include.

     
  • Comment has been marked as spam. 
    Undo

    You can see all pending comments posted by this user  here

    Anonymous - 2011-10-07

    Hello,

    No i had some trouble installing GLib, but then i installed the packages described on the install page and the problem was gone. So i thought GLib was installed with does packages.
    I did not install it myself from source.

    Greeting.

     
  • Comment has been marked as spam. 
    Undo

    You can see all pending comments posted by this user  here

    Anonymous - 2011-10-07

    I forgot, I installed it via the package manager. GLib2.0-dev package.

    I attached the installed files paths

     
  • Comment has been marked as spam. 
    Undo

    You can see all pending comments posted by this user  here

    Anonymous - 2011-10-07

    Paths of the installed files for GLib2.0-dev

     
  • Jakub Adam

    Jakub Adam - 2011-10-07

    /usr/include/glib-2.0/glib.h is in the right place. I wonder why /usr/local/include is searched instead. Check the output of

    pkg-config --libs --cflags glib-2.0

    Anyway, this will be a problem with system installation, not a bug in SIPE.

     
  • Comment has been marked as spam. 
    Undo

    You can see all pending comments posted by this user  here

    Anonymous - 2011-10-07

    This is my output. I'm pretty new the linux scene, so no idea what i just ran :)

    jens@Rd-Ubuntu:~$ pkg-config --libs --cflags glib-2.0
    -I/usr/local/include/glib-2.0 -I/usr/local/lib/glib-2.0/include -L/usr/local/lib -lglib-2.0

     
  • Jakub Adam

    Jakub Adam - 2011-10-07

    pkg-config says configure script where it should search headers for particular library. You have glib headers installed at /usr/include but pkg-config reports they are located at /usr/local/include which is obviously wrong. You can check contents of /usr/lib/i386-linux-gnu/pkgconfig/glib-2.0.pc, that is a file from which pkg-config reads its data. It should begin with lines similar to these:

    prefix=/usr
    exec_prefix=${prefix}
    libdir=${prefix}/lib/i386-linux-gnu
    includedir=${prefix}/include

    Probably you will have prefix=/usr/local instead of prefix=/usr, in which case you should report to Ubuntu maintainers that glib-2.0-dev package is buggy. You can change prefix in the file by hand as a temporary solution until fix is released.

    If prefix is correct, then for now I have no idea what else can be wrong.

     
  • Comment has been marked as spam. 
    Undo

    You can see all pending comments posted by this user  here

    Anonymous - 2011-10-07

    Unfortunately this file is correct, and the first 4 lines are identical to yours. This would mean there's a bug in pkg-config? Would be strange.

     
    Last edit: Anonymous 2014-07-28
  • Jakub Adam

    Jakub Adam - 2011-10-07

    Hmmm, last thing I can think of, install strace and run

    strace -o trace.log pkg-config --libs --cflags glib-2.0

    and on created file trace.log execute

    cat trace.log | grep ^open

    you will see a list of files that pkg-config reads or tries to read

    open("/lib/libglib-2.0.so.0", O_RDONLY) = 3
    open("/lib/libpopt.so.0", O_RDONLY) = 3
    open("/lib/x86_64-linux-gnu/libc.so.6", O_RDONLY) = 3
    open("/usr/lib/charset.alias", O_RDONLY) = -1 ENOENT (No such file or directory)
    ...
    open("/usr/lib/pkgconfig/glib-2.0.pc", O_RDONLY) = 3

    See if there isn't any other .pc file that is loaded instead of the right one.

    Sorry I can't provide more help with this, try some Ubuntu forum.

    Anyway, as this is not a bug related to SIPE, this report should be closed as invalid.
    @stefan, anibal - please close this or give me rights to do so.

     
  • Stefan Becker

    Stefan Becker - 2011-10-08

    You have (at some point in the past) compiled SW, e.g. glib-2.0, yourself and installed it. By default autoconf uses /usr/local as prefix to avoid overwriting system headers. configure/gcc also looks under /usr/local/include for headers. My guess is that you have a 64-bit system, but the glib-2.0 version is most likely installed as 32-bit version.

    Please clean everything out under /usr/local and use "apt-get install xyz-dev" to get the CORRECT development headers for your system.

    Closed as INVALID.

     
  • Stefan Becker

    Stefan Becker - 2011-10-08
    • status: open --> closed-invalid
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks