#14 setField() returns false while field exists

closed
None
5
2008-01-11
2007-02-14
No

Hello,
I am evaluating SimpleTest for use with our site. Everything looks great except for WebTestCase which gave me a fatal error in the bet tar ball. The CVS code works kinda:

I am filling out a registration form which contains <select> tags. It seems that the setField() does not fill out the <select> fields of the form.

I have prepared some sample code (17 lines) and attached it to this . Please keep in mind that I am using:
PHP 4.4.4 (cli) (built: Nov 1 2006 18:12:33)
Copyright (c) 1997-2006 The PHP Group
Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies

Discussion

  • Gardner Bickford

    Test script which demonstrates error

     
  • Perrick Penet

    Perrick Penet - 2007-12-27

    Logged In: YES
    user_id=292377
    Originator: NO

    I had a look at your HTML source code. The <option> tags are never closed and that's what is blocking SimpleTest web tester. Please make sure you use the complete syntax <select><option></option></select> if you want to carry on using SimpleTest web tester ;-)

    Hope it helps !

    Yours,
    Perrick

     
  • Perrick Penet

    Perrick Penet - 2007-12-27
    • assigned_to: nobody --> pp11
    • status: open --> pending
     
  • SourceForge Robot

    Logged In: YES
    user_id=1312539
    Originator: NO

    This Tracker item was closed automatically by the system. It was
    previously set to a Pending status, and the original submitter
    did not respond within 14 days (the time period specified by
    the administrator of this Tracker).

     
  • SourceForge Robot

    • status: pending --> closed
     

Log in to post a comment.