Here is a brief summary of all the actions I took based on your numerous suggestions last night. Thank you so much - you guys are amazing!!!

1) git commit 26be4eb of libsigrok fixed the segfault

(if you had a bug tracking system you could close that now - sorry,

couldn't resist :-)

2) AX clone works for Joel on current commit -

he can officially fob me off now :-)

3) fx2lafw-cwav-usbeesx.fw built with sdcc 3.10 by Joel

(vs the one built by me using sdcc 2.9.0)

made no difference in outcome (the files diff, however!)

4) uwe_ also has a USBee SX, which works fine for him.

His bcdDevice is 16.b5 - mine is 4.23

5) I have taken an image of the PCB of my device.

What is the best way to get it to you (it is 9 MB)?

6) I installed sigrok on a different PC (Kubuntu 12.04 32-bit) - same result

7) Tried to up #define MAX_RENUM_DELAY_MS 3000 in hardware/fx2lafw/fx2lafw.h

a) this header file is in include/ in my installation, not in hw/

b) this header file does not contain a #define MAX_RENUM_DELAY_MS

in fact, I did a grep on the whole directory tree obtained from

sigrok-firmware-fx2lafw-0.1.0.tar.gz -

there was no MAX_RENUM_DELAY_MS anywhere -

am I using a wrong version???

Thanks again for all your help!!!!!!!!!!