Shairport disappears on iphone frequently. App needs to be closed/reopened.

Help
2013-10-14
2016-06-18
  • slapshot1285

    slapshot1285 - 2013-10-14

    I would really appreciate some help trying to figure out this issue.

    I use Shairport4W to play music via airplay from my iphone 5 to my PC. I have had an issue where Shairport disappears from my iphone as an airplay option frequently and the only fix tends to be closing the Shairport app and reopening it. Of course this means that I can play a song one minute, and the next minute I can't because it's as if the airplay server is just gone (it's not displayed on the phone.)

    I have had the issue for several months now but never used to for over a year. I have tried everything I can think of including turning off the firewall, updates, power settings (standby, etc.) metadata and multimedia controls and nothing helps. I even clean installed Windows 7 and installed nothing else but that only worked the first day. I've since tried Windows 8.1 hoping it was the OS and some bug but still he same issue. I have no know network connection issues. My WiFi works perfectly. The computer is hardwired with Ethernet and logging a 30 minute PING to it shows 0% packet loss and no other red flags.

    I am going crazy because I have an entire computer dedicated to being an airplay receiver for my iphone music and it doesn't work. Please help!

    Thank you so much in advance.

     
    Last edit: slapshot1285 2013-10-14
    • Rilwan

      Rilwan - 2014-07-05

      Even I had the issue of disappearing Airplay from my iPhone.
      Make sure you have IPv6 enabled in your WiFi properties.. and you may run Shairport4w as an administrator.
      Thats how I fixed my problem.

       
  • Andy Rhine

    Andy Rhine - 2013-11-24

    I had to allow mine through the firewall manually. It showed twice.

    Press start, type "firewall" then select "allow an app through the firewall"

    Find shareport4win in the list and put checks in all the boxes. Relaunch and try again.

    Andy

     
  • Nessly

    Nessly - 2014-09-25

    I still encountered the issue described above. I was running Windows 7 x64-bit. I tried the following with no success:
    -run profile as administrator
    -run application as administrator
    -turn off firewalls/antivirus/malware protectors

    Only after upgrading my computer to Windows 8 did the issue go away. I'm even using the same antivirus/malware protectors as I did when running Windows 7.

    I'm not sure if the issue was Windows 7 or another application I had installed, but since I've been running Windows 8, I haven't had any connection drops after hours of use.

     
  • benjaminv

    benjaminv - 2014-11-09

    Hi, I have exactly the same problem than you. I have seen the problem comes from iOS devices and not from computers which have iTunes.

    When the device has disappear on my iPad/iPhone, I can see Shairport4w devices on computers which have iTunes. I have also tried solutions written above and it does not work. The only solution for me, and I hope for the moment, is to create a .bat file which close and launch Shairport after an inactive period.

    An other solution, if your computer is only dedicated to Shairport is to buy a Raspberry and to install a solution like Volumio to have Airplay. With the money you will save in electricity, you can easily buy a raspberry ;)

    By the way, I stay interrested by a solution for the problem exposed. Thanks to everyone who could help us.

     
  • Frank Friemel

    Frank Friemel - 2014-11-14

    Shairport4w announces its service through Apple Bonjour. In case it appears correctly in your iTunes but doesn't on your iPhone/iPad then this is probably an issue with your Router which doesn't handle ipv6 correctly. Updating the Firmware of your Router may help. Additionally your can install "Discovery" from the App-Store on your iPhone/iPad which may help you to reveal such problems

     
  • benjaminv

    benjaminv - 2014-11-16

    Hi Frank and thank you for your answer.

    I have given a static IP to my computer so I don't use DHCP. Can it be a problem ?

    I have also checked my router and it is up to date. I have also try to find your app but I don't have found it. Is it a discover ip app ? I use Fing app to do this.

     
  • Frank Friemel

    Frank Friemel - 2014-11-16

    Static IP is no Problem. Please try to temporarily switch off "ipv6" in your Router Settings and see if it helps. Don't forget to reboot your router after you've modified the Settings.

    Here's the link to the App I mentioned:

    https://itunes.apple.com/de/app/discovery-bonjour-browser/id305441017?mt=8

    It lists all available Bonjour Services in your network. Shairport should appear in the list under _raop._tcp

     
    Last edit: Frank Friemel 2014-11-16
  • TigerB

    TigerB - 2015-03-10

    I think I finally may have found a solution to this problem.

    Uncheck certain ALGs in router firewall: Enter your router setup by typing in your router ip in your browser (here's how to find your router ip) and configure the router firewall. Under Application Level Gateway (ALG) Configuration UNCHECK the settings for IPSec (VPN) and SIP.

     
  • TheOneill

    TheOneill - 2016-06-14

    I am experiencing the same problem as the one described in the original slapshot1285 message : After a fresh shairport4w start, I can see and select it as an Itunes speakers, then stream music on it without any problem. But after a while it disappears from the speakers list and I need to start it again. If music streaming is in progress, it will not stop, but if I uncheck the speaker, it disappears.
    I tried to run it as an admin but the behaviour remains the same.
    I checked with Bonjour Browser : Right after shairport4w start it appears in the list like this :
    Type: _raop._tcp. Name: 00278E9E9C9D@NINA
    which is normal I guess, then after about 5-10 minutes it disappears. If I quit the app then restart it, it comes back for a while. The PC running shairport4w is running Windows 10.

    Thanks for the dev effort, appart from this, it works pretty well and seems quite stable !

     
  • Frank Friemel

    Frank Friemel - 2016-06-17

    can you provide a log file ( see shairport options )? Maybe we can wire a particular log file event to your problem

     
  • TheOneill

    TheOneill - 2016-06-18

    Yesterday I tried 2 things : IPv6 activation (on the router and on the PC running Shairport) and deactivation of additional network cards (one virtual card used by virtual box which is installed on this computer, the other one is a BT gateway). With these 2 changes, noticed that the server no longer disappears from the list of Airbplay speakers. I will check to understand which one of the 2 modifications had an influence on the problem I had.

    Lionel

     
    Last edit: TheOneill 2016-06-18

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks