Does it start w/o -D from the command line?  


On Thu, Dec 6, 2012 at 5:32 PM, Paul Schmehl <> wrote:
I'm working on upgrading the FreeBSD ports and I've run into a strange
problem.  My startup scripts fail for the server and the sensors.

Even if I start them from the commandline they refuse to daemonize.

I'm not sure what changed.  These scripts worked fine in version 0.7.0.

For example:

I get this when trying to start sguild from the rc.subr startup script that
worked with 0.7.0:

# /usr/local/etc/rc.d/sguild start
Starting sguild.
/usr/local/etc/rc.d/sguild: unknown directive '/usr/local/bin/sguild'.
Usage: /usr/local/etc/rc.d/sguild
/usr/local/etc/rc.d/sguild: WARNING: failed to start sguild

If I try to start it from the commandline, it starts, but it does not

# /usr/local/bin/sguild -D
% ^C
[root@buttercup4 /usr/ports/security/sguil-server-update/sguil-server]# ps
-auxw | grep sguild
root    42536  0.0  0.0  9128  1452   0  S+   10:29PM   0:00.00 grep sguild

Even the -h option fails:

# /usr/local/bin/sguild -h

I'm not getting any error messages, so it's hard to know where to begin.
Any suggestions would be appreciated.

Paul Schmehl, Senior Infosec Analyst
As if it wasn't already obvious, my opinions
are my own and not those of my employer.
"It is as useless to argue with those who have
renounced the use of reason as to administer
medication to the dead." Thomas Jefferson
"There are some ideas so wrong that only a very
intelligent person could believe in them." George Orwell

LogMeIn Rescue: Anywhere, Anytime Remote support for IT. Free Trial
Remotely access PCs and mobile devices and provide instant support
Improve your efficiency, and focus on delivering more value-add services
Discover what IT Professionals Know. Rescue delivers
Sguil-devel mailing list

sguil - The Analyst Console for NSM