SourceForge has been redesigned. Learn more.

7-zip doesn't want to take over file extensions

  • saucefrog

    saucefrog - 2013-08-11

    I installed 7-Zip with admin rights on Windows 7, but it won't take over the file extensions I choose in the options. For example I click on 001, 7z, lha, rar, zip, then "OK", but the icons of archived files still show the usual Zip icons of Windows. When I have a look at the options again, all the boxes are unticked.

    Why won't 7-Zip take over the extensions, even with admin rights?

  • saucefrog

    saucefrog - 2013-08-31

    Nobody here that can tell me how you installed it on Windows 7 and assign the various archive format extensions with two accounts, one being the admin and the other a simple user?

  • Chris

    Chris - 2013-09-01

    That does seem strange. Could be all sorts of reasons, possibly a restart after choosing the ext options might help. There might be something guarding against such changes - you could try switching off your anti-virus beforehand.

  • saucefrog

    saucefrog - 2013-09-01

    I'm using Microsoft Essentials as anti-virus software. I used Windows XP before with only one user account (being also the admin) and never had problems assigning the format extensions.

    Now on Windows 7, I tried both the user and admin account, but 7-Zip simply doesn't leave the boxes ticked. I could try reinstalling, but I don't know if I should do it as an admin or user?

  • Richard

    Richard - 2013-09-02

    When you select which formats to associate with, are you selecting from the left column (username) or the right column (All Users)? I've found when running as Admin to set using the All Users column on the right and it works perfectly me.

  • saucefrog

    saucefrog - 2013-09-06

    I guess you mean the columns in the security options of Windows? That's not what I'm trying to do, my problem is with the format extensions in the options window of 7-Zip.

    I think I solved the problem by now. I reinstalled 7-Zip with the user account (had to type in the admin password to execute the installation), then right-clicked the 7zFM.exe icon and opened/ran the software with admin rights. I then could set the format extensions in the options and it kept them ticked when closing the window.

    I haven't restarted my computer yet, but I guess it should work now.

    Last edit: saucefrog 2013-09-06
  • Ghost Templar

    Ghost Templar - 2013-09-07

    I'm pretty sure Richard was referring to the option in 7-Zip at Tools -> Options..., in the System tab, which shows the file associations and the left column has your username and the right column has all users (and are labelled as such). I know because I had the same problem and fixed it by setting the associates in All users only.


Log in to post a comment.