7z e "LiteTouch.iso" -oF: -y Fails to copy files in <ISO>\Boot

  • Chuck

    Chuck - 2014-02-15


    I'm trying to automate the process of creating litetouch flash drives for use with my deployment share.

    I'm using 7-Zip 9.20 32-bit on Windows 7 32-bit machines with 4 gigs of RAM; specifically, a Dell OptiPlex 3010.

    I've read the 7z help file and many websites in search of a solution; however, I still haven't found a solution.

    The drive is formatted as NTFS using a DiskPart script, then I invoke the 7z command: 7z e "LiteTouch.iso" -oF: -y, which extracts successfully without throwing an exception; however, the F:\Boot folder is empty. Keep in mind I've tried many configurations, even without the -y flag.

    Normally, the way I go about this is right-clicking the ISO file and select "Extract Files" from the contextual menu, then type F: in the destination field. All files are present and accounted for when using this method.

    Any tips, suggestions, or insight is welcome.



  • Igor Pavlov

    Igor Pavlov - 2014-02-16

    Call "7z x" instead of "7z e".

  • Chuck

    Chuck - 2014-02-17

    This solution solved my problem. Thanks for the feedback!

    In my experimentation, I neglected to try just the "x" option. I always combined it with the "e" options, which produced an error.



    Last edit: Chuck 2014-02-17
  • ryan

    ryan - 2014-04-13

    How do i fix this problem on my windows 7?
    I encountered this problem when I want to do with an application of data compression. usually successful, but now can not anymore.
    I saw this article on my computer "7Zip standalone console has stopped working"
    spech : windows 7 ultimate, 32 bit.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks