Windows 8 - file associations and integrated shell context menu are not applied

Help
Anonymous
2013-06-05
2013-07-08
  • Anonymous - 2013-06-05

    When installing 7-Zip on a Windows 8 Pro (64 bit) OS the file associations are not being applied -

    .zip stays with the OS (default state),
    7z, bzip2, gzip, tar, wim, xz - all have no file association on all tests.

    Tested with version 4.57 (32 bit) (our standard version for Windows XP and 7) then downloaded version 9.20 (32 and 64 bit) and 9.30 alpha (64 bit). User Account Control (UAC) is turned off the user account is a domain account with local admin privileges.

    For the 32 bit of 9.20 i tried "run as administrator" same result. The 64 bit version is an msi so no right click run as option was available. Tried shift right click "run as a different user" on both the 9.20 and 9.30 alpha 64 bit msi's and then entered the same username and password as i was logged in with - this allowed the integrated shell context menu to work but still no file association.

    We are looking to deploy 7-zip msi via GPO in the near future, if we cant find a solution to this issue this don't look like a possibility. Is this an issue with the way the installation file talks to the OS, how thinks changed with windows 8 on this front?

    Any help would be appreciated.

     
  • Igor Pavlov

    Igor Pavlov - 2013-06-05

    7-Zip installer doesn't install extension associations.
    You can use 7-Zip/Tools/Options (run as administrator).
    Or create .reg file.

     
    • Anonymous - 2013-07-08

      Hi Igor,
      Why do you not give the option in the installer to set file associations? This is normal for most applications and makes the tool difficult to use for novice users.

       
  • Anonymous - 2013-06-07

    Hi Igor,

    Why do you not give the option in the installer to set file associations?

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks