Help! How do I undelete or restore a deleted file?

  • Deputy Dawg

    Deputy Dawg - 2014-03-26

    Good morning, I have an urgent problem and I am asking for help...

    I accidentally deleted a very valuable file from inside a 7-zip archive. It was my only copy of this file! I thought there was an undelete function but I can't find this in any of the menus.

    I tried Control + z but it didn't work. I ran Piriform Recuva, but that didn't find the file either. I looked in the Recycle Bin, but it's not in there.

    Please, is there any way to recover this file?

  • Igor Pavlov

    Igor Pavlov - 2014-03-27

    You can try to use software for deleted files in NTFS.
    In 7-Zip 9.20 there is such feature.
    Run 7-Zip File Manager with admin rights.
    Open root folder (most top folder)
    Open \. folder
    Open your drive
    Look to [Deleted] folder and try to find that archive (version of archive before change) there.

    • Deputy Dawg

      Deputy Dawg - 2014-03-28

      Igor, thank you for your reply. I have version 9.25 alpha. Should I install 9.20 instead?

      I have followed your instructions but I think my file has been erased beyond recovery. I opened 7-Zip using admin rights but I don't see the root folder anymore. It disappeared when I deleted the file inside it. Unless you know a way to recover a file that was deleted from within the root folder, I fear that my file may be lost. I now appear to have an empty zip file with no content.

      I carried out a deep scan using Piriform Recuva but my lost file wasn't listed.

      Thank you for your help, I appreciate you must be very busy...

  • Igor Pavlov

    Igor Pavlov - 2014-03-29

    1) you need 7-Zip 9.20 to see [Deleted] folder.
    2) you can go root folder, if you press "Backspace" key (or "UP" button) several times.

    3) also you can try to open in 9.20 with admin rights:


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks