Jacky - 2013-10-09

Hi experts,
I managed to successfully combine 25 split 7-zip files, which presented me with a .7z file. However, when I try to right-click it to unzip, I got the "7 zip cannot open file as archive" error.

I try to do a test on all the 25 files (selecting all the files and right-clicking the "Test Archive" option) and got a success, even the total file size is correct.

However, if I tried to right-click and test the extracted .7z file, it also gave an error.

I also tried running the following commands, but also encountered errors:

@@@@@@@@@@@@@@@@@
C:\Program Files\7-Zip>7z l -slt O:\TEMP\Workshop_AccessMgmt_Part2.7z > MyList.txt

C:\Program Files\7-Zip>7z x O:\TEMP\Workshop_AccessMgmt_Part2.7z > MyX.txt

C:\Program Files\7-Zip>type MyX.txt

7-Zip [64] 9.22 beta Copyright (c) 1999-2011 Igor Pavlov 2011-04-18

Processing archive: O:\TEMP\Workshop_AccessMgmt_Part2.7z

Error: Can not open file as archive

C:\Program Files\7-Zip>dir MyList.txt
Volume in drive C is System
Volume Serial Number is 46EF-29F1

Directory of C:\Program Files\7-Zip

09/10/2013 02:47 PM 163 MyList.txt
1 File(s) 163 bytes
0 Dir(s) 130,392,252,416 bytes free

C:\Program Files\7-Zip>type MyList.txt

7-Zip [64] 9.22 beta Copyright (c) 1999-2011 Igor Pavlov 2011-04-18

Error: O:\TEMP\Workshop_AccessMgmt_Part2.7z: Can not open file as archive

Errors: 1

@@@@@@@@@@@@@@@@@

Any help is greatly appreciated.

Regards,
Jacky