LZMA2 compression processs

DJ7115
2013-06-05
2013-06-29
  • DJ7115

    DJ7115 - 2013-06-05

    I am trying to achieve following setting.

    Compression Level: Ultra
    Compression Method: LZMA2
    Dictionary size: 1024MB
    Word size: 273
    Solid Block size: 1GB
    CPU threads: 2

    By running following command.
    7z.ex a –mx9 –m0=LZMA2:D1024M –ms=1g –mmt=2 DESTI.7Z *.VHD

    Issue: But i am not getting desired result and compression gets stuck at 14%, is there is a issue in my command or what is command should i use to achieve above settings for compression.

    I am using 7z 64- bit version 9.20

     
    Last edit: DJ7115 2013-06-06
  • Shell

    Shell - 2013-06-29

    Your command is correct, otherwise 7-Zip would have immediately shown you an error. It is difficult to identify the error without having the files you are trying to compress and some other details. Please, look at the progress messages: do you stuck on the very first file or not? Which size does that file have? Which operating system do you have?

    You may have problems with the storage. If the files are on your hard drive, check it for physical damage. The fastest way to do that is to copy the file you get stuck at. If you have an external drive, first check whether it is connected reliably. If you compress files from the network, check your connection and (if you can) the host's hard drive.

    This may also be the problem in 7-Zip. You may try to use another version (check 9.30 alpha for example), or reducing the dictionary size and the number of threads (as a benefit, you will get somewhat better compression with -mmt=1). Memory allocation and multithreading are often the sources of programming errors.

    The problem may be triggered by a faulty memory module or improper overclocking. If you get other programs "hanging", this is definitely the case. Besides, a one-gigabyte dictionary requires about 12 gigs of memory for compression, some of which are not used during an ordinary work with your computer (unless you run a server or certain professional software). Return all hardware settings to their default values and check if the problem persists.

    By the way, you are probably using word size 64, since this is the default value. You need to write something like -m0=lzma2:d30:fb273 to adjust the word size.

     
  • szfong

    szfong - 2013-06-29

    you need to remove the -mx9 command as it creates a set of settings which overrides the other switches. such as dictionary size fastbytes, etc. in v9.20, the method becomes LZMA dict size is 64 MB fastbytes is 64 and is using the defaults for "Ultra" compressing.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks