Incorrect Command Line when opening .rar

Matt Anon
2008-11-02
2012-12-08
  • Matt Anon

    Matt Anon - 2008-11-02

    Whenever I attempt to open .rar files I get a "Incorrect Command Line" message. I can open .zip files. Also, if I right click and go to 7zip in my right click menu, i can open the file. Just not when I double click. Help?

     
    • Skylar Sutton

      Skylar Sutton - 2008-11-17

      I get that message with any file type that gets associated with 7Zip. Right clicking and using the context menu to open it works though...

      Anyone have a solution?

      Running Vista Ultimate x64

       
      • TC

        TC - 2008-12-26

        I have this issue on windows server 2008 as well..(for the most part Vista api's so i think same issue as the OP)
        Right click from context menu works

        This bug has been in here for while it was the the beta before the release of 4.62 as well

        does any one know how we can see what the exact cmd line that is used  when dbl click on a known file extensions
        -I have made the associations using
        -control panel-default program (set your default program , set file file etc)
        -7Zip file manager-Tools-System

        One other item of note I first set the associations using the control panel app, then when i went to
        7Zip file manager-Tools-System associations NONE of the associations  i had set where selcted as check boxs
        so there is some other issue here as well the 7_zip should prolly read from the registry hive that the control app uses

         
    • Tyler Mitchell

      Tyler Mitchell - 2008-11-17

      Hi Matt, Skylar,

      How did you create the association – did you use the 7-Zip File Manager, or did you double-click the file and set the association through Windows?

      Skylar, are you running 64-bit 7-Zip or the 32-bit version? (Or are you using both, like me? :-)

      Kind regards,
      Tyler

       
    • egerhardt

      egerhardt - 2008-12-05

      I've been getting this same issue with a clean install of 7-Zip 4.57 in Windows XPSP3, primarily with multi-part RAR archives.  In my case the problem was definitely related to file associations.  When I first tried to open a RAR file, I set the association through Windows after double-clicking the RAR file, and saw the error from that point forward.  Right-clicking and going through the context menu worked, as Skylar says.  When I checked the GUI under Tools / Options / System, I had no file associations set (all boxes empty) - after setting them (I just used Select All), multi-part RAR files opened fine.

      I guess it'd be nice if the program gave a clearer error message, or if it handled the association set through Windows a bit better, but it's an easy fix once you know where the problem is coming from.

      Cheers
      Eric

       
    • TC

      TC - 2008-12-26

      OK just more update here If I look in HKCR for .zip I se default is "7-Zip.zip"
      then I look at HKCR/7-Zip.zip I see the following
      Windows Registry Editor Version 5.00

      [HKEY_CLASSES_ROOT\7-Zip.zip]
      @="zip Archive"

      [HKEY_CLASSES_ROOT\7-Zip.zip\DefaultIcon]
      @="C:\\Program Files\\7-Zip\\7z.dll,1"

      [HKEY_CLASSES_ROOT\7-Zip.zip\shell]
      @=""

      [HKEY_CLASSES_ROOT\7-Zip.zip\shell\open]
      @=""

      [HKEY_CLASSES_ROOT\7-Zip.zip\shell\open\command]
      @="\"C:\\Program Files\\7-Zip\\7zFM.exe\" \"%1\""

      well if open a dos window and try

      C:\Users\Administrator>"C:\Program Files\7-Zip\7zFM.exe" XXX.zip

      I does open & works BUT here is the ODD thing if change that
      @="\"C:\\Program Files\\7-Zip\\7zFM.exe\" \"%1\""
      to nonsense
      @="\"C:\\Program Files\\7-Zip\XXX.exe\" \"%1\""

      I still get the incorrect command line err message with the string 7-Zip in the title bar
      hmm is this really a 7zip message or is vista using different hive for "shell\open\command" to use for the dbl click

      any one ???

       
    • TC

      TC - 2008-12-26

      OK Fixed
      I went back to
      -control panel-default program -Associate a File or Protocol with a program
      changed .zip to Notepad.exe then dbl click the .zip notepad tried top open it BUT HKCR/.zip was not change :(
      I then  changed the association back to 7zFM.exe (using the browse button) and all it good

      and I tracked down in the registry what gets changes

      Windows Registry Editor Version 5.00

      [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.zip]

      [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.zip\OpenWithList]
      "MRUList"="dcba"

      [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.zip\OpenWithProgids]
      "CompressedFolder"=hex(0):
      "7-Zip.zip"=hex(0):

      [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.zip\UserChoice]
      "Progid"="Applications\\7zFM.exe"

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks