cannot find the codes that works with archive

gms 2000
  • gms 2000

    gms 2000 - 2010-02-10

    I got that error (no 2) with the following command-row on win xp(?) running the cmd-version of 7z 4.65
    7z x tmp\ -aoa -x!7z.exe
    Any suggestions,

  • gms 2000

    gms 2000 - 2010-02-11

    Found the problem: 7z.dll missing

  • Jack McElwee

    Jack McElwee - 2010-10-22

    I run an HP Pavilion Home Premium PC with Windows 7. I use 4 browsers- Firefox 3.6.11; Opera 10.63; IE9 (Beta) and Google Chrome ----63 (latest version). I just got 7-Zip 4.65 and I finally got my unzipped files into an SFX (Whatever that is!) Archive. When I try to extract and/or open a specific file with the suffix sdf which I have associated with 7-Zip GUI; 7-Zip FM (which let me start archive); 7-Zip Console and 7-Zip.exe and RealPlayer which is where I like to take my games to play them. None of it works and I keep getting a blasted dialogue box telling me that 7-Zip cannot find the code to use with Archives. I have tried everything and still I get that same message and if I right click a file and hit Open or Open With or anything in the 7-Zip drop down boxes I get 'Cannot open file. C:\ID of file I am trying to open- Copy .swf as archive. How do I find out what code works with my Archives? Thanks a lot- keimanzero

  • Mark Holtkamp

    Mark Holtkamp - 2011-10-20

    Same problem.

    Seems as if there are many people with the same problem with no answer thus from the developers that I can locate.

    "7-Zip cannot find the code that works with archives." Is the error I get as well. I just jumped from XP SP3 to Win 7 Ultimate 64 bit trying to cure this problem. I can get this to work on other machines, but not the laptop I use. I am currently trying to use Sardu to create a multiboot pen drive for computer service. As far as this laptop is concerned, 7-zip has never been able to run on it XP or win 7. It's an ASUS G50VT core2duo T9400.

    I assume at this point that there are some memory controllers or chipsets that 7-zip does not handle correctly. I will answer in advance: Yes, the program is run as administrator, yes the 7z.dll is present in the folder with 7z.exe. Yes there is plenty of available memory for the operation.

    After years of repairing & building computers this isn't just a crank call. Since your software is packaged with several other packages, that makes all of them totally useless to those of us that cannot run your software on our machines. Please help us out here. Any and all real help would be appreciated. Thank You.

  • Igor Pavlov

    Igor Pavlov - 2011-10-20

    That error means that 7z.exe can't find 7z.dll.

    Maybe you have another copy (in other folder) of 7z.exe without 7z.dll, and you called that another copy.

    7z.exe i > info.txt
    and show info.txt here.
    Try also to specify full path for 7z.exe.

  • Mark Holtkamp

    Mark Holtkamp - 2011-10-20

    No such luck. this is a clean install of Windows 7 as of this afternoon. The program Sardu calls the files within its folder. Both files are present just as what happened in XP. This is a very easy program to use. No install, just extract to its own folder and rock. As to why there would be an issue of 7z.exe not being able to find 7z.dll within the same folder even if there were another reference in the path on this system (assuming the file didnt exist and the path did, which is not the case) would be interesting to me. Files called should be looked for in the same folder by the os first before the OS tries to look at defined paths.

    Here is the resulting info you requested:
    7-Zip 4.62  Copyright (C) 1999-2008 Igor Pavlov  2008-12-02



    The program that calls it has no way to specify a full path to it from the user. Tried two different versions of their program, as well as replacing the 7z files with newer versions to see if that were the problem. I deleted the folder and extracted the latest beta with the same results one more time.

  • Igor Pavlov

    Igor Pavlov - 2011-10-20

    Maybe Sardu calls 7z.exe with some unusual way.
    What is full path to 7z.exe?
    You can download extra package from
    and copy 7za.exe to 7z.exe in your Sardu folder.

  • Mark Holtkamp

    Mark Holtkamp - 2011-10-20

    I downloaded and installed 7z922-x64.msi. Then I moved out the old 7z.exe & 7z.dll, replaced them with copies of 7z.exe & 7z.dll from the x64 installation folder. The extraction of the ISOs completed properly.

    The actual path to the files (non defined as far as the OS is concerned) is c:\Sardu\

    Last night I had tried this same thing with v9.22 32 bit exe and dll under XP and it wouldn't work… Go figure.

    I know others out there have this same problem, but as to why it happens I am baffled. The x64 solution isn't going to work for everyone either. Thanks for your help! I was beginning to think I wasn't going to get anywhere with it!

  • Scott Lincoln

    Scott Lincoln - 2014-06-03

    Igor, Others:
    I am having a similar problem here at my office. We have multiple computers and log in through a server, so we have roaming profiles. I have scripts that I frequently run that download compressed files, then extract them via command line (using python calls). I have had success using this method for a few years now.

    We have one user, however, who gets this error. The "7-Zip cannot find the code that works with archives." I have searched for this error and it seems related to the .dll file not in the folder. But we don't have that DLL in the folder yet multiple other users can get the script to run just fine.

    Just for the heck of it, we put the .dll in the folder, and it made no difference.

    EDIT: We also tried to run the command line "7z.exe i > info.txt" as both users. One user would get data in the file, the other user would return a blank file (blank other than the headers). Even though I am almost certain we tried this late last year when the problem was first noticed, we tried again to put the .DLL in the folder. This time it worked. I'm really not sure why this time and not last time. I specifically remember reading this thread last time and remember the .DLL advice. What is odd to me is that for most users, the .DLL doesn't need to be in there. Just this one user requires it. Any thoughts on how that makes sense?

    Last edit: Scott Lincoln 2014-06-03
  • Igor Pavlov

    Igor Pavlov - 2014-06-04

    Just put 7z.dll and 7z.exe to one folder.

  • Rex Panton

    Rex Panton - 2015-08-31

    Any known problems with Windows Server 2012 Essentials and 7z? Was working fine on previous versions of Server and all XP, Vista, 7, 8, 8.1 and 10. Moved system to from Windows 7 to Server 2012 and now gets Error: 7-zip cannot find the code that works with archives. 7z.exe and 7z.dll both exist only one time on the drive, and remain in the same folder where they were when working. Have reviewed the threads previous to mine regarding same message, but see nothing I haven't tried. Thoughts?

    • Igor Pavlov

      Igor Pavlov - 2015-09-01

      It means that some 7zg.exe or 7z.exe can't load 7z.dll.
      How do you call 7-Zip?

  • Kurtis Lininger

    Kurtis Lininger - 2015-11-23

    This is just a suggestion:
    1) Make sure the 7z.exe and the dll are both 32bit or both 64bit.
    2) if 32bit doesn't work, try 64bit


Log in to post a comment.