unsupported compression method

sww
2010-03-25
2017-05-08
  • sww

    sww - 2010-03-25

    Hi,
    I'm using 7zip from a while and it was all ok with it. (I've it updated to ver 4.65)
    Just today I've got a problem.
    A contact send a zip archive with two pdf inside.
    I can see the zip and opening it with 7zip I can see the pdf, but if I try to extract them I got
    "unsupported compression method" error

    I thought it was a broken archive,
    but using Winzip it works

    I then tried to use 7zip 9.12 beta but same problem

    Can you help with it ?
    Thanks in advance

     
  • chornobyl

    chornobyl - 2010-03-25

    Run

    7z l -slt archive.zip

    and paste here

     
  • Igor Pavlov

    Igor Pavlov - 2010-03-25

    There are two possible reasons:
    1) Unsupported method (check "Method" column in 7-zip file manager).
    2) Bad ZIP headers in archive. Ask person that have created that archive to use "GOOD" zip sofware.

     
  • sww

    sww - 2010-03-25

    Hi chornobyl

    here's the output

    7-Zip 4.65  Copyright (C) 1999-2009 Igor Pavlov  2009-02-03

    Listing archive: ver.zip


    Path = IT_9B2870243T000-00_4.pdf
    Folder = -
    Size = 108977
    Packed Size = 104792
    Modified = 2010-03-24 21:50:20
    Created =
    Accessed =
    Attributes = …..
    Encrypted = -
    Comment =
    CRC = 5D4834FA
    Method = Deflate
    Host OS = FAT

    Path = IT_9L1871423T000-00_4.pdf
    Folder = -
    Size = 109604
    Packed Size = 105411
    Modified = 2010-03-24 21:50:20
    Created =
    Accessed =
    Attributes = …..
    Encrypted = -
    Comment =
    CRC = 068A2FC2
    Method = Deflate
    Host OS = FAT

     
  • Igor Pavlov

    Igor Pavlov - 2010-03-25

    Probably it's error in ZIP headers.
    Ask contact about sofware that was used to create that archive.

     
  • sww

    sww - 2010-03-25

    Hi ipavlov

    the compression Method, as on the list, is Deflate

    about the software, the originating one could be bad,
    but the files in the archive can be extracted by Winzip
    and meantime I've done another test,
    if I copy the zip in another PC that has Win7, the 7zip continues to give error but using the built-in support in Win7 works and this too can extract the files

     
  • Igor Pavlov

    Igor Pavlov - 2010-03-25

    WinZip and Win7's ZIP don't check some fields in headers. 7-Zip checks them.

    It works so.
    There is ZIP software (from Developer-1)  that doesn't follow ZIP standard for 100%.
    1) User-1. uses that software to create "bad" archives and send them to User-2.
    2) User-2 (like you) uses 7-Zip to extract these archives. User-2 sees error and sends information to User-1 about problem.
    3) User-1 writes to Developer-1 about problem.
    4) Developer-1 fixes software.

    That way 7-Zip allows other ZIP software Developer's to fix problems.

     
  • sww

    sww - 2010-03-25

    Hi ipavlov,

    you're correct and it is this way among tech people,

    it's not always this way among end users,
    they often don't even know where the tool come from;
    asking them to contact support is often out of mind.

    And my customer only know that he cannot read archives from that paricular contact using 7zip but it works using winzip.

    I will try a way around,
    I will ask to get info from software used from User-1
    and try then to contact the software developer

    May be you can have a look at the zip and point me to the right thing to tell them ?

    Thanks

     
  • sww

    sww - 2010-03-25

    Hi,

    meantime I've done a search for "corrupt zip header file"
    and found this one http://www.diskinternals.com/zip-repair/
    that (in this case) has helped me.

    If fixes the zip archive and I'm now able to extract files with 7zip

    Hope this help others

    Best Regards

     
  • Igor Pavlov

    Igor Pavlov - 2010-03-25

    Maybe that bug was already fixed by Developer-1.
    And user-1  just  uses some old version of sotware.
    In 90% cases such error means that
    "bad values in local header or information in local header doesn't match information in central directory header".
    So you can write it to developer.

     
  • sww

    sww - 2010-03-25

    Hi ipavlov

    Thanks for the note

     
  • Susan Waters

    Susan Waters - 2010-03-27

    thanks for this!

     
  • shamabbas

    shamabbas - 2010-04-06

    I got this same error.
    I ziped file using 7Z and it compressed file with name cmp.zip.001.
    I renamed with cmp.zip and tried to unzip but gave me this error.

    # unzip cmp.zip
    Archive:  cmp.zip
       skipping: cmp.dump                unsupported compression method 14
    #
    quote]

    I also tried to use tool mentioned above http://www.diskinternals.com/zip-repair/
    It said file has repaired but again when tried to unzip nothing done.

    PLEASE can anyone help?
    p.s Does file size matter? its size is actually almost 3GB. :D

    Thanks in advance

     
  • sww

    sww - 2010-04-06

    Hi shamabbas

    I'm not an expert and only have basic needs, but having the file named xxx.001 usually means it has been splitted
    in this case you can't work on only a part but have all of them together to proceed with extraction.

    I tried to zip a large files using volume setted to FD and indeed it creates some part with extension .001, .002, .003 …..
    in this case if I test the first file - .001 - it is ok
    it I test others or if I rename first one .zip and test it, I got error

    The only problem, honestly, is that I wasn't able to extract the test file back from here ……

     
  • shamabbas

    shamabbas - 2010-04-07

    i actually Unzipped my file with name tf.zip.001 with command " 7za e tf.zip.001 " it extracted and gave me my file but also gave this error message

    Processing archive: tf.zip
    Extracting  tf.dump     Unsupported Method
    Sub items Errors: 1

    file is there in the directory but i got some other issues while uploading where was needed to.. it says that file has corrupted :(
    I'm not sure if my file was just corrupted or when zipped it didnt get to zip fully orrr 7zip is not properly working :(
    Thanks for your reply though "swwork" :D Cheers

     
  • sww

    sww - 2010-04-07

    Hi shamabbas

    thanks to you to exchange knowledge.

    Here's my other two cents,

    I did the same as before (zipping a big file using volume setted to FD and having the three parts .001, .002, .003)
    this time I extracted the file using the command line as you say
    7z e archivename.001
    and all is ok
    so zipping using volumes and unzipping them is working

    about the extensions, I tried to zip a file using volume setted as DVD,
    this time I got only one file named …001
    so having just one file with .001 extension could be correct

    about the size, you say your file is about 3 Gb, there shouldn't be any problem
    because if volume supports DVD setting should mean that 3 Gb is supported

    So the problem could be at first steps of  your file's life and it could be corrupt.

    Could you start from scratch, from the original file and try to zip it again ?
    Also, if you just have one file as output you could avoid using volume and have just a .zip file as archive

    Hope it helps
    Regards

     
  • shamabbas

    shamabbas - 2010-04-08

    Yes, I guess my file has been corrupted. I did get to extract but couldn't get to use it any more. And my Manager asked to leave it and is gonna do from begining, will zip again and then do whatever want to  :D

    7zip i wasnt aware of before but now il personaly use it cuz i found it very smart ;)

    Thanks alot for your help "swwork". greatly appreciatable!

     
  • Brian

    Brian - 2017-05-08

    fyi - I just got this same error on a zip I've viewed many times. After some time looking into the problem, I found that I had another instance of 7zip with this file open. After I closed it, the error no longer occurred meaning there was nothing wrong with the zip file or headers. You might check yoru system for unexpected 7zFM processes and end them. I hope this helps someone else.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks