Possible Bug? .7z Files with CRC errors prevent the remaining files from extracting.

Craig
2014-08-13
2014-08-17
  • Craig

    Craig - 2014-08-13

    I have a 14GB .7z file that I created (using 7-zip) about two years ago using "Store" compression so that I more quickly transfer one large file as apposed to several thousand smaller .jpg files. I tried to uncompress the entire file at once, at around 80% there were several hundred CRC errors. (I noticed decompressing .7z Store files makes it so that I cannot click Pause or Background because the wheel is endlessly spinning.) At 100%, when the files would usually copy from the Windows temporary folder to my desired location the program stops endlessly. There is no longer any CPU or disk activity coming from the 7-zip processes and the wait wheel endlessly spins when moved over the decompression status window.

    I found I could manually copy folders from the archive one at a time to my desired location. This worked until I reached the folders that had files with CRC errors. All 4 of 30 folders that had files with CRC errors were unable to be copied, at the end of the extraction the wheel just endlessly spins.

    Since the wait wheel endlessly spins and the Window does not respond at any time during .7z Store file decompression I am unable to scroll down the list of files with CRC errors to try and manually extract all but those files, though that would be a very tedious process. I am unable to press "Close" on the window and after several hours of waiting I just end the process using task manager.

    I tried installing the 9.34 x64 beta but ran into the same problems. Are there any workarounds? Does anyone know what the problem may be? I tried this archive on another machine with and AMD processor and ran into the same problems.

    Disclaimer: I realize I will not be able to recover the files with CRC errors and if I could they would be unviewable. My goal is to extract the remaining files.

    One other update, I did notice if I manually browse over to the Windows TEMP directory I am able to copy the successfully extracted files to my desired location but I am thinking this may be some kind of bug that would be useful to report. I tried an alternative open source archiver that supports .7z and was able to extract the files without resorting to grabbing them from the temp folder before ending the process.

    Windows 7 x64
    Intel Core i7-3770
    16GB RAM

    Edit: Oops I meant to post this to the Help forum but I am unable to move it now that it has been posted, sorry about that.

     
    Last edit: Craig 2014-08-13
  • J.J. Lee

    J.J. Lee - 2014-08-13

    All were operated in 7-Zip x64 9.34 alpha.
    LZMA2/16MB/32/2GB

    I have a 12.7GB "Windows Vista-LZMA2-16M-32-2G.7z" file created today (2014/8/13).
    I got a CRC error around 100% on decompressing it. Anyway it didn't stop forever. I could move on.

    Windows 7 x64 with SP1
    Intel Core i7-3770
    16GB RAM

    Is there a way to provide a log file (or anything else) to help locating this problem?

    I just tried to compress another Windows XP VM with the same settings. It worked perfectly without any error.

    Thanks

     
    Last edit: J.J. Lee 2014-08-14
  • Craig

    Craig - 2014-08-13

    I would like to provide some kind of log file as well. To have it stop forever at 100% when there are any CRC errors seems like a bug.

     
  • Craig

    Craig - 2014-08-16

    Any update on this Igor? I am wondering if this is a known bug or if there is some kind of workaround?

     
  • Igor Pavlov

    Igor Pavlov - 2014-08-17

    1) don't use drag and drop.
    And it will not use Temp folder.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks