7zip support for Windows 8

  • Robert Ferrari

    Robert Ferrari - 2011-11-07

    When will 7zip support Windows 8/Windows Server Next? Will a new version be required?

  • Jake Freiman

    Jake Freiman - 2012-06-13

    It would be great to have some type of Windows 8 Metro x86/x64/RT version of 7-Zip available. :)

  • Mark van Tilburg

    7-zip works on Windows 8, however the context menu is not installed correctly.

    How to fix this:
    Go to the folder where 7-zip is installed, rightclick: 7zFM, choose run as administrator.
    In 7-zip go to options, to the 7-zip tab, toggle the checkbox with "integratie 7-zip to context menu" and press apply. Context menu is working again.

  • Pernat1y

    Pernat1y - 2012-08-20

    Context menus was installed successfully for me (Windows 8 x64)

  • Anonymous

    Anonymous - 2012-08-24

    It would be absolutely great to have a Metro/Modern-UI styled version of 7zip. I don't know much about programming - but I'm a Media Designer and could probably help to design the UI. Is there a programmer who is interested in getting this job done?

  • streetwolf

    streetwolf - 2012-09-02

    I've got a strange problem running 7-Zip under Windows 8 Pro x64 RTM.  Hope you can help.

    In order to be able to click on a zip file and then extract it's contents to a folder I have to set 7zFM.exe to run with Administrator rights via Properties | Compatibility.  However, when I do this the 7-Zip 'Open Archive' context menu does not work.

    When I remove Admin rights from 7zFM.exe the 'Open Archive' context menu works but I can no longer click on a zip and extract it's contents.  I get multiple messages for various files like this one:

    0    ERROR: Can not delete output file <file path is here>

    Interestingly, I get these same exact messages if I try to extract to a folder that is open by a running program.

    Keep in mind I can't use the 'Run as Administrator' context menu option because I am clicking on the zip file not running the 7-Zip GUI directly. My only option is to use compatibility mode to set Admin rights.

    I've had many programs that require Admin rights under Windows 8 then I ever had with Windows 7.

    Any thoughts/ideas on my problems?

  • streetwolf

    streetwolf - 2012-09-02

    Forgot to mention that I'm running 7-Zip 9.28 alpha

  • streetwolf

    streetwolf - 2012-09-02

    Windows 8 is driving me nuts. I got 7-Zip to work fine when I gave my user account full control over the folder I am extracting to. Why did I have to do this to get it to work? I never had to do this in Windows 7. I've run into all sorts of Administrator rights problems with W8.

    For example, the Registry Scanner from NirSoft. If you try the to Open the Registry on a key RS is displaying nothing happens. Either you have to run RS as Administrator or set RS to have Admin rights in compatibly mode. Once again I never had to do this in W7.

    Is it just me that is having these sort of Admin issues?

  • Lee Binder

    Lee Binder - 2012-09-16

    FYI, I just noticed one little thing in general not working in 7zip (64bit) in Windows 8 (64bit) incl. the latest alpha .29: context menu. 'Tools/ Options/ 7zip: integrate 7-zip into shell context menu' does simply not stick in Win 8 RTM, not even when 7-zip is run via right-click, run as admin. I also restarted Explorer via Task Manager, no difference. Oddly WinRar does not have that problem with its context menu in Windows 8 Explorer, so it's definitely a current 7-zip bug, at least of the 64bit version in a 64 bit Windows 8 (don't have a 32 bit Win8 at hand, sorry).

    I already informed Project Admin ipavlov.

  • Lee Binder

    Lee Binder - 2012-09-16

    strange forum software - cannot edit the posting I just made .. Anyway, markvt's approach (see above) did NOT work for me (7-zip latest versions stable/ beta/ alpha 64bit in Windows 8 RTM 64 bit, activated, all updates installed)

  • weshare

    weshare - 2012-09-22

    i'm using windows 8 x64 RTM and 7 zip 9.20. evrerything works well except that i cannot set file association in 7zip options.

  • Max

    Max - 2012-09-22

    file associations work as well, but as markvt has pointed out, even if you disable UAC, you still need to go into "Program Files", and run 7zFM "As Administrator", in order to create the needed system changes (file associations).

  • velhote

    velhote - 2012-12-24

    Right button Context menu NOT working on Windows 8 Pro, even after checking on the checkbox with "integrate 7-zip to context menu". Anyone knows how to solve that, or warn the programmers? Thanks.

    • Kim Tram

      Kim Tram - 2013-01-01

      I had the same issue with the context menu not appearing on my Windows 8 Pro computer. On my system, there was a permissions issue on the HKEY_CLASSES_ROOT*\shellex\ContextMenuHandlers\7-Zip registry key. The key didn't have an owner, and the Users group didn't have permissions to the key.

      I had the same symptoms as described in this other post: https://sourceforge.net/p/sevenzip/discussion/45797/thread/5f7f58dd. Once I resolved the registry permissions issues, I was able to get the context menu working.

      One odd thing I noticed was that my registry key permissions listed a "msiserver" user, but I have no such user on my computer.

      Last edit: Kim Tram 2013-01-01
    • Vincent Deconinck

      I had the exact same symptom (no 7-zip context menu when right-clicking on files or folders) while file association itself worked (upon double-click). I tried all proposed solutions (run as admin, check registry permissions) to no avail before realizing I had installed a 32-bit version of 7-zip while my Windows 8 was 64-bit !
      It might be obvious, but maybe this can help others...


      PS: To determine which version you have installed (the About box does not say it), check where your 7-zip folder is installed:
      - under "C:\Program Files" => 64-bit
      - under "C:\Program Files (x86)" => 32-bit

      • Travis Lange

        Travis Lange - 2013-02-20

        I don't know why I didn't think about that.... I knew I had it working in 8 pro before but I had to reinstall and when I installed 7-zip it hadn't worked since and it was starting to become a pita.

        thank you Vincent

      • Regis Rodrigues

        Regis Rodrigues - 2013-10-23

        Just once you noticed this, I found the specific 7-zip Download page (http://www.7-zip.org/download.html) and installed the appropriated version x64 to my system (Windows 8 x64). Before this, have tried several times to fix the context menu, as taught here, without success. Thanks for being obvious. ;)

        Last edit: Regis Rodrigues 2013-10-23
      • Calexico

        Calexico - 2014-02-24

        Thanks, Vincent! It's surprising, but it made all the difference!

  • Flat-twin

    Flat-twin - 2014-03-12

    Hi I also have a problem on windows 8.1 Pro x64 french with mediacenter.
    I have the context menu displayed but I can't do any action of it. I used the latest alpha version (9.32 x64 ) and I have all rights on my 7-zip installation folder. I also added the option to run as adminsitrator 7zG.exe and 7zFM.exe in there properties but nothing with right click works. I have to precise that I disabled my anti-virus (Avira antivir free) during installation and UAC is at it's lowest level (in configuration panel).
    However if I run 7zip as administrator (from the start menu for example) and then navigate to my files, I can create archives, unzip archives and so on by the buttons or the right-click inside 7zFM.

    In my context menu i have :
    - Open> (which doesn't give problems I think)
    - extract files...
    - extract here
    - extract to "folder"
    - add to archive...
    - add to "name.7z"
    - add to "name.zip"

    Exept for Open that I didn't really tested, the other doesn't work directly in windows explorer.
    However I can extract using drag and drop since I set my temporary folder to D:\temp (instead of windows temporary folder).
    I can't add files using drag and drop from windows explorer to an opened archive.

    I hope a solution will be found because it's a bit anoying even if I continue to use it because it's a great soft !!


Log in to post a comment.