Problems with 7-Zip 64-bit x64

  • Ken

    Ken - 2011-07-16

    Having some problems with 7-Zip 64-bit x64 Ver. 9.20 on Windows7 pro.
    If I double-click on a .rar file, I see a menu pop up quickly and then disappear.
    Next I run 7-Zip and it's half-dead. Click on "Info" or File->open and nothing happens. Tools->Options works but under System tab no file associations are selected. I select all and hit "Apply" or "OK" and an error message comes up: "An event was unable to invoke any of the subscribers"
    Using the screen far right pick-list, I am able to navigate to my folder with the .rar and extract works.
    I did an uninstall and reinstall and nothing changed.
    Anything else I could try to fix?

  • Igor Pavlov

    Igor Pavlov - 2011-07-16

    Yes, you can install 7-Zip 9.22 beta or 7-Zip 9.23 alpha .

  • Ken

    Ken - 2011-08-01

    I uninstalled 9.20 (x64) and note the C:\Program Files\7-Zip folder is gone, as expected.

    Next installed 9.22 beta and 7-Zip comes up showing a previously loaded archive (from 9.20).
    If I look at Options->System I have no files associated with 7-Zip. I select 'rar' and 'gz' + and click apply and error message comes up "An event was unable to invoke any of the subscribers" then the apply button is dim and no longer works.

    Click on File-> Open does nothing, but right-click on an archive and 7-Zip comes up okay.

    It might be settings are stored somewhere and got scrambled?

  • Anonymous - 2011-08-04

    Try run as administrator, then modify options, then it should work. Somehow installer does not do these settings correctly.

  • abagnale

    abagnale - 2011-08-04

    Run it as an administrator.. it would  not show you again this problem.

  • gratefully

    gratefully - 2014-03-31

    This advice worked for me! Thank you all for your dedication to helping us who know so much less. (at least about software, anyway!)


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks