7-Zip 9.32 alpha

2013-12-01
2014-07-30
<< < 1 2 3 4 > >> (Page 3 of 4)
  • Nicola Bressanin

    Hello Igor, we use and appreciate 7zip a lot so..thanks!
    We tought it would be nice to have an updated archiver comparison chart, so here it is http://www.polarmachines.com/docs/7z.ods

     
  • Alex Matsoka

    Alex Matsoka - 2014-01-12

    Игорь, простите, я по-русски напишу: пожалуйста, зарелизьте что нибудь более менее стабильное, чтобы по умолчанию алгоритм LZMA-2 был. Хоть ту же 9.22 бету, ей уже 2 года все пользуются. Я просто почему прошу - понимаете, люди же вумные стали, через 1 программисты, и знают что бета - плохо, а альфа - смерть, вообще. И что характерно, начальники. Если вам не сложно, я сам то не программист, а админ, и понимаю, что раз не далает человек, то причина есть у него. Просто чтобы уже LZMA-2 если он более-менее стабильный в вашей реализации стал фактичски стандартом для 7-zip. Или если я чего не понимаю, отпишите что там за сложности. С уважением.

     
    Last edit: Alex Matsoka 2014-01-12
    • Igor Pavlov

      Igor Pavlov - 2014-01-13

      I work only with latest version, that is alpha now.
      I don't want to update old 9.22 code.

       
  • Ron Burk

    Ron Burk - 2014-01-13

    Thank you for the new alpha! Giving 9.32 a try,

    a) the -sns option produces "not implemented", so I presume it isn't. However, it does at least let me manually backup streams. 9.20 when given a stream name like "test:strm" decides I've used a bad filename syntax.

    b) But oops, there's a bug. In c:\what\ever create a file called "c" and give it a stream called "strm". If I then ask 7z to archive "c:strm", it defies Windows/NTFS convention and reads the stream in the file "c". It should instead have tried to load the file "c:.\strm". From MSDN http://msdn.microsoft.com/en-us/library/windows/desktop/aa364404%28v=vs.85%29.aspx

    When there is an ambiguity about whether a one-character name is a drive letter or a file name, Windows assumes it is a a drive letter if the string following the colon is a valid path, even if the drive letter is invalid.

    Possibly silently backing up the wrong (and effectively hidden) file has some security implications. I wonder if there's a scenario where backup and restore leads to clobbering the victim's file with a stream I hid in a file I named after a drive letter.

    c) The -spf switch does seem to permit some forms of absolute path, but not the \?\Volume{<GUID>}\ form of absolute path.

    d) The -spf switch also doesn't seem to let me give an absolute path like "\?\c:\foo.bmp". This seems like the 9.20 treatment of stream names--the code is incorrectly objecting to syntax that it merely needed to pass on to the filesystem API. But I haven't looked at the code, so that's idle speculation.

    e) I was interested in the -slt option, but it still gives me timestamps merely to seconds. OTOH, I guess I'm not clear on whether -mtc makes 7z store full 64-bit NTFS timestamps or if it's rounding them to seconds... If it is really storing the complete resolution, then obviously it would be nice to be able to view that information.

     
  • wanezhiling

    wanezhiling - 2014-01-14

    http://www.sendspace.com/file/z5r1fs

    An error occurs at the end.

     
    • Igor Pavlov

      Igor Pavlov - 2014-01-14

      Yes, the problem with exe-Certifacate:
      - EXE Stub
      - NSIS archive
      - Certificate

      7-Zip sends only NSIS archive to NSIS handler, but NSIS archive refers to Exe Stub also to unpack uninstall.exe.

      That problem will be partially fixed in next version.

       
      • gorbchevo

        gorbchevo - 2014-01-14

        Dear Mr. Pavlov, you are doing an excellent job with still developing 7zip and I love to use your tool every day. But please do not bother releasing another beta/alpha before adding RAR5.X support. I want to get rid of this non-free software as soon as I can. Richard Stallman would understand me. I speak for myself but I believe other people may agree with my statement. Kind regards.

         
  • Anonymous - 2014-01-19

    Hello developer of 7zip.

    I love your product and I am using the latest version 9.32 alpha.

    There is an issue. When I want to make a zip or 7z file. 7-zip running perfectly but it uses %96 of my CPU.. What the heck?

    When the job finish CPU turns normal.

    This is inform to you. Please check it. Thanks for amazing software for us ;)

    Regards
    yigido

     
    • john lee

      john lee - 2014-01-20

      No details about your pc, but not sure what you think is wrong & why you think this a problem- zipping is processor intensive. What are you comparing it with?

      john

       
  • PIK

    PIK - 2014-01-22

    @leon
    Wth is this? This is correct. f=bcj2 and exes are significantly smaller.

    I though, with 9.3x and LZMA2 on Max or Ultra I dont more need voodoo things as superoptions like bcj2 hcf=on b01:1 b0s1:2 f=off and and and

    :-\ :-\

     
  • grml4d

    grml4d - 2014-01-27

    i am back with a new idea that it seems 7zip 9.30 alpha does not have and probably not 9.32 either .
    i am still doing win7x64 in vhds for my pcs and i use usb sticks for booting them .
    grub4dos can not handle and load in mem some gzip files , so i checked if compact.exe from M$ can reduce file enough so i can use a 8 Go stick for a 10 Go vhd [ even if i am not sure grub4dos can handle this format ] .
    when i used 7zip manager to store the compressed vhd , it stored the uncompressed file...
    my idea was to make stick bootable and directly extract the ntfs compressed file onto the stick . the stick not being able to have the original vhd .
    something to invent in options , may be a keep ntfs compressed files checkbox

     
    Last edit: grml4d 2014-01-27
  • therube

    therube - 2014-01-29

    @wanezhiling, that is RAR5 & not currently supported by 7-zip.
    (Mentioned earlier in this thread.)

    @bibi, works in 9.30 but not in 9.32.

     
  • Rich McGrew

    Rich McGrew - 2014-01-31

    It cannot open Project64 1.6 save game files (which are in .ZIP format). Previous versions could open these files (I think, not 100% sure). To test, try making a save game from the Nintendo 64 emulator Project64 and try to open in 7-Zip. Or, I will include one as an attachment, and you can test this file in 7-Zip and other archivers that can open .ZIP files. The attachment is a save game file from Super Mario 64 from Project64 1.6 (which saves its games in .ZIP format). Please fix so 7-Zip can open this .ZIP file and others like it. Thank you. The size of this file should be 1,309,779 bytes. Anyway try and find what's odd about this .ZIP file and why it doesn't open in the latest alpha version of 7-Zip while most other .ZIP files do and correct the problem, thank you.

     
    • Igor Pavlov

      Igor Pavlov - 2014-01-31

      That archive contains incorrect dos timestamp value.
      Probably I'll fix that code in next version.

       
      Last edit: Igor Pavlov 2014-01-31
      • Rich McGrew

        Rich McGrew - 2014-02-06

        Thank you for the fast response. For reference, Project64 1.6 savegames in .ZIP format are produced and read using version 0.15 beta of code by Giles Vollant from March 19, 1998 (I looked at Project64 1.6's source code, specifically zip.c, zip.h, unzip.c, and unzip.h to determine this). So those files are written and read by a VERY old version (0.15 beta from March 19, 1998) of Giles Vollant's Minizip library. It would thus be likely that other files written by old versions of that same zip compressor would likewise encounter the same error. There are probably other programs that include old versions of the Minizip library in their source code, and would therefore produce similar .ZIP archives with incorrect DOS timestamps. Hopefully you will be able to get 7-zip to open these somewhat-flawed .ZIP files. Thanks.

         
        • Gilles Vollant

          Gilles Vollant - 2014-05-07

          I'm really sorry ! Can you say more about this bug? And check that current minizip is good?

           
  • h11p5g

    h11p5g - 2014-02-02

    Hi Igor,

    if using password protection without encrypted filenames, checksum is correct for file. This is changed for view in Rar5 (protection for gues password).
    Is it possible in 7-zip?

     
  • Valentyn Shtronda

    Hi.

    Checksum calculation in 9.32 command line version is spoiled.

    Command line:

    7z.exe h -mm=sha256 file.txt
    

    9.30 output:

    7-Zip 9.30 alpha  Copyright (c) 1999-2012 Igor Pavlov  2012-10-26
    Scanning
    
    sha256                                                                    Size  Name
    ---------------------------------------------------------------- -------------  ------------
    38361C5E378BE8ABA40DE2C43704651D8BAC2F528F6D81272A5CEE237DB11F5E          3714  file.txt
    ---------------------------------------------------------------- -------------  ------------
    38361C5E378BE8ABA40DE2C43704651D8BAC2F528F6D81272A5CEE237DB11F5E          3714
    
    Files: 1
    Folders: 0
    Hash sum of data and file names: 1DD60B47F18C12970E7436B21D77BE68C6B7E82CBA9CFDD949EC6A879100BD59
    
    Everything is Ok
    

    9.32 output:

    7-Zip [64] 9.32 alpha  Copyright (c) 1999-2013 Igor Pavlov  2013-12-01
    Scanning
    
    CRC32             Size  Name
    -------- -------------  ------------
    F6ACA4ED          3714  file.txt
    -------- -------------  ------------
    F6ACA4ED          3714
    
    Size: 3714
    
    CRC32  for data:              F6ACA4ED
    
    Everything is Ok
    
    Kernel  Time =     0.031 =    4%
    User    Time =     0.000 =    0%
    Process Time =     0.031 =    4%    Virtual  Memory =      3 MB
    Global  Time =     0.670 =  100%    Physical Memory =      6 MB
    

    This applies to both 32-bit and 64-bit versions (both versions in 9.30 are OK, both versions in 9.32 are not OK).

     
  • Valentyn Shtronda

    Is there a way to suppress time statistics?

    Kernel  Time =     0.031 =    4%
    User    Time =     0.000 =    0%
    Process Time =     0.031 =    4%    Virtual  Memory =      3 MB
    Global  Time =     0.670 =  100%    Physical Memory =      6 MB
    
     
    • Igor Pavlov

      Igor Pavlov - 2014-02-04

      -slt switch

       
  • Igor Pavlov

    Igor Pavlov - 2014-02-04

    I've changed the switch to -scrc:
    -scrcsha256
    I'll fix help file in next version.
    Thanks for report!

     
  • Valentyn Shtronda

    Igor, thanks for prompt reply!

    Please also fix help for -slt switch:
    1. It says that it shows technical information but actually it hides this info. Or better fix the switch to opposite: -slt shows info, -slt- hides info.
    2. Help page says this switch is used with l command, but it is also used with h.

     
    • Igor Pavlov

      Igor Pavlov - 2014-02-05

      -slt switch is temporary solution to hide time stat.

       
  • PaddyM

    PaddyM - 2014-02-14

    7zip is invaluable. Many thanks to Igor.
    Thanks to shell for the tricks with versions >9.20
    Dinosaur systems like NT4 are still out there.
    Thanks to all for not abandoning them.

     
    • Shell

      Shell - 2014-02-16

      Thank you :-)

       
  • Nike

    Nike - 2014-02-28

    I found that in version 9.32 does not work format tar-gzip.
    In 9.20 was OK.

     
  • Vahit

    Vahit - 2014-03-14

    Hello Igor 7 zip Is For Me A Great Tool But it Still Have Problems with some Iso Files You cant extract them Its getting error or slow extreme down In some Situations I Must Install Winrar To Extract Them Pls Can You Fix That ?

     
    • Tom Watson

      Tom Watson - 2014-05-22

      Yes, I have problems with file names over 64 characters as well. I can make up an '.iso' file if it is necessary.

       
  • grml4d

    grml4d - 2014-03-17

    @Vahit may be winrar has been updated while 7z-gui is using an old lib from winrar...

    i wonder if i am next in line for gift ? <3 [you can upload the new grub4dos to mega.me if you want ]
    i made a free account and uploaded a remix of the 4 schreks : https://mega.co.nz/#F!GMAwFSiA!GdfJtRKzkiIMEWVzdlMBdw

    may be you ll have added 7z support to grub4dos before end of film <3 <3

     
    • grml4d

      grml4d - 2014-04-01

      no one helps ?

       
  • Paulo Ferreira

    Paulo Ferreira - 2014-03-20

    updated
    thanks for the very good software

     
  • Squeeze M

    Squeeze M - 2014-03-25

    Hi, is there any project to support lzip file format?
    It's a gzip-like and LZMA based compressor/decompressor (take a look: http://www.nongnu.org/lzip/lzip.html ).
    At least for decompression purpose?

    Thanks, Marco

     
    • Sr. Zé Alguém

      Sr. Zé Alguém - 2014-04-05

      lzip calls itself as "a clean implementation of the LZMA algorithm".

      Why do you think Igor, one of the creators of LZMA, would want to use an almost unknown fork of his own work?

       
      • Squeeze M

        Squeeze M - 2014-04-08

        Hi, Ricardo.

        Maybe because:
        0) I'm a little bit curious and not a cat?

        1) Seems to be an easy to add support? Being an LZMA implementation it sounds quite compatible with the off-the-shelf 7zip code, xz also is a fork and has support.

        2) Being also bzip2-like it's a quite useful tool under nix machines? Using a mixed nix/MS environment a 7-zip support it's of my interest. And it has some interesting features (like chained files decompression). Trying to change the 9.32alpha source to add support by myself it's quite difficult (as they are not released, being an alpha release).

        BTW: A plain, simple "no" (or even nothing) (by Igor) it's enough. The lzip source code it's really easy to compile under any platform and I can use the command-line.
        I've stumped on it testing some *nix projects with the source compressed only with lzip.

        Marco.

         
  • Fallon

    Fallon - 2014-04-06

    A reminder that 7-Zip File Manager cannot yet start up several jpg files from archives in common viewers like Acdsee and Faststone Viewer. This aside, I like each update!

     
    Last edit: Fallon 2014-04-06
  • gora2

    gora2 - 2014-04-12

    This 7z SFX made ​​version 9.30 (Used modified SFX module).
    Archiver version 9.30 opens, tests, unpacks this SFX without problems.
    Archiver version 9.32 can not open, test, unpack this SFX.

    https://dl.dropboxusercontent.com/u/35142695/IE8RU.exe

     
    Last edit: gora2 2014-04-12
    • Igor Pavlov

      Igor Pavlov - 2014-04-12

      The resource section in PE stub was reduced (stripped zeros).
      7-Zip skips pe-stub before 7z detection. So it skips start of 7z archive.
      Now I'm not ready to change that code.
      It can break something.

      Note also that it's possible to open that archive via context menu (open > 7z).

      If it's default pe stub, is it possible to make correct and full stub?

       
      Last edit: Igor Pavlov 2014-04-12
      • gora2

        gora2 - 2014-04-12

        Now I'm not ready to change that code.

        Sorry.

        So there will be another opening protection 7z SFX... :)

         
  • szfong

    szfong - 2014-04-28

    Hi Igor,

    Since 7-Zip supports RAR files in general, and has no plans to support RAR 5 files in the foreseeable future, I was wondering if it was possible for the next alpha to display an error that tells its user it does not support RAR 5 files. Currently I keep mistakenly thinking that I've got a corrupted RAR file... :-)

     
  • Linda

    Linda - 2014-05-08

    Hi Igor,

    7z 9.32 can't extract last 4GB files from matlab803.iso (CJK version, http://pan.baidu.com/s/1bngoQmV) correctly (7.32 GiB or 7868692480 B), for example bin, etc, help...
    WinRAR 5.01 is OK, and reports 'ISO 9660 Joliet File'.
    Maybe you can reproduce and fix?
    Thanks.

     
  • Melchior

    Melchior - 2014-05-25

    Hi Igor thx for a great Program =D

    over the year I have tried to get at drivers, etc stored in cab files
    inside packed-installers or loose-installers in an archive and such...
    for manual installs to avoid extra clutter of installed crap.

    from what I found out its really using zlib as compression...

    As WinRAR and 7zip are the best(I like to use both ^_^) archive tool in the world that I have ever used
    I wanted to ask/send-out this minor request to add support to view and extract the
    "Install Shield [.cab]" files
    if at all possible

     
  • grml4d

    grml4d - 2014-05-29

    i opened an exe archive having multi-files made with winrar last year in february .
    the 7z x64 extracts the first file aka the exe of the archive but it does not continue with the others files ...
    files are an hl mod , you can find them at :
    https://mega.co.nz/#F!qIJSjLDA!JzVfOlptpjwOZ2w2ML1HfQ

    [what about grub4dos with gz files larger than 4Go loaded in ram ?]

     
  • Devil

    Devil - 2014-06-01

    при тестировании файла GOMPLAYERENSETUP.EXE пишет Data error, а цифровая подпись файла OK

     
<< < 1 2 3 4 > >> (Page 3 of 4)

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks