Shell integration Win7 64bit

2010-02-04
2012-12-07
  • crystalclear

    crystalclear - 2010-02-04

    I've just formatted my PC last night and installed win7 64bit, downloaded 7zip 4.65 but no shell integration? Help me how to fix it? On my laptop it's running Win7 RC 32 bit and the shell integration works fine. Any help would be much appreciated. Thanks in advance

     
  • foxyshadis

    foxyshadis - 2010-02-05

    Did you download the x64 version? Did you start the x64 version as administrator when associating?

     
  • crystalclear

    crystalclear - 2010-02-05

    Maybe I downloaded the wrong version, where is the x64 link? I downloaded from that bigbutton on the homepage. Thanks for replying.

     
  • crystalclear

    crystalclear - 2010-02-06

    Anybody? I downloaded from www.7zip.com and I don't see any other downloads, other that one big green button that says download. Where can I find 64 bit version?

     
  • fernando

    fernando - 2010-02-06

    7-zip.org is correct site and files are hosted here on sourceforge.net

    Also see above… "Files"

     
  • crystalclear

    crystalclear - 2010-02-25

    Thank you, now it works flawlessly. So is \www.7zip.com a fake or something?

     
  • Anonymous - 2010-06-21

    I have the same problem. I use 7-zip portable, but if i set the shell integration in both the portable .exe and 7zFM.exe (as an admin) it always worked under xp and vista. Now i have the problem on two pc's with win7 64 bit, but not on two other computers with xp and win7 32 bit.

     
  • Anonymous - 2010-06-21

    I could try replacing the 32 bit files in the 7-zip folder with 64 bit versions, but then it wouldn't work on 32 bit systems. I guess the only real option is to accept that i need two seperate installs (or folders with portable apps).

     
  • Andy Fielding

    Andy Fielding - 2010-06-22

    Yes, I had this problem too… For shell integration to work with 64-bit Windows, you must specifically download and install the 64-bit 7-Zip version. You have to look for it on the Files page—it's not obvious.

     
  • Vacon

    Vacon - 2010-06-23

    Hello everyone,

    come on! How obvious has something to be, that you don't see *I*m*m*e*d*i*a*t*e*l*y* the two links at the top of http://www.7-zip.org underneath the big green lines? One for 4.65 x64 and one for 9.15 x64 nearly in the middle of the screen…

    Best regards!

     
  • Anonymous - 2010-06-23

    Just to clarify vacon, it may not be the 7-zip.org link folks are using.

    I downloaded an "update" from FileHippo - this did NOT specify 32 or 64bit. I too had a problem with file associations after the update. After digging through the registry I found all paths pointed to Program Files/, not Program Files(x86)/. The "update" had installed the software in the 32bit folder so it was obviously the wrong one for me to use. Once I realized this, I uninstalled and found the correct installation package. This resolved the problem.

    KJ

     
  • Vacon

    Vacon - 2010-06-24

    Hello everyone,

    I saw the posting from crystal-clear mentioning the wrong site. But we cannot prevent people from downloading from sometimes obscure sources, and we cannot stop people putting something online that is useless or wrong or even dangerous to data.
    And my comment was regarding ander1122 who said "

    You have to look for it on the Files page—it's not obvious.

    . I think it's pretty obvious if you look at the right site. And if you know that one should install the x64-version if one runs the x64-system.

    Best regards!

     
  • Rebecca Menessec

    7-Zip, whether 32-bit or 64-bit, should run perfectly fine on any 64-bit system that hasn't had the Win32 ("compatibility") subsystem removed.  However, I think you'll find that, to make shell integration work properly, you'll need to launch 7zFM.exe with Administrator privs, then attempt to associate it with files.

    -or you could disable UAC, but this will have the secondary effect of trashing most of the improved security features IE has on NT6.x by default.  Yes, this is silly, but it's how it works.  All the new sandboxing code will be disabled.

    Even if you "don't run" IE, this will drastically lower the security of anything embedding IE components, such as Windows Explorer.  If you run an alternate shell (LiteStep?) and an alternate browser and an email client that doesn't hook IE, and don't use IETab for Firefox, and- look, just don't turn UAC off completely, mmkay?

    Igor: Can 7-Zip call UAC to elevate privs temporarily to remove this extra step?

     
  • adriantnt

    adriantnt - 2012-10-12

    With latest version I am able to …
    Open 7zFM.exe, go to "Tools > Options > 7zip" and there you have "Integrate 7zip to shell context menu";
    If already enabled, then disable it , save, re-enable it and save again, it worked for me.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks