Shell - 2013-12-12

That is strange. What does 7-Zip say to you? Please, give a screenshot or cite the error message.

Try the same version you used to create the archive. Does the error persist? There is a chance (very small though) of incompatibility between versions, or a specific version of 7-Zip may have a bug.

You may also try several other versions (e.g. 4.57, 9.20, 9.22, 9.30, 9.32). There is no need to install them all - you may either use 7za.exe (7-Zip Standalone package) or extract 7z.exe and 7z.dll from an installation package.

 
Last edit: Shell 2013-12-12