7 Zip failed after having run 8300 times on Windows 2008

Weibin Sun
2014-01-07
2014-02-11
  • Weibin Sun

    Weibin Sun - 2014-01-07

    We have being using 7z.exe (command line) in many years starting from v5.X to recently v9.20 (7za.exe 32 bit). It has been working fine on Windows 2003 but started to fail on Windows 2008 (both 32 and 64 bit version) after ca. 8300 times executions.

    7-Zip version and type (32-bit commandline)
    Windows version and type (2008 32-bit and 64-bit)
    CPU type (Intel Xeon X5677, ProLiant DL380 G7)
    RAM size (24 GB)
    Calling appplication: VBScript

    I am stuck to 32-bit 7z version, because the calling application is 32 bit version running on Windows 2008 64 bit version.

    I can simulate the error by creating a VBScript scheduled to run every minute.
    There are consequences if this error occurs. I have experienced that WinScp won't work any longer and some of the Windows services can not be controlled any more by WMI functions.

    Anybody else has the same experience and any solutions?

     
  • Igor Pavlov

    Igor Pavlov - 2014-01-07

    What exact command do you use?
    What exact error message do you have?
    Try 64-bit version of 7-Zip also.

     
  • Weibin Sun

    Weibin Sun - 2014-01-08

    Thank you for reply.
    VBScript:
    strcmd = "cmd.exe /c 7za.exe a -tzip -y -ssw ""c:\tgtfolder\tgtfile.zip"" ""c:\srcfolder\"""
    set objFSO = CreateObject("Scripting.FileSystemObject")
    set objShell = CreateObject("Wscript.Shell")
    logfile = objFSO.BuildPath(objFSO.GetSpecialFolder(2).Path, objFSO.GetTempName)
    objShell.Run strCmd & ">""" & logfile & """", 0, True
    ' code to show/analyze the logfile comes here
    ' code to delete logfile comes here after

    Problem is when it went wrong I never got the logfile. I have also tried with a logfile on a pre-defined location without using Windows/vbs functions to get the tempfile. It doesn't get any better.

    Error occurs only when script is executed by scheduled task (tried with different accounts, no difference). I can still run the script manually in DOS prompt without error.

    I may try 64-bit of 7za.exe later. But it wouldn't help me with my situation.

     
    • Weibin Sun

      Weibin Sun - 2014-02-11

      Just for information.
      I have tested some different scenarios and the results are:
      7za (32bit) v9.2 starts to fail after 18000 times run (tested twice with similar result).
      7z (64bit) v9.2 is still running fine after 46000 times.

       
      • Weibin Sun

        Weibin Sun - 2014-02-11

        The error I got in Windows Event log (under SYSTEM) is:
        Source: Application Popup
        Application popup: cmd.exe - Application Error : The application was unable to start correctly (0xc0000142). Click OK to close the application.

        I have no way to know what is in the Popup box.

         

Log in to post a comment.