SourceForge has been redesigned. Learn more.
Close

Problems with unpacking big files.

checkphp
2014-08-09
2014-10-02
  • checkphp

    checkphp - 2014-08-09

    Hello everybody.
    First of all please forgive me any grammar/spelling mistakes, english is NOT my native language.
    Second, I've been using 7zip for several years, haven't encountered any problems until now.

    PC specs:

    CPU: Intel Core i5 4440
    MB: MSI H81M-P33
    MEMORY: Goodram 4gb DDR3 1600mhz CL9
    HDD: ST500DM002-1BD142
    GPU: Radeon HD7850 1GB GDDR5 256-bit
    PSU: CoolerMaster 550W

    OS: Windows 7 x64
    7zip: Latest 64bit version, downloaded today just in case

    Problem description:
    1. About a week ago using 7zip I packed big file (8gb) into 2 files that I can fit into 4.7gb DVDs
    2. Packed them with 7zip compression, fastest
    3. Compressing done without errors, burned the files on discs (X.7z.001 & X.7z.002) checked them if burned correctly and thats it - these files been waiting for a day like today.
    4. Today I copied these files onto my hdd and tried to unpack them using 7zip.
    5. 7zip while unpacking shows error reporting CRC error - file corrupt.

    What have I done to diagnose the problem:
    1. Looked up cheksum on both DVD and HDD files, heres the link to screenshot:
    http://i.imgur.com/dyrwuRN.jpg
    2. Since the above seem to match I did deep scan for errors on my HDD with HD Tune.
    HD Tune reported no errors whatsoever.
    3. Done some tests with OCCT (cpu, mem, psu), no errors.
    4. Checked RAM usage while unpacking - never reached 75% of total installed memory.
    5. Uninstalled 7zip, cleaned with app similiar to CCleaner, downloaded latest 64bit version of 7zip, installed - tried to run unpacking again, tried to change temporary directory - still CRC error
    6. Packed the 8gb file multiple times with multiple options (7zip/zip | fastest/normal/maximum)
    Haven't moved the .001 & .002 files from disk but tried to unpack them like they were packed a minute ago - bang, CRC error.
    7. Every archives split into .001 and more that I try to unpack end up with broken file error. Even those that 7zip could extract a week ago with no problem. 1-2 DVDs I can understand but 10 of them burned at different time? No way.
    8. I am dual-booting my system with Debian 7.6.0 64bit and here's what I did there:
    a) packing the file on Debian and unpacking it on Debian works with no problem
    b) packing the file on Debian and unpacking it with 7zip on Windows shows CRC Error
    c) packing the file on Windows 7 and unpacking it on Debian shows CRC Error

    I hope somebody either gets a brilliant idea or will use info I provided, I can also provide additional hardware/software info per request, although nothing else comes to my mind at the moment.

    That's all, I can also add that every piece of this PC is still quite new, all parts have been bought ~8 months ago. Yes, I've bought them, yes I've packed the pieces together to make it work.
    Been Windows/Linux user for quite some time, I do remember Intel CPU with 100mhz and 120mhz AMD so please don't ask questions "Have you tried to restart your computer?" I tried. Didn't work :(

     
  • Igor Pavlov

    Igor Pavlov - 2014-08-10

    Check RAM:
    1) http://www.memtest.org/
    2) Run "7-Zip Benchmark" for 10-30 minutes.

     
  • checkphp

    checkphp - 2014-08-10
    1. memtest completed, no errors
    2. I hope 10 mins is enough: http://i.imgur.com/WAiqW2h.jpg
     
  • Igor Pavlov

    Igor Pavlov - 2014-08-10

    Try to find simplest case with error.
    If you create multi-volume, try also with single-volume.

     
  • Igor Pavlov

    Igor Pavlov - 2014-08-10

    You can make also some HDD test.
    7-Zip 9.34 has "CRC/CRC32" calculation feature.
    You can call it for big file/folder on HDD (> 100 GB) two times.
    And check that the sum is same in both passes.
    It can show that hdd returns same data.

    And call 7-Zip benchmark in debian to check RAM:
    7z b 10

     
  • checkphp

    checkphp - 2014-08-10

    When I try to pack/unpack smaller files there are no errors, no matter how many parts I split the file into (tried 2-10 parts)- it works flawlessly.
    The problem seems to begin with files >=1gb
    Haven't tried the benchmark on linux yet cause I need to keep windows up and running for the night.
    Tried 9.34, zip/7zip compression, packing into one big archive/splitting into parts works. Unpacking it, again, doesnt, same CRC error. And no, sum does NOT match.

    But I do have some additional info, be aware thats v9.20 below:
    1. Cant pack the file using zip or 7zip format into one archive. It gets to 100% in around 2-3 mins then it stucks, elapsed time keeps ticking but there's no disc/cpu activity and packing the file isn't completed - sums don't match either. When elapsed time hit 10mins I tried to cancel - elapsed time still ticking but window is unresponsive, finally had to manually kill the process.
    Packing files/folders smaller than 1gb works with no problem.
    2. Packing the file using "wim' archive format into 2 parts then unpacking them gives no errors and the file itself works too. More like a workaround than a problem solver but works for me.

    Anyway, thanks for the patience, I've been planning to format Windows partition and reinstall it so if you don't mind I'll post once more (probably next week) after I check packing/unpacking on freshly installed system.

     
  • checkphp

    checkphp - 2014-08-16

    Well, the problem is still alive on freshly installed Windows 7 x64 (7zip v9.34), looks more like compressing issue rather than unpacking:
    1. Packed file into 2 parts with rar/rar5/zip compression using Winrar and 7zip unpacked them without errors.
    2. Packed it with 7zip and tried to unpack it with 7zip - CRC errors again.
    3. Packed it with 7zip and tried to unpack it with Winrar - errors while unpacking - file broken.

     
  • Igor Pavlov

    Igor Pavlov - 2014-08-16

    1) Try to find smallest case with error:
    - if you create two parts, try single part archive.
    - split your "BAD" source file into two parts and compress each part. If there is unpacking error, split bad part again, and so on.
    2) try to compress / unpack "BAD" file in another computer with same options.

     
    • r3sidual

      r3sidual - 2014-10-02

      I have the same issue. Unpacking a small file gives no errors but trying to extract a file that's 30+ GBs says that the file is broken. I installed WinRAR and the file is extracting now. There's definitely a problem with 7zip

       

Log in to post a comment.