7-Zip 9.34 alpha

2014-06-22
2016-03-23
  • Igor Pavlov

    Igor Pavlov - 2014-06-22

    7-Zip 9.34 alpha was released.

    This is a development version.
    Don't use this alpha version to process important files and archives.
    The code of this version contains big number of changes.
    And probably there are some new BUGs.
    If you use 7-Zip 9.34 alpha, check 7-Zip's forum periodically for updated information.

    If you need more stable version, you can use previous versions: 7-Zip 9.25 alpha or 7-Zip 9.30 alpha.

    7-Zip for 32-bit Windows:

    http://dl.7-zip.org/7z934.exe
    or
    http://dl.7-zip.org/7z934.msi

    7-Zip for 64-bit Windows x64:

    http://dl.7-zip.org/7z934-x64.msi

    7z Library, SFXs for installers, Plugin for FAR Manager:

    http://dl.7-zip.org/7z934_extra.7z

    7-Zip 9.34 alpha version is provided without source code.
    Source code will be released in future beta version.

    Please write here at forum about any new bugs.

    What's new after 7-Zip 9.33 alpha:

    • The BUG in 9.33 was fixed:
      Command line version of 7-Zip could work incorrectly, if there is relative
      path in exclude filename optiton (-x) and absolute path as include filename.
    • The BUG in 9.26-9.33 was fixed:
      7-Zip could not open some unusual 7z archives that were created by another
      software (not by 7-Zip).
    • The BUG in 9.31-9.33 was fixed:
      7-Zip could crash with switch -tcab.

    What's new after 7-Zip 9.32 alpha:

    • 7-Zip now can show icons for 7-Zip items in Explorer's context menu.
    • "Add to archive" dialog box:
      • new options in "Path Mode"
      • new option "Delete files after compression"
      • new "NTFS" options for WIM and TAR formats:
      • Store symbolic links
      • Store hard links
      • Store alternate data streams
      • Store file security
    • "Extract" dialog box:
      • new optional field to set output folder name
      • new option "Eliminate duplication of root folder"
      • new option "Absolute pathnames" in "Path Mode".
      • new option "Restore file security" (that works for WIM archives only)
    • 7-Zip File Manager:
      • new "File / Link" dialog box in to create symbolic links and hard links.
    • Command line version:
      • new -spd switch to Disable wildcard matching for file names
      • new -spe switch to Eliminate duplication of root folder for extract archive command
      • new -snh switch to store hard links as links (WIM and TAR formats only)
      • new -snl switch to store symbolic links as links (WIM and TAR formats only)
    • NSIS support was improved.
    • The problem was fixed:
      The command "extract to *" with multiple archives could use same
      output folder, if archives are placed inside PE (EXE) file.
    • The BUG of 9.31-9.32 was fixed:
      Command line version for test and extract commands returned the
      value 0 as exit code, if it couldn't open archive.
    • The BUG was fixed:
      7-Zip could not create archives with anti-items for any archive type,
      except of 7z type
    • Some bugs were fixed.
    • New localization: Mongolian (script).

    7z934.exe SHA-1:
    A765EBB43993916028C7566227CA5894F5856836

    7z934.msi SHA-1:
    8C28A7A83D6201EAD8A5C847DF84FC461C9CADBC

    7z934-x64.msi SHA-1:
    16EB40991B02869B49D8E8E501152C3ED6A9F064

    7z934_extra.7z SHA-1:
    A76A9BA206D0B113EA9FF44A031E82AEEC809767

     
    • Reddy

      Reddy - 2014-06-25

      @Igor Pavlov: Sorry to disturb you after installation me facing following issue when i try to open ZIP/RAR files. Can you help me with this issue. Thanks, in advance.

      Me using 7-Zip for 64-bit (Mine Config: Windows-64 bit)

       
      Last edit: Reddy 2014-06-25
    • txtsd

      txtsd - 2014-06-28

      I get errors 2503 and 2502 when I try to install 7z934-x64.msi
      Win8.1 x64

       
    • Nick Korotysh

      Nick Korotysh - 2014-09-11

      latest openssl sources archive can't be extracted correctly. there are some symlinks in archive (extracted on linux) and 7z gives errors on them.

      9.34-x64, win 8.1

       
      • Igor Pavlov

        Igor Pavlov - 2014-09-12

        Does it work, if you run 7-Zip with Administrator rights?

         
        • Nick Korotysh

          Nick Korotysh - 2014-09-12

          yes, this works correctly with administrator rights

           
          Last edit: Nick Korotysh 2014-09-12
    • grml4d

      grml4d - 2014-10-20

      i used Disk2vhd : http://technet.microsoft.com/en-us/sysinternals/ee656415.aspx
      to backup a 60 Go ssd with a fresh win7

      it created me a 7.20 GB (7,742,602,240 bytes) file in few minutes , i found that so incredible that i created a 60 Go vhd using disk management console and made a copy of my partition with a backup tool in this 60 Go vhd

      i used 7z 9.34 to compress it uzing 7z-lzma2 setting with 8Go of ram free and 16 threads, after 90 minutes or so , the resulting file is 13.0 GB (13,991,225,093 bytes)...

      i tried to create the archive on a 32 Go usb stick but quickly had a crashbox saying not enough disk-space . i created a sfx archive but if i launch it the mbox says that it is not a valid win32 application . i was able to extract file with 7z9.34 gui.

       
  • dimon4ezzz

    dimon4ezzz - 2014-06-22

    Ура! Новая версия!

     
  • gora2

    gora2 - 2014-06-22

    Standalone console archivers (7za and 7zr) have the same built-in help

     
    • Igor Pavlov

      Igor Pavlov - 2014-06-22

      Yes, both programs support all commands and most of switches.
      7zr.exe now supports also encryption.

       
      • gora2

        gora2 - 2014-06-22

        Clear. But headers should be different?

        7-Zip (a) 9.34 alpha Copyright (c) 1999-2014 Igor Pavlov 2014-06-22

        Usage: 7za [<switches>...] <archive_name> [<file_names>...]

        7-Zip (r) 9.34 alpha Copyright (c) 1999-2014 Igor Pavlov 2014-06-22

        Usage: 7zr [<switches>...] <archive_name> [<file_names>...]

         
        • Igor Pavlov

          Igor Pavlov - 2014-06-22

          Ok, I'll think about way to fix it.

           
          • Sr. Zé Alguém

            Sr. Zé Alguém - 2014-06-22

            What's the difference between them?

             
            • Igor Pavlov

              Igor Pavlov - 2014-06-23

              7zr.exe supports only lzma related formats (7z and xz)
              7za.exe supports also zip, bzip2, gzip2, Z, cab and tar.

               
              • gora2

                gora2 - 2014-06-23

                7za.exe supports also zip, bzip2, gzip2, Z, cab and tar.

                In readme no cab archives

                7-Zip Extra 9.34

                Features of 7za.exe:
                - High compression ratio in new 7z format
                - Supported formats:
                - Packing / unpacking: 7z, xz, ZIP, GZIP, BZIP2 and TAR
                - Unpacking only: Z, lzma

                 
  • Byron Taz

    Byron Taz - 2014-06-22

    Thanks Again Igor,
    I hope I don't sound like a nag, but I asked about the poss. of a password keeper and never heard from you about if it is something you might add in the future or not. Like I said before cloud storage is getting more and more popular, and I always compress and password protect everything before I upload it.

    Thanks for you hard work either way.

    ByronTaz

     
    • foxpat

      foxpat - 2014-06-23

      Igor said in the first post:

      Please write here at forum about any new bugs.

       
  • Bruce Alexander

    Bruce Alexander - 2014-06-23

    Thanks for the new alpha Igor, but could you please consider adding an option to verify a password when an archive is being created using the command line version of 7-zip? At the moment a typo when typing the password can easily render the archive useless.

     
    • foxpat

      foxpat - 2014-06-23

      Igor said in the first post:

      Please write here at forum about any new bugs.

       
  • Sr. Zé Alguém

    Sr. Zé Alguém - 2014-06-23

    When one file is opened in 7-zip FM "Add" button in toolbar always give me error "Operation is not supported". Shouldn't it show explorer window for selecting files to add to the opened archive?

     
    • Igor Pavlov

      Igor Pavlov - 2014-06-23

      No, 7-Zip expects operation for selected files.

       
  • Fallon

    Fallon - 2014-06-23

    Context menu icons needing to be 13 wide for XP is news to me.
    Did 16x16 not work?
    (XP could not adjust bigger than 96x96 in Tiles Mode, that was an issue, I remember).
    Thanks for new updates!

     
    • Igor Pavlov

      Igor Pavlov - 2014-06-23

      As I understand there are several ways to show icon in menu. 7-Zip now uses simplest way via MENUITEMINFO::hbmpChecked. And XP shows only 13 pixels in that case. Another ways to show icon are more difficult to implement.

       
  • Fallon

    Fallon - 2014-06-23

    13x13 is good enough, until you want to look at it again. Thank you.

     
  • szfong

    szfong - 2014-06-23

    Nearest days - next alpha.
    If there are no critical bugs, beta with source code will be released in 1-2 weeks.
    Then probably I'll start to work for RAR5 decoding support.
    https://sourceforge.net/p/sevenzip/discussion/45797/thread/19f51038/#b59c/785c/f6c2/4be9/46c4/5061/375a

    Hi Igor,

    You mentioned that after you release the beta code, you will be working on RAR5 decoding support.

    Does this mean you will once again be returning to alpha releases for the foreseeable future when you start adding features again, like what happened to v9.22 beta?

    Perhaps designating the source release beta as a "stable" release might let the net community know 7-Zip is still alive and development is still occurring... Just my opinion though...

     
    Last edit: szfong 2014-06-23
    • Igor Pavlov

      Igor Pavlov - 2014-06-23

      If I work for RAR5 code, I don't change main code of 7-Zip. So rar5 will not delay the release.

       
      • foxpat

        foxpat - 2014-06-23

        @Igor I thing what szfong meant is labeling your "Betas" as "stable releases".
        I humbly agree with szfong. The community is long time waiting for a 7zip "stable release"; something that i.e. a manager somewhere (that does not read this forum) can take as a clear indication that this project is actively being developed and not abandoned at all.

         
        Last edit: foxpat 2014-06-23
  • szfong

    szfong - 2014-06-23

    If I work for RAR5 code, I don't change main code of 7-Zip. So rar5 will not delay the release.

    Hi Igor,

    If it's not too much trouble, adding a:

    WinRAR equivalent of
    -ds Do not sort files while adding to a solid archive.

    would be great as I've notice MUCH higher compression when compressing files with many sub-directories or multilevel sub-directories....

     
  • Oleg

    Oleg - 2014-06-24

    Hello Igor,
    Thank you for best archiver ;)

    Sorry but versions 7-Zip 9.34 and 9.33 can't add busy/shared files (see attachment), 1C Bases in this example

    7-Zip 9.32 can do this.

    This is bug i'm checked from GUI, but in command string also possible contain this error...

    Best regards,

    Oleg

    p.s: compress shared files checked in all exaples.

     
    Last edit: Oleg 2014-06-24
    • Igor Pavlov

      Igor Pavlov - 2014-06-24

      I'll fix it.

       
      • Oleg

        Oleg - 2014-06-24

        Ok Igor,

        Thank you very much :)

        Best regards,

        Oleg

         
  • gora2

    gora2 - 2014-06-24

    Bug report on Ru.Board

    In the console versions 9.33a and 9.34a archiver something is not working the switch -spf.
    For example, if you execute the following command does not find archive files to compress:
    7z.exe a -r -spf archive.7z \\Server\Work\*.doc
    In 9.30a still worked ...

     
    Last edit: gora2 2014-06-24
    • Igor Pavlov

      Igor Pavlov - 2014-06-24

      I'll fix it.
      I read posts at Ru.Board forum.

       
  • Tehmul Ghyara

    Tehmul Ghyara - 2014-06-25

    Hi Igor,
    thank you for adding the options for hard and symbolic links.

    This version seems to store and extract hard links properly, but it has problems with symlinks.
    When I create a tar file containing symlinks, 7-zip file manager doesn't even show the file name in the symlink column, and fails to extract the symlinks correctly.

    Also, when I open a tar file with symlinks (created using tar), 7-zip file manager shows the symlink name correctly in the symlink columnn, but fails to extract the symlink correctly.

     
    • Igor Pavlov

      Igor Pavlov - 2014-06-25

      1) what is your WINDOWS version?
      2) you must run 7-Zip File Manager with administrator rights.

      If you still have problems, please follow the following steps:
      1) run 7-Zip File Manager with administrator rights
      2) create file.txt
      3) create symlink.txt to file.txt (via 7-Zip File Manager)
      7-zip File Manager must show the link in Link column.
      4) select both .txt files and create a.tar with "store symbolic links" enabled.
      5) open a.tar

       
      • Tehmul Ghyara

        Tehmul Ghyara - 2014-07-11

        Thanks Igor! I did not run 7-zip with administrator rights. After I did, this worked fine. Thanks!

         
  • Andreas Hoppe

    Andreas Hoppe - 2014-06-25

    Hello Igor,
    we made an update of 7-zip from 9.25 to 9.32 for our Win7-x64 systems. Now, after rollout, i got this error:

    ZIP Files created on z/OS Host System with „Zip 2.2 (November 3rd 1997)“ can now not be opened with 7-zip versions 9.32 or 9.34 (x64) on Windows systems. Error „Can not open file xyz.zip as archive" is displayed
    With 7-zip version 9.25 everything was ok.

    (Please see Attachments here; also a test.zip for you)

    But ZIP-Files created on (newer) Linux System with newer version of Info-ZIP „3.0 (July 5th 2008)“ can still be opened with 7-zip 9.25/9.32/9.34 !!

     
    • Igor Pavlov

      Igor Pavlov - 2014-06-25

      There is error in Extra Field of local-header.
      7-Zip doesn't like such errors in header of first file in zip. It checks it to ensure that it's real zip file.

      Proably it's known bug of old ZIP 2.2. But now I can't find any references to that bug.

      Maybe I'll change the code to work with such files.

       
      Last edit: Igor Pavlov 2014-06-25
  • paf22

    paf22 - 2014-06-25

    Hi Igor,
    And thank you for your great software!

    Even 7zip 9.34 alpha can't extract .exe files contained in .zipx archive created with the latest version of Winzip (18.5).

    7zip decompression error: "Unsupported compression method"

    7zip columns informations:
    Method: 95
    Host OS: FAT
    Version: 20

    Example attached. (iview438_setup.zipx) (or https://www.dropbox.com/s/jqhkfesjpe1o88k/iview438_setup.zipx)

    Detailed diagnostic from Winzip 18.5:

    Archive: C:\iview438_setup.zipx 1835974 bytes 2014-06-25 18:55:46
    Current Location part 1 offset 1835952
    End central directory record PK0506 (4+18)
    ==========================================
    location of end-of-central-dir record: 1835952 (0x001c03b0) bytes
    part number of this part (0000): 1
    part number of start of central dir (0000): 1
    number of entries in central dir in this part: 1
    total number of entries in central dir: 1
    size of central dir: 100 (0x00000064) bytes
    relative offset of central dir: 1835852 (0x001c034c) bytes
    zipfile comment length: 0

    Current Location part 1 offset 1835852
    Central directory entry PK0102 (4+42): #1
    ======================================
    part number in which file begins (0000): 1
    relative offset of local header: 0 (0x00000000) bytes
    version made by operating system (00): MS-DOS, OS/2, NT FAT
    version made by zip software (20): 2.0
    operat. system version needed to extract (00): MS-DOS, OS/2, NT FAT
    unzip software version needed to extract (20): 2.0
    general purpose bit flag (0x0000) (bit 15..0): 0000.0000 0000.0000
    file security status (bit 0): not encrypted
    extended local header (bit 3): no
    compression method (95): xz compression
    file last modified on (0x000044d9 0x00009640): 2014-06-25 18:50:00
    32-bit CRC value: 0x75b2ef77
    compressed size: 1835804 bytes
    uncompressed size: 1898640 bytes
    length of filename: 18 characters
    length of extra field: 36 bytes
    length of file comment: 0 characters
    internal file attributes: 0x0000
    apparent file type: binary
    external file attributes: 0x00000020
    non-MSDOS external file attributes: 0x000000
    MS-DOS file attributes (0x20): arc
    filename: iview438_setup.exe
    extra field 0x000a (PKWARE Win32 Filetimes), 4 header and 32 data bytes:
    The Extended Timestamps are:
    Creation Date: 2014-06-25 18:49:54
    Last Modified Date: 2014-06-25 18:50:00
    Last Accessed Date: 2014-06-25 18:49:54

    Testing iview438_setup.exe
    * iview438_setup.exe Tested OK

    Current Location part 1 offset 0
    Local directory entry PK0304 (4+26): 1

    operat. system version needed to extract (00): MS-DOS, OS/2, NT FAT
    unzip software version needed to extract (20): 2.0
    general purpose bit flag (0x0000) (bit 15..0): 0000.0000 0000.0000
    file security status (bit 0): not encrypted
    extended local header (bit 3): no
    compression method (95): xz compression
    file last modified on (0x000044d9 0x00009640): 2014-06-25 18:50:00
    32-bit CRC value: 0x75b2ef77
    compressed size: 1835804 bytes
    uncompressed size: 1898640 bytes
    length of filename: 18 characters
    length of extra field: 0 bytes
    filename: iview438_setup.exe

    No errors detected in compressed data of C:\iview438_setup.zipx.

     
    • Igor Pavlov

      Igor Pavlov - 2014-06-26

      WinZip now supports xz compression as "95" method.
      I have working xz code.
      So I can add decoding for "95" to 7-Zip too.

       
      • paf22

        paf22 - 2014-06-26

        Coooool!
        Then please, add it for the next version.
        Thank you very much in advance! =D

        Subsidiary question: Why not add automatically all compression/decompression code you have working? To keep 7zip as small as possible?

         
        • Igor Pavlov

          Igor Pavlov - 2014-06-26

          xz in WinZip (zipx) is pretty new feature. Now when I have example of such archive, I can add that feature to 7-Zip (unpacking only).

          xz code is already included in 7z.dll. So zip code will just call that xz code. Maybe it's additional 1 KB. So 7zip's size is not problem here.

          I will not add xz-zipx encoding in near versions. It's more difficult to implement and test compatibility of encoding code than decoding code.

           
  • paf22

    paf22 - 2014-06-26

    Ok, nice.
    Thank you in advance for adding this decoding-code in next version.
    No problem for not implementing xz-zipx encoding code since LZMA2-ultra-7zip seems equal or better in most of case for me. :)

     
    Last edit: paf22 2014-06-26
  • Anonymous

    Anonymous - 2014-06-27

    Hello Igor,

    Folder entries are now(?) stored before other entries (e.g. files), at least by 7za.
    Thus, folder timestamps are no longer properly restored.
    Is this an intended behaviour? (sorry if this has already been asked formerly)

     
    • Igor Pavlov

      Igor Pavlov - 2014-06-28

      Did you check it?
      7-Zip makes second pass for folders. So it must restore timestamps.

       
  • Anonymous

    Anonymous - 2014-06-28

    Oops... I built the test archive with 9.34, but inadvertently extracted it with a former version, sorry.
    Thanks for your reply Igor.

     
  • gora2

    gora2 - 2014-06-29

    The manual describes two ways to call Extract Dialog Box, but it's different dialogues! Or am I mistaken?

    extract

    copyto

     
    • Igor Pavlov

      Igor Pavlov - 2014-06-29

      Probably I used "Extract" dialog in past for open archive, but then there were reasons to use "Copy" dialog instead.
      I'll fix the help.

       
      • gora2

        gora2 - 2014-06-29

        Fixes for help:
        1 fm/plugins/7-zip/add.htm
        no description option "Delete files after compression"

        2 fm/plugins/7-zip/extract.htm
        no description option "Show Password"

        3 fm/plugins/7-zip/add.htm
        no description option "Path mode"

         
        Last edit: gora2 2014-07-11
  • stifani

    stifani - 2014-06-30

    ok tnx.
    where is the source of this one? are you going to release it?

     
    • Sr. Zé Alguém

      Sr. Zé Alguém - 2014-06-30

      Below download links you can clearly read:
      "7-Zip 9.34 alpha version is provided without source code.
      Source code will be released in future beta version."

       
  • Anonymous

    Anonymous - 2014-07-02

    I have Windows 8.1 64 bit. cannot associate files or add to the context menu of the menu of 7-zip, because I show up 2 messages. Please improve. This happens in both versions of 7-zip 32 and 64 bit.

    I had to change it to an easy 7-zip, and I want to use 7-zip

     
    • n00b

      n00b - 2014-07-04

      Did you try to run 7z manager as administrator (right click) and then set associations? Context menu will work only with the same OS version - in your case is 7z x64. Please write here these messages.

       
  • Anonymous

    Anonymous - 2014-07-04

    You cannot uncheck those associations which said, after you press ok, the error message access denied.

    http://images61.fotosik.pl/1139/cb3d0f9356ec0fd3med.jpg

    edit:

    even in catalogs, system do not want to pack your directories, folders and files through the context menu, add to ....7z and add to ... zip

     
    Last edit: Anonymous 2014-07-05
    • n00b

      n00b - 2014-07-05

      Maybe you have AV software that sandbox 7zip?
      Try disable it. (What kind of AV do you have?)
      Try to disable User Account Control - set it to minimum.
      If these tips failed, then email to me - n00b@wp.pl

       
    • Sr. Zé Alguém

      Sr. Zé Alguém - 2014-07-07

      You need to execute 7zFM with administrative rights before setting associations. You should not disable UAC.

       
  • Anonymous

    Anonymous - 2014-07-05

    ok, it works. I have avast free

     
  • academic

    academic - 2014-07-08

    -ssw switch doesn't work in command line version :-(

     
  • Igor Pavlov

    Igor Pavlov - 2014-07-08

    Yes, it will be fixed in next version.

     
  • john lee

    john lee - 2014-07-10

    Igor, can you please clarify the status of -spf (in previous version) in the help file and in the code (see separate thread discussion 'save full path name') Think I've used it & it has worked ok. It is not in help for the latest 9.34.

     
  • jacky yang

    jacky yang - 2014-07-13

    First the CRC SHA is useful.
    You should save the result of CRC SHA in a text file.
    So someone can change the case of character in CRC SHA.

     
  • jacky yang

    jacky yang - 2014-07-13

    Can you provide the feature in the future version.
    ( From WinRAR Help )
    Put each file to separate archive
    Put each selected file or folder to separate archive. If you set this option, an entered archive name is treated only as a destination path for new archives (if it is not a folder, its name part is ignored) and archive names are generated basing on file names.

     
  • jacky yang

    jacky yang - 2014-07-13

    You can add a Edit Box or Combo Box with a select path Button in Add to Archive Dialog.
    So someone can select a save path quickly more than use File Save As dialog box.

     
  • john lee

    john lee - 2014-07-13

    Next version (eg the beta) is for fixes - not new functionality. j

     
  • jacky yang

    jacky yang - 2014-07-13

    I am so happy! But Add MD5 in CRC SHA is so far.

     
    Last edit: jacky yang 2014-07-13
  • john lee

    john lee - 2014-07-14

    re -spf (see above), I have just tried it on this version and the switch is accepted by 7z but then doing a 7z l (list) doesn't show full path names and -spf is not in help, so clarification needed. Believe it worked in a previous alpha/beta! j

     
    Last edit: john lee 2014-07-14
  • Andy Fielding

    Andy Fielding - 2014-07-14

    Thanks for this! I thought I'd have to switch to a different archiver, because the previous 7-Zip (beta) didn't show context-menu commands in my file manager (xplorer2). v9.35 alpha fixes that, though—so whether it was intentional or not, nice work! I've been using it for a week and haven't had any problems.

    Cheers, Ander

     
  • Valentyn Shtronda

    I often use password in archives but there is no hotkey for "Enter password" field in "Add to Archive" dialog. Some other fields are missing hotkeys too.

    Considering that password is probably used more often than additional parameters, I would suggest to use:
    - R for "Parameters"
    - P for "Enter password"
    - O for "Show password"
    - H for "Path mode"
    - C for "Compress shared files"
    - I for "Delete files after compression"
    - Dot for "...".

    Also I noted that N is used twice:
    - for "Number of CPU threads"
    - and for "Encrypt file names".
    You may fix this by using Y for "Encrypt file names" or T for "Number of CPU threads".

    Thanks!

     
    Last edit: Valentyn Shtronda 2014-07-16
  • ante

    ante - 2014-07-20

    I've been having this issue since 9.20. I thought trying the alpha of the newest version would solve it, but it hasn't. I have files, whether they be .zip or .7z, that are zipped with multiple subfolders, or sometimes just a single subfolder. Whenever I use 7zip to unzip them, the program decides to remove all files from within the subfolders and place them in the main folder, leaving all subfolders empty. This isn't usually a problem. However, I have a program I am trying to unzip that is in .7z format, and in order for it to run appropriated, files must be in their designated folders. I have no clue what goes where since 7zip took everything out of their original subfolders. Is there some setting I'm missing here that stops the program from doing this? Way back when, it didn't do this. If it's just something I'm being blind to, can you kindly explain the process? Thank you much!

    **I should add that it doesn't do this if I manually extract everything by opening the actual program and locating my file. However, it does this EVERY TIME I right click and extract by that method, instead of opening the program. Is there a reason it does this?

     
    Last edit: ante 2014-07-20
    • gora2

      gora2 - 2014-07-20

      ante
      Сontext menu -> 7-Zip -> Extract file... -> Path mode: "No pathnames"
      change to: "Full pathnames"

       
  • Starshadow

    Starshadow - 2014-07-22

    I found a bug in extracting files from very large .iso files e.g. a Blu-ray image. I am trying to extract a file that exists at offset 0x2B0F40000 in the .iso file (I found it by opening the .iso in a hex editor). When I extract this file with 7-zip 9.31 and newer, the extracted file contains a chunk of data from some other file which exists at offset 0xB0F40000 (missing the leading 2) in the .iso file. 9.30 and earlier is able to extract the file correctly.

     
    • Igor Pavlov

      Igor Pavlov - 2014-07-22

      Yes, there is such bug in 9.31-9.34.
      I'll fix it in next version.
      Thanks for report!!!

       
  • netlord

    netlord - 2014-07-28

    Hi there

    i want to use 7zip as a installer with pe
    therefore i created an config.txt with this content

    ;!@Install@!UTF-8!
    Path=".\"
    Progress="No"
    ExecuteFile="cmd"
    ExecuteParameters="/c install.cmd"
    ;!@InstallEnd@!

    It doesnt work with this version.... (with the older version its working - but not unter PE64)
    It seems that the config.txt is completly ignored.

     
    • Igor Pavlov

      Igor Pavlov - 2014-07-28

      7-Zip doesn't support the following script command:
      Path=".\"

       
  • gora2

    gora2 - 2014-07-30

    Hi, Igor
    File vcredist_x86.exe (http://www.microsoft.com/ru-ru/download/details.aspx?id=30679) is cab SFX
    7-zip by default opens it incorrectly
    7-zip mode "cab" opens it incorrectly
    7-zip mode "#" or "#:e" opens it correctly

     
    • Igor Pavlov

      Igor Pavlov - 2014-07-30

      Yes, 7-zip opens first cab, even if there is larger cab later.
      Now I'm not ready to change that code.

       
      • gora2

        gora2 - 2014-07-30

        If one cab, then need to open it
        If more than one cab then enter the cab is not necessary.

         
  • Martin Claus

    Martin Claus - 2014-08-08

    It would be great to include some kind of helper which connects to selected filetypes for all users. If I start 7Zip as limited user and try to set it for all users I get an "Access denied" error. So an additional program which request the uac would be very helpful.

     
    Last edit: Martin Claus 2014-08-08
    • Hobby-boy

      Hobby-boy - 2014-08-08

      Similar to what WinRAR does when you change associations?

       
      • Martin Claus

        Martin Claus - 2014-08-10

        I don't know how Winrar is working. But most programs are downloading stuff like updates and to install the updates the programs are requesting administrative rights. All gaming platform use that for game installations.
        So the program itself is able to start in limited mode and requests administrative rights if required.

         
  • Rich McGrew

    Rich McGrew - 2014-08-11

    Hello, I have 3 features I request please.

    1) Files that are .tar.gz or .tar.bz2 or .tar.xz (or alternate extensions .tgz or .tbz2 or .txz) should have an option to extract all at once instead of first extracting .tar from .gz/.bz2/.xz and secondly extracting files from .tar. This does not need to be default behavior, it could be an option in the preferences.

    2) Currently I look inside an archive before extracting it. If everything is in one directory then I use the "Extract Here" context menu item. If the files and directories are in the root directory of the archive I extract the archive into a directory with the same name as the archive, using a different context menu item. Perhaps there can be an option to do this behavior automatically so I don't have to manually check if all files are in the same directory inside the archive... an option to extract it into its own directory that won't create a directory with just another directory inside it and all the files in that, because that is too complicated and Windows is not happy if you go too many directories deep and go over the maximum path length. And if the archive is several levels of just one directory it would go through each of those until it gets to a level with at least one file and/or more than one file/directory. This would option would still preserve subdirectories of the first directory that has more than one entry. Anyway this would make it a little more convenient to use.

    3) Change the default Ultra/"-mx=9" compression options for Deflate to include "-mpass=15 -mfb=258" for even better compression.

     
  • gora2

    gora2 - 2014-08-20

    Hi, Igor
    Installer JAVA - jre-8u20-windows-i586.exe (http://www.oracle.com/technetwork/java/javase/downloads/jre8-downloads-2133155.html)

    I'm trying to extract the files: .rsrc\1033\JAVA_INSTALLER\103 and .rsrc\1033\JAVA_INSTALLER\105

    1 From the command line - getting error
    2 7zFM click "Extract" - getting error
    3 7zFM drag the files to another folder - 7zFM hangs! :(

    Previous installers of JAVA extracted without problems.

     
    • Igor Pavlov

      Igor Pavlov - 2014-08-20

      Yes, 7-Zip can't work with UPX archives.
      3. It's old drag and drop mouse hang problem. Use keyboard.

       
    • Synetech

      Synetech - 2016-03-23

      Unfortunately Oracle doesn’t like the concept of portable and wants to force everybody to use their installer no matter what. The best I can offer at the moment is to install the JRE, then get the MSI from Administrator\AppData\LocalLow\Oracle\Java\jre…, then uninstall the JRE. Then you can extract the files from the installerexe from the Data1.cab from the MSI file.

      Fortunately the 64-bit version of the JRE installer has not been ruined yet and you can extract it without having to first install (or run the executable at all).

      I’m really not sure why the 32-bit installer wraps the JRE in an MSI, but the 64-bit one doesn’t.

      Alternately, you could just forgo the installer altogether and just donwload the .gz archive.

       
      Last edit: Synetech 2016-03-23
  • Byron Taz

    Byron Taz - 2014-08-25

    Fizzles out or stops on larger files. 1st system and settings. Win 8.1 64 Bit AMD 8350 16 GB DDR3 OC Mem 256 GB SSD & 4TB 7200rpm HDD. 7-zip 9.34 alpha Settings Com Level Ultra, LZMA2, Dict Size 1024 MB, Word Size 273, Solid Block Size. On files under 2 GB everything works fast and fine, but if file is over 2 it will slow down around 2 GB, pause for about 5 min, then slowly start compressing again (but still much slower than the 1st 1.5 GB, however I tried to compress/split into 700MB files a file just under 7 GB last night and 7.5 hours later it was stuck at 5.4 GB, but the funny thing is I only had 2 of the sections 1 700 MB, and 1 that was 315 MB (just under 1 GB of actual files). I did another file the night before (about 6 GB) and it did the same thing. I compressed both of these files with WinRAR 5.10 and they took under 15 min with no problems. WinRAR compression settings RAR 5, Best Compress, Dict Size 1024 MB, Word Size 273, etc. Basically the best same settings as 7-zip. I know that 1024 Dict Size is a lot, but 16 GB should work (works with WinRAR) and both times I opened Task Manager and showed %85 used and %88 used. Note: when I compress files I'm only compressing file, and shut down every thing else.

    Thanks for all your hard work

     
    Last edit: Byron Taz 2014-08-25
    • Igor Pavlov

      Igor Pavlov - 2014-08-26

      When you select "1024 MB" dictionary, look also the line "Memory usage for compressing:" in "Add to Archive" dialog box. If that value is too large, just reduce the value in "Number of CPU threads" to 2.

       
      • Byron Taz

        Byron Taz - 2014-08-26

        Yea that worked. I changed it to 3 cores (Same mem usage as 2 cores) and worked fine. Question; is the memory usage for physical mem or virtual mem (pagefile)? Because my virtual mem is 38 GB and I could increase it more to use all 8 cores. Next question is; is this a bug? 38 GB virtual & 16 GB physical memory seems like it should be enough to compress a 6.5 GB file. Is this version not releasing memory or something elese?

        Thanks again for this great software.

         
        • Igor Pavlov

          Igor Pavlov - 2014-08-27

          Don't look virtual memory size. LZMA2 needs physical memory.

          It's not bug. LZMA2 needs about 11x times more memory than dictionary size for each 2 threads.
          For 1024 MB / 2 threads you need about 11 GB of physical memory, and 22 GB for 4 threads.

           
          • Byron Taz

            Byron Taz - 2014-08-27

            OK, thanks for the info and all your hard work. I guess if I want to compress files as small as possible, I'm limited to 3 cores.

            Thanks again.

             
  • BillAnt

    BillAnt - 2014-08-27

    When opening some archives (.zip, .exe or .msi) in Flat View mode, when you try to select some or all files for extraction it crashes the GUI. In non-flat view mode it works fine.
    Here's an example of a zip file you can try. Just click on the black download button.
    http://d-h.st/Bhx

    Bill

    Using 9.34 in Win7x64

     
    • Igor Pavlov

      Igor Pavlov - 2014-08-27

      Is 7-Zip 32-bit or x64?
      I can't reproduce the bug.
      Maybe there was such bug in some old version.
      So please check again that you use 9.34 alpha (look to Help / About window)
      And describe exact actions to crash.

       
      • BillAnt

        BillAnt - 2014-08-31

        Using 9.34 in Win7x64

        Weird because I can reproduce it consistently.
        Just open the archive in the link above then select View > Flat View
        Select all files and try to extract them, it should crash.
        When not in Flat View mode it works fine with the same archive.

        If it doesn't crash for you then I have no idea why I've tried 9.34 on 3 different computers with Win7x64 and it's happening consistently.

         
        • Marco

          Marco - 2014-08-31

          Hi,
          it crashes for me too, tested under Win7 x64 with 9.34 x64.
          The crash happens as soon as I press CRTL+A to select all files.

           
        • Igor Pavlov

          Igor Pavlov - 2014-08-31

          OK. Now I can reproduce it.
          There is bug in 9.26-9.34.
          7-Zip File Manager crashes in "Flat Mode", if there is file "dir\file", but there is no "dir\" item in archive.

          I'll fix it in next version.

          Thanks!

           
          • BillAnt

            BillAnt - 2014-09-11

            Funny thing is that I've been experiencing this crash since 9.26, but was too afraid to report it to the zip "master" ;)

             
  • superproz

    superproz - 2014-09-02

    I apologize for putting a feature request in a bug reporting thread, but I did check out this version to see if it did what I was hoping for.

    In the GUI, it would be handy to see what the equivalent command line would be. For example, this link shows someone trying to recreate on the command line what he can do in the GUI:

    http://stackoverflow.com/questions/22680954/7zip-ultra-lzma2-compression

    I have seen you give help of "7z l archive.7z -slt" to compare two 7z, one from CLI and one from GUI, but that wasn't too helpful.

    Even looking at some of the examples in the help doesn't really clear things up for me, like this:

    7z a -t7z archive.7z .exe .dll -m0=BCJ2 -m1=LZMA:d23 -m2=LZMA:d19 -m3=LZMA:d19 -mb0:1 -mb0s1:2 -mb0s2:3

    How does that relate to number of threads, for example? Does -m0 specify to use... something and then -m1 to -m3 spawn 3 threads? And mb0... what? The help text specifies:

    "using BCJ2 converter, LZMA with 8 MB dictionary for main output stream (s0), and LZMA with 512 KB dictionary for s1 and s2 output streams of BCJ2"

    After reading the help, I still am unclear on it.

    If you had, say, a CLI version of what people are clicking on listed at the bottom of the GUI, that would be really helpful. Right now I am using 7-Zip to compress 11 GB SQL backups and trying different permutations with the GUI to get the best balance of speed and size. However, I now realize I'm unsure how to translate all of these settings to the CLI. I did it before with .zip, easy (-mx=9 -mfb=256 -mpass=5 -mem=AES256) but looking at the 7z options it's daunting.

    And looking at BCJ2, it's for 32-bit only? So I can't even use it with 64-bit 7-Zip? If I want the best compression, do I need to use the 32-bit version? Confusing.

    So blah blah blah, the main request is for the GUI to show a CLI equivalent to what is being selected so it's easier to translate to something like a batch file.

    Thanks!

     
    • Igor Pavlov

      Igor Pavlov - 2014-09-03

      BCJ and BCJ2 are just filters to compress executables (EXE and DLL files).
      64-bit and 32-bit version provide same compression ratio.
      But 64-bit version allows larger dictionary.

      You can change dictionary size (d) and word size (fb) for 7z format:
      -mx9 -md128m -mfb256

       
  • grml4d

    grml4d - 2014-09-08

    i just used the 9.34 with some folders and found few things .
    first , if i select a size of X Mo for a multiparts archive and if archive is below this limit , then name is like 7z.001 while the 001 could be deleted...
    second thing , that is about same subject a posts above : when you select memory settings and threads that can go very high , if the total size of files is below the "required memory" , that value will be the maximum memory used .
    so may be you should update 7fm compression window .
    edit : it seems that it can go higher , at least above my 32 Go ram for 16 Go of files , 8 threads 1024M dict...

    with lzma2 and multiparts , i have troubles having all core used , is it normal because files are too small ?

     
    Last edit: grml4d 2014-09-08
    • Igor Pavlov

      Igor Pavlov - 2014-09-09

      7-Zip scans files and directories later.
      So it doesn't know exact size of files in directories at that stage.
      And if you select high settings for small files. Then later for big files such settings will move your system to swapping.

       
  • JHSands

    JHSands - 2014-09-08

    I don't see the "delete files after compression" switch on 7za. Please advise.

     
    • Igor Pavlov

      Igor Pavlov - 2014-09-09

      I'll fix it. You can use -sdel.

       
  • gora2

    gora2 - 2014-09-11

    https://dl.dropboxusercontent.com/u/35142695/7zip.PNG

    1a - tabulated digits
    1b - not tabulated digits

    2 Not translated headers

    3 Camel Style. Why? In Russian it is not used.

     
    • Igor Pavlov

      Igor Pavlov - 2014-09-11

      1 - Probably I'll fix it.
      2 - I still don't suggest to translate some specific fields.

       
  • Cenite

    Cenite - 2014-09-13

    Nice to see work done on such a great archive tool.

    I have a few bugs and comments:
    (0) The current version creates the temp files on the target disk volumes and does not extract the files to Windows temp folder (%tmp%) and then copy them to the target folder anymore. (4 times disk IO) Extracting the files directly from source to destination volume is great. Especially since I often work with archives bigger than 4GB this makes it much faster. Thx :)

    (1) Root folder duplication only works if the archive name and the root folder name inside the archive are the same. It would be quite useful if this would not depend on the name:
    I.e. if multiple files/folders are at the root of the archive create a new folder from the archive name (like now) or if it's only one folder at the root then use this name to extract all the contents. (like with the root folder duplication option)

    It would also be nice to have this as an additional context menu option (e.g. "Extract into seperate folder" instead of "Extract into [archive name]\" ) available, too.

    (2) File associations are not changed when run under a standard user account (Windows 8.1 x64). Error Message "Access denied" if the user tries to change something under "All users".

    Solution proposal: Automatically acquire elevated rights for actions like this when run without administrator priviledges or at least add a message that this action requires 7-Zip being "run as administrator" if applying the changes fails. A simple refresh of the associations listing already reveals that nothing has changed.

    (3) Entering a wrong archive password shows the message "The file ... can't be opened as an archive. Wrong password?" It would be nice to have the password dialog shown again if the original archive was indeed password protected. A simple bool carry on flag for password protection may do the trick.

    (4) Dragging some files from a password protected 7z archive unto a Windows Explorer folder window led to the error message: "Wrong parameters" The files were temporarily stored in the %tmp% but never moved/copied to the destination folder. Unfortunately I can't reproduce the error even with the same archive, destination folder and file selection. Maybe you have an idea where there could be a bug inside 7-Zip, if it weren't Windows' fault.

    (5) Adding files to an existing archive does not work any more over the context menu options "Add to "test.7z"", "Add to "test.zip" or "Add to an archive..." , neither for encrypted nor unencrypted archives. Error Message: "Access denied. 7-Zip cannot open file test.7z.tmp".

    This may/may not have something to do with my selected working directory: current folder under Settings>(Tab) Folder.

    (6) From my previously installed 7-Zip version (9.20 I think):
    When adding new files, not yet contained in the archive, to an encrypted 7z archive, they are added unencrypted (over the "Add to "test.7z"" in the context menu). Same for zip archives but existing encrypted files are replaced by their newly added unencrypted version as well.

    Is this behaviour in all cases really intended?

    Thanks a lot for all the effort you put into 7-Zip.

     
    Last edit: Cenite 2014-09-14
  • Alex

    Alex - 2014-09-27

    is there a portable version? or at least an installer with installation location select.

     
  • grml4d

    grml4d - 2014-10-03

    @Alex : for what ?
    hl2 mods are to be installed in ...steam\SteamApps\sourcemods

    @igor : what about my movie , do you like it ?...["8
    it s a pleasure to find and a second pleasure to report : bugs like this one :-*

     
  • Alex

    Alex - 2014-10-03

    grml4d, portable version of 7zip, it's a forum of 7zip isn't it?

     
    Last edit: Alex 2014-10-03
  • gora2

    gora2 - 2014-10-03

    @ Alex

    installer with installation location select

    7z934-x64.msi INSTALLDIR="E:\7-zip 9.34"

     
    Last edit: gora2 2014-10-03
  • pukovnice

    pukovnice - 2014-10-16

    Is 7zip still being developed or does Igor not care anymore? Please come back, please release a beta, please put in RAR5 support. No more alphas, this would show at least people that something still happens. Else we will never get a stable again before 2020.

     
    • szfong

      szfong - 2014-10-19

      Is 7zip still being developed or does Igor not care anymore? Please come back, please release a beta, please put in RAR5 support. No more alphas, this would show at least people that something still happens. Else we will never get a stable again before 2020.

      I believe it only gets brief development every once in awhile by Igor. In all intensive purposes, it seems not to be a priority for him and is once again undergoing a long hiatus. 7-Zip 9.20 serves my simple needs and I use WinRAR for everything else. PeaZip on Sourceforge is also quite good/popular....

       
      Last edit: szfong 2014-10-19
  • grml4d

    grml4d - 2014-10-20

    i used Disk2vhd : http://technet.microsoft.com/en-us/sysinternals/ee656415.aspx
    to backup a 60 Go ssd with a fresh win7

    it created me a 7.20 GB (7,742,602,240 bytes) file in few minutes , i found that so incredible that i created a 60 Go vhd using disk management console and made a copy of my partition with a backup tool in this 60 Go vhd

    i used 7z 9.34 to compress it uzing 7z-lzma2 setting with 8Go of ram free and 16 threads, after 90 minutes or so , the resulting file is 13.0 GB (13,991,225,093 bytes)...

    i tried to create the archive on a 32 Go usb stick but quickly had a crashbox saying not enough disk-space . i created a sfx archive but if i launch it the mbox says that it is not a valid win32 application . i was able to extracct file with 7z9.34 gui.

     
    • Igor Pavlov

      Igor Pavlov - 2014-10-20

      Don't create big sfx archives.
      Windows doesn't run exe files larger than 4 GB (or 2 GB).

       
      • szfong

        szfong - 2014-10-20

        Don't create big sfx archives.
        Windows doesn't run exe files larger than 4 GB (or 2 GB).

        I wonder if 7-Zip can create an SFX stub that has the same filename as the large 7z file (different extension, of course)....

        Adobe uses this method to distribute all their massive 4 GB+ application software.

         
        • Igor Pavlov

          Igor Pavlov - 2014-10-20

          9.32 alpha 2013-12-01

          • 7-Zip now can create multivolume SFX archives in 7z format.
            Standalone sfx module now can unpack external 7z archive with name that is
            matched to name of sfx module. For example, sfx module renamed to archive.exe
            can unpack archive.7z or archive.7z.001 .
           
  • gora2

    gora2 - 2014-10-21

    Command "I" has any use for the user?

     
  • manju_86

    manju_86 - 2014-10-25

    hi Igor!

    i took the liberty to review and translate\update the pt-p language file for 7-Zip 9.34 Alpha, based on English file provided on installation.

    this may not be the best place to leave it but i'm not sure where to send it (your email doesn't show on 7-zip's page :\ ), so i'll place a dropboxed link here for the file ;)

    https://dl.dropboxusercontent.com/u/45436175/7-Zip%209.34%20Alpha%20pt-pt.7z

     
    • Igor Pavlov

      Igor Pavlov - 2014-10-25

      It's better to upload translation files to patches section.

       
  • Anonymous

    Anonymous - 2014-10-30

    @Igor

    Complete fr language file for 7-Zip 9.34 Alpha.

    https://sourceforge.net/p/sevenzip/patches/246/

     
    Last edit: Anonymous 2014-10-30
  • chrislong

    chrislong - 2014-11-06

    Igor,

    I use 7-Zip in a "mission critical" application where data integrity is important. 7-zip 9.20 and 9.22b both contain a bug that produces seemingly random CRC errors when dealing with large amounts of data (i.e. backing up your user profile folder on Windows). This seems to be solved in the newer alpha releases (9.34 especially in my limited testing seems to not have this problem). However, the alpha releases have their own rather serious bugs. I just read on this thread how 9.34 has recently introduced other data-related bugs. It also has broken other functionality.

    My question/point is this:

    There is NO version of 7-Zip right now that really can be used for reliable archiving.

    I thank you for 7-Zip, but could you please just release a version that's sole purpose is to fix the bugs found in it? You keep releasing versions that, while fixing bugs, also keep introducing new features/changes, which inevitably introduce new bugs. Please, I beg, forget about "innovating" for a few versions and just release a few alphas that solely fix the bugs that people find. Then you can release a new beta and stable version! 9.20, with it's rather serious CRC error problem, I don't consider stable in the slightest!

    By the way, I'm not the only one to be in this predicament: See the following:
    http://sourceforge.net/p/sevenzip/discussion/45797/thread/54561e50/

    Thanks Igor for your consideration. I appreciate you and your work. :)
    Chris

    p.s. - also, you state not to use 9.34 in production environments and mention possibly using 9.30 or 9.25, however I need the cmd line 7za.exe - I can't find the "extra" package for 9.30 or 9.25 that contains this to even try it.

     
    Last edit: chrislong 2014-11-06
  • chrislong

    chrislong - 2014-11-10

    Igor, any news when we might be able to expect 9.35? The -ssw problem is my biggest concern right now, hopefully you've got that fixed. Also, please release command-line version / extra package when you do so there will be a recent version of 7za that has the -ssw working. Thank you.

     
    Last edit: chrislong 2014-11-10
  • SharkyEXE

    SharkyEXE - 2014-11-11

    Igor,

    My OS: Windows 8.1 update 1 Pro x64 Russian
    I use: 7-Zip 9.34 alpha x64

    In 7-Zip 9.34 alpha x64 there is a problem:

    Situation 1:
    1) In my OS * .jpg extension is associated with the program "Viewing Photos Windows": 2014-11-11_1.gif
    2) On the desktop is located the archive 1.zip, inside the archive 1.zip is located file 1.jpg
    3) Using the software 7-Zip 9.34 alpha x64, I open archive 1.zip
    4) Inside the archive 1.zip I once left mouse click on the file 1.jpg
    5) On the keyboard I pressed the button "Enter"
    6) I issued a: 2014-11-11_2.gif
    Everything is bad, so there should be, a file 1.jpg not shown in "Viewing Photos Windows"

    Situation 2:
    1) In my OS extensions * .jpg I make associations with the program "Paint": 2014-11-11_3.gif
    2) On the desktop is located the archive 1.zip, inside the archive 1.zip is located file 1.jpg
    3) Using the software 7-Zip 9.34 alpha x64, I open archive 1.zip
    4) Inside the archive 1.zip I once left mouse click on the file 1.jpg
    5) On the keyboard I pressed the button "Enter"
    6) I issued a: 2014-11-11_4.gif
    Everything is fine, as it should be, the file 1.jpg is displayed in the program "Paint"

    Please fix bug, described in "Situation 1"

    Thank You!

     
    Last edit: SharkyEXE 2014-11-11
  • chrislong

    chrislong - 2014-11-19

    Igor, I've found what apparently is a bug but it seems to have existed for a long time - at least back to 4.53.3 (earliest I tested).

    Consider the following 7za cmdline:
    7za.exe u -r- -tzip -up1q0r2x1y2z1w2 -ssw "E:!Backups\Util\Util.zip" "C:\Util*.*"

    Assume that Util.zip does NOT exist. Also assume that C:\Util folder has several subfolders, 1 of which has a period in its name.

    In this example, Util.zip will end up with only the files in C:\Util, but will ALSO have the subfolder (and it's files) of the subfolder that has a period in its name.

     
  • Igor Pavlov

    Igor Pavlov - 2014-11-19

    -r- only sets the way to find the file / folder,
    But if it have found the folder, it compresses all files and subfolders.
    To restrict it you must use -x switch:

    -x!*\*\
    
     
  • foxpat

    foxpat - 2014-11-22

    You guys like it or not if Igor does not release the code he has to change 7z license. His software is not Alpha quality; his software is not now GNU GPL as he declares. Those are the facts.
    Period.

    I have been always a big fan of Igor and his work but after 3 years without publishing his code and recently telling me that he cannot publish his source because he's now coding the "single thread version" of 7z I started to think he is probably making fun of me and the rest of us. Not cool.

     
    Last edit: foxpat 2014-11-22
    • Igor Pavlov

      Igor Pavlov - 2014-11-22

      Yes, alpha is not LGPL'ed.
      alpha should be short_time version.
      I didn't expect such difficulties with started changes.

      Actually "single thread version" is not main reason of delay. But that code showed another problems, that must be fixed. When I fix them, I see "bad" things in old code, so I had to change that code too.

      foxpat: If you don't like alphas, just forget about new 7-Zip for some months more.

       
      • foxpat

        foxpat - 2014-11-22

        Igor,
        Do not get me wrong; it is not my intention arguing with you and I hope you can fully understand why at this point I'm upset.

        You are now trying to code "the single thread version" of 7z what implies a major impact in the whole codebase; well that extra feature that you decided to add (and you said before it's the one that prevents you for publishing the code) is highly unnecessary today. Now you say that you discovered that there are "other" problems that we do not know and that AFAIK they are not reported by users here...

        Igor, let's be honest; your current codebase (9.34) is not Alpha quality by any means; you cannot call "Alpha" what is not alpha. Even 9.30 at the moment (2 years ago) was not Alpha quality either.
        Then if you want to keep calling your project GNU GPL please publish the code of the stable multi-thread 9.34 that everybody uses today. If you think that has errors just make a list of them and add it as "known issues" to be fixed in a future 7z release.

        If you do not want to do that, and after 3 YEARS of alphas that work very well, I encourage you to change the license of your project and please do not call it GNU GPL anymore.

        you know what? the alpha trick is an old one...

         
        Last edit: foxpat 2014-11-22
  • foxpat

    foxpat - 2014-11-22

    Igor just needs time to finish work on new version.

    That's not true.

    he always did stable versions with no or few bugs,

    That's not true

    always usable,

    That's true

    don't force him to release unfinished buggy shit,

    9.34 is made out of a very stable codebase

    lets wait and get stable source,one version, stable enough

    He already has it it is called 9.34

    or u want buggy source now, and 1000+ daily and nightly builds, rewritten, some compatible with others some not? me not.

    this is completely false; see how long 9.34 remains unchanged, see how many bugs reported. Obviously you do not know what you are talking about.

    so shut up and stop complaining.

    It's pretty clear who's the one that has has to shut up here.

     
    • Sr. Zé Alguém

      Sr. Zé Alguém - 2014-11-22

      Me, Igor itself and some others do see bugs in 9.34. It could be a Beta, but not stable in any way.

      Append "?limit=250" to the url of this topic so you can read all posts on one page.

      Imo, you're forgetting your own claim: Igor should give truthful expectations whether he will or not release an open version and when.

      Very probably he doesn't care about transparency.

      russ

       
      • foxpat

        foxpat - 2014-11-22

        Please guys stop the game; 9.34 is not Alpha, it does not have obvious bugs and it's very stable.

        If Igor doesn't care about transparency that's fine; I'll wait a couple of more days and after that I'll be forced to report EVERYWHERE that he is publishing for more than 3 YEARS now a GPL licensed software while he refuses to either publish the source or change to a different license. That's it.

        3 years of "Alpha games" and patience are more than enough.

         
  • gora2

    gora2 - 2014-11-25

    Hi, Igor
    Incorrect unpacking !?

    1 file - http://download.virtualbox.org/virtualbox/4.3.20/Oracle_VM_VirtualBox_Extension_Pack-4.3.20-96996.vbox-extpack
    2 unpack this:

    7z x Oracle_VM_VirtualBox_Extension_Pack-4.3.20-96996.vbox-extpack -oa
    7z x a\* -ob

    3 we have a strange catalog - b\[]
    4 when unpacking 7z.exe version 9.30 this directory ( b\[] ) is missing.

     
    • Igor Pavlov

      Igor Pavlov - 2014-11-25

      [] item was for item that has no name './'.

      Probably I've fixed already that problem in my current 9.35 code.

       
      • CoolOppo

        CoolOppo - 2014-11-27

        Igor, please release the code. It would cause a lot of frustration to go away if you did it, especially if you use GitHub or Bitbucket so that other coders may collaborate and create pull requests to help you out with 7-Zip. At the very least, it would shut up skeptics concerned with malware in the releases. At the best, you could be working with others to push out new features and bug fixes at a much faster rate, and with more ease. Seriously consider it; I have only the best in mind.

         
  • Philippe Ombredanne

    +1 to publish the history and the ongoing development of the code in some version control system...
    It could be done @ sf.net here easily

    Igor: would you have any special reason why not doing so? Happy new year and thank you for 7zip in anycase!

     
  • Abdou

    Abdou - 2015-12-30

    Hello Igor, I can't preview (F3) files with Russian names

     

Log in to post a comment.