7-Zip 9.34 alpha

2014-06-22
2016-03-23
<< < 1 2 3 4 5 6 > >> (Page 4 of 6)
  • Igor Pavlov

    Igor Pavlov - 2014-07-30

    Yes, 7-zip opens first cab, even if there is larger cab later.
    Now I'm not ready to change that code.

     
    • gora2

      gora2 - 2014-07-30

      If one cab, then need to open it
      If more than one cab then enter the cab is not necessary.

       
  • Martin Claus

    Martin Claus - 2014-08-08

    It would be great to include some kind of helper which connects to selected filetypes for all users. If I start 7Zip as limited user and try to set it for all users I get an "Access denied" error. So an additional program which request the uac would be very helpful.

     
    Last edit: Martin Claus 2014-08-08
    • Hobby-boy

      Hobby-boy - 2014-08-08

      Similar to what WinRAR does when you change associations?

       
      • Martin Claus

        Martin Claus - 2014-08-10

        I don't know how Winrar is working. But most programs are downloading stuff like updates and to install the updates the programs are requesting administrative rights. All gaming platform use that for game installations.
        So the program itself is able to start in limited mode and requests administrative rights if required.

         
  • Rich McGrew

    Rich McGrew - 2014-08-11

    Hello, I have 3 features I request please.

    1) Files that are .tar.gz or .tar.bz2 or .tar.xz (or alternate extensions .tgz or .tbz2 or .txz) should have an option to extract all at once instead of first extracting .tar from .gz/.bz2/.xz and secondly extracting files from .tar. This does not need to be default behavior, it could be an option in the preferences.

    2) Currently I look inside an archive before extracting it. If everything is in one directory then I use the "Extract Here" context menu item. If the files and directories are in the root directory of the archive I extract the archive into a directory with the same name as the archive, using a different context menu item. Perhaps there can be an option to do this behavior automatically so I don't have to manually check if all files are in the same directory inside the archive... an option to extract it into its own directory that won't create a directory with just another directory inside it and all the files in that, because that is too complicated and Windows is not happy if you go too many directories deep and go over the maximum path length. And if the archive is several levels of just one directory it would go through each of those until it gets to a level with at least one file and/or more than one file/directory. This would option would still preserve subdirectories of the first directory that has more than one entry. Anyway this would make it a little more convenient to use.

    3) Change the default Ultra/"-mx=9" compression options for Deflate to include "-mpass=15 -mfb=258" for even better compression.

     
  • gora2

    gora2 - 2014-08-20

    Hi, Igor
    Installer JAVA - jre-8u20-windows-i586.exe (http://www.oracle.com/technetwork/java/javase/downloads/jre8-downloads-2133155.html)

    I'm trying to extract the files: .rsrc\1033\JAVA_INSTALLER\103 and .rsrc\1033\JAVA_INSTALLER\105

    1 From the command line - getting error
    2 7zFM click "Extract" - getting error
    3 7zFM drag the files to another folder - 7zFM hangs! :(

    Previous installers of JAVA extracted without problems.

     
    • Igor Pavlov

      Igor Pavlov - 2014-08-20

      Yes, 7-Zip can't work with UPX archives.
      3. It's old drag and drop mouse hang problem. Use keyboard.

       
    • Synetech

      Synetech - 2016-03-23

      Unfortunately Oracle doesn’t like the concept of portable and wants to force everybody to use their installer no matter what. The best I can offer at the moment is to install the JRE, then get the MSI from Administrator\AppData\LocalLow\Oracle\Java\jre…, then uninstall the JRE. Then you can extract the files from the installerexe from the Data1.cab from the MSI file.

      Fortunately the 64-bit version of the JRE installer has not been ruined yet and you can extract it without having to first install (or run the executable at all).

      I’m really not sure why the 32-bit installer wraps the JRE in an MSI, but the 64-bit one doesn’t.

      Alternately, you could just forgo the installer altogether and just donwload the .gz archive.

       
      Last edit: Synetech 2016-03-23
  • Byron Taz

    Byron Taz - 2014-08-25

    Fizzles out or stops on larger files. 1st system and settings. Win 8.1 64 Bit AMD 8350 16 GB DDR3 OC Mem 256 GB SSD & 4TB 7200rpm HDD. 7-zip 9.34 alpha Settings Com Level Ultra, LZMA2, Dict Size 1024 MB, Word Size 273, Solid Block Size. On files under 2 GB everything works fast and fine, but if file is over 2 it will slow down around 2 GB, pause for about 5 min, then slowly start compressing again (but still much slower than the 1st 1.5 GB, however I tried to compress/split into 700MB files a file just under 7 GB last night and 7.5 hours later it was stuck at 5.4 GB, but the funny thing is I only had 2 of the sections 1 700 MB, and 1 that was 315 MB (just under 1 GB of actual files). I did another file the night before (about 6 GB) and it did the same thing. I compressed both of these files with WinRAR 5.10 and they took under 15 min with no problems. WinRAR compression settings RAR 5, Best Compress, Dict Size 1024 MB, Word Size 273, etc. Basically the best same settings as 7-zip. I know that 1024 Dict Size is a lot, but 16 GB should work (works with WinRAR) and both times I opened Task Manager and showed %85 used and %88 used. Note: when I compress files I'm only compressing file, and shut down every thing else.

    Thanks for all your hard work

     
    Last edit: Byron Taz 2014-08-25
    • Igor Pavlov

      Igor Pavlov - 2014-08-26

      When you select "1024 MB" dictionary, look also the line "Memory usage for compressing:" in "Add to Archive" dialog box. If that value is too large, just reduce the value in "Number of CPU threads" to 2.

       
      • Byron Taz

        Byron Taz - 2014-08-26

        Yea that worked. I changed it to 3 cores (Same mem usage as 2 cores) and worked fine. Question; is the memory usage for physical mem or virtual mem (pagefile)? Because my virtual mem is 38 GB and I could increase it more to use all 8 cores. Next question is; is this a bug? 38 GB virtual & 16 GB physical memory seems like it should be enough to compress a 6.5 GB file. Is this version not releasing memory or something elese?

        Thanks again for this great software.

         
        • Igor Pavlov

          Igor Pavlov - 2014-08-27

          Don't look virtual memory size. LZMA2 needs physical memory.

          It's not bug. LZMA2 needs about 11x times more memory than dictionary size for each 2 threads.
          For 1024 MB / 2 threads you need about 11 GB of physical memory, and 22 GB for 4 threads.

           
          • Byron Taz

            Byron Taz - 2014-08-27

            OK, thanks for the info and all your hard work. I guess if I want to compress files as small as possible, I'm limited to 3 cores.

            Thanks again.

             
  • BillAnt

    BillAnt - 2014-08-27

    When opening some archives (.zip, .exe or .msi) in Flat View mode, when you try to select some or all files for extraction it crashes the GUI. In non-flat view mode it works fine.
    Here's an example of a zip file you can try. Just click on the black download button.
    http://d-h.st/Bhx

    Bill

    Using 9.34 in Win7x64

     
    • Igor Pavlov

      Igor Pavlov - 2014-08-27

      Is 7-Zip 32-bit or x64?
      I can't reproduce the bug.
      Maybe there was such bug in some old version.
      So please check again that you use 9.34 alpha (look to Help / About window)
      And describe exact actions to crash.

       
      • BillAnt

        BillAnt - 2014-08-31

        Using 9.34 in Win7x64

        Weird because I can reproduce it consistently.
        Just open the archive in the link above then select View > Flat View
        Select all files and try to extract them, it should crash.
        When not in Flat View mode it works fine with the same archive.

        If it doesn't crash for you then I have no idea why I've tried 9.34 on 3 different computers with Win7x64 and it's happening consistently.

         
        • Marco

          Marco - 2014-08-31

          Hi,
          it crashes for me too, tested under Win7 x64 with 9.34 x64.
          The crash happens as soon as I press CRTL+A to select all files.

           
        • Igor Pavlov

          Igor Pavlov - 2014-08-31

          OK. Now I can reproduce it.
          There is bug in 9.26-9.34.
          7-Zip File Manager crashes in "Flat Mode", if there is file "dir\file", but there is no "dir\" item in archive.

          I'll fix it in next version.

          Thanks!

           
          • BillAnt

            BillAnt - 2014-09-11

            Funny thing is that I've been experiencing this crash since 9.26, but was too afraid to report it to the zip "master" ;)

             
  • superproz

    superproz - 2014-09-02

    I apologize for putting a feature request in a bug reporting thread, but I did check out this version to see if it did what I was hoping for.

    In the GUI, it would be handy to see what the equivalent command line would be. For example, this link shows someone trying to recreate on the command line what he can do in the GUI:

    http://stackoverflow.com/questions/22680954/7zip-ultra-lzma2-compression

    I have seen you give help of "7z l archive.7z -slt" to compare two 7z, one from CLI and one from GUI, but that wasn't too helpful.

    Even looking at some of the examples in the help doesn't really clear things up for me, like this:

    7z a -t7z archive.7z .exe .dll -m0=BCJ2 -m1=LZMA:d23 -m2=LZMA:d19 -m3=LZMA:d19 -mb0:1 -mb0s1:2 -mb0s2:3

    How does that relate to number of threads, for example? Does -m0 specify to use... something and then -m1 to -m3 spawn 3 threads? And mb0... what? The help text specifies:

    "using BCJ2 converter, LZMA with 8 MB dictionary for main output stream (s0), and LZMA with 512 KB dictionary for s1 and s2 output streams of BCJ2"

    After reading the help, I still am unclear on it.

    If you had, say, a CLI version of what people are clicking on listed at the bottom of the GUI, that would be really helpful. Right now I am using 7-Zip to compress 11 GB SQL backups and trying different permutations with the GUI to get the best balance of speed and size. However, I now realize I'm unsure how to translate all of these settings to the CLI. I did it before with .zip, easy (-mx=9 -mfb=256 -mpass=5 -mem=AES256) but looking at the 7z options it's daunting.

    And looking at BCJ2, it's for 32-bit only? So I can't even use it with 64-bit 7-Zip? If I want the best compression, do I need to use the 32-bit version? Confusing.

    So blah blah blah, the main request is for the GUI to show a CLI equivalent to what is being selected so it's easier to translate to something like a batch file.

    Thanks!

     
    • Igor Pavlov

      Igor Pavlov - 2014-09-03

      BCJ and BCJ2 are just filters to compress executables (EXE and DLL files).
      64-bit and 32-bit version provide same compression ratio.
      But 64-bit version allows larger dictionary.

      You can change dictionary size (d) and word size (fb) for 7z format:
      -mx9 -md128m -mfb256

       
  • grml4d

    grml4d - 2014-09-08

    i just used the 9.34 with some folders and found few things .
    first , if i select a size of X Mo for a multiparts archive and if archive is below this limit , then name is like 7z.001 while the 001 could be deleted...
    second thing , that is about same subject a posts above : when you select memory settings and threads that can go very high , if the total size of files is below the "required memory" , that value will be the maximum memory used .
    so may be you should update 7fm compression window .
    edit : it seems that it can go higher , at least above my 32 Go ram for 16 Go of files , 8 threads 1024M dict...

    with lzma2 and multiparts , i have troubles having all core used , is it normal because files are too small ?

     
    Last edit: grml4d 2014-09-08
<< < 1 2 3 4 5 6 > >> (Page 4 of 6)

Log in to post a comment.