#1425 Error extracting NSIS installers created on Linux

open
nobody
None
5
2014-08-08
2014-08-07
No

I have installers, that are built from the same .nsi file on Windows and Linux. The ones built on Windows can be extracted, but the Linux ones either don't extract at all or it gives "Data error" for some files. The ones with errors are 0 bytes after the extraction. It does detect all the files thought just some are 0 bytes.

The Linux system is Debian 6.0.2 and the installed NSIS version is v2.46-2 from the official repository.

Discussion

  • Igor Pavlov

    Igor Pavlov - 2014-08-08

    Try 7-Zip 9.34 alpha.

     
  • Oliver Stöneberg

    Ah...forgot to mention which version I am using.

    I experienced the issues with 7.20 and saw in the release notes, that 7.32 improved the NSIS support. So I updated to 7.34 and it didn't help.

     
  • Igor Pavlov

    Igor Pavlov - 2014-08-08

    Please create small example, and attach file here.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks