Input error using telnet, no error locally

  • lumothesinner

    lumothesinner - 2012-09-19

    Hi There!

    Having an issue when connecting via telnet to a CISCO ASA5505.  Upon connection the terminal looks like it gets a massive number of inputs that seems to continue indefinitely.  The screen scrolls indefinitely with entries like "ERROR: % Invalid input detected at '^' marker." and the name of the device being entered, not just reported, it looks like these are actually entered into the console and the return button pressed.

    When connecting locally using minicom it will cycle through the remainder of key presses sent for a few seconds then return control to me and allow me to use the terminal correctly.  Upon reconnection using minicom the terminal is working fine.  Only over telnet does this problem occur.

    The fact that minicom works suggests that its not a hardware issue with the USB to serial converter I am using. 
    I have tried changing the options for my line but nothing seems to make a difference
    6001:telnet:60:/dev/HUB1-1:9600 8DATABITS EVEN 1STOPBIT -LOCAL NOBREAK banner
    I am using a udev alias so that if my multiple usb entries get disconnected and reconnect on a different ttyUSB# I have them still mapped to the correct telnet port.

    Do you have any idea what could be causing this issue?
    Any help would be appreciated.



  • Corey Minyard

    Corey Minyard - 2012-09-19

    I assume the data scrolling on the screen comes from the serial port, not ser2net itself.

    What is the banner you have?

    Have you tried it in raw mode (not telnet)?

    Can you enable the control port and then use "monitor tcp <port>" to see what is coming in on the tcp port when you connect?

    I'm guessing that the data is somehow interfering with the telnet initialization sequences, but I can't see how that would happen.  The above should help me narrow it down.

  • lumothesinner

    lumothesinner - 2012-09-24


    Sorry for the delay, I was, and still am, having trouble with the control port setting.

    Have not changed the banner, it’s the standard:
    BANNER:banner:\r\nser2net port \p device \d  (Debian GNU/Linux)\r\n\r\n

    I have tried raw mode and I get no output from the device using this protocol.  Nothing I enter gets a response.

    I have tried a few things to enable the control port but kept failing on the port I was trying.  Have also tried changing the port number and using other devices.  I have multiple, similar devices all with the same issue.  I cannot seem to controller session working on any port.  Any port listed in my ser2net.conf says unable to connect and any other port I tried just to see what would happen does not start any session, just gives me a new line without an error message.

    I agree that the data is probably coming form the serial port as it does not start until I press enter/tab to get a response from the console.

  • Corey Minyard

    Corey Minyard - 2012-09-25

    I think you are misunderstanding how to use the controller port.  You pick an unused port (say 9000, *not* one in the ser2net.conf file) then specify that on the command line, like "ser2net -p 9000".  Then do a "telnet localhost 9000" and you should be in.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks