Hey,

> Should I keep the SMWCompatibilityHelpers code in SIO for now, since there's no alternative at the moment?

There is no reason to do effort changing it to whatever the new approach is since it's going to break in 1.8 anyway. So I'd just stick with using the compatibility helper class for now.

Cheers

--
Jeroen De Dauw
http://www.bn2vs.com
Don't panic. Don't be evil.
--