Hey,

I have been playing around with Composer [0] a bit recently. Though I'm not yet at the point where one can install SMW as MediaWiki extension in an existing MediaWiki install, it is now possible to install the dependencies of SMW using composer.

This means that when you have a working MW install and get a clone from SMW that you include in LocalSettings, you no longer have to care about which dependencies SMW has, much less which versions you need or where to get them. You can simply run "composer install" in the SMW directory and Composer will fetch the dependencies, which will automatically be loaded by SMW. Updating the dependencies at some later point can be done using "composer update".

Once we got full Composer support, we will have made installation for the users simpler, will be able to split up our code more and rely on more third party libraries.

This is not on master quite yet, this first needs to be merged: https://gerrit.wikimedia.org/r/#/c/67621/

[0] http://getcomposer.org/

Cheers

--
Jeroen De Dauw
http://www.bn2vs.com
Don't panic. Don't be evil. ~=[,,_,,]:3
--