Hi Patrick,

Indeed, that's a bug in SIO - I just fixed it in SVN, here:


If you re-update the code, it should work fine.


On Fri, Jun 25, 2010 at 10:40 PM, Patrick Nagel <mail@patrick-nagel.net> wrote:

I just tried the latest SVN version of SIO, and am getting a database error on
saving a page containing a #set_internal call:

A database query syntax error has occurred. This may indicate a bug in the
software. The last attempted database query was:

(SQL query hidden)

from within function "SIO::deleteCoordsData". MySQL returned error "1146:
Table 'wiki.sm_coords' doesn't exist (localhost)".

I believe SIO should first make sure, SM is installed (or the relevant tables
are present in the database), since SM is not a prerequisite for SIO.


Key ID: 0x86E346D4 http://patrick-nagel.net/key.asc
Fingerprint: 7745 E1BE FA8B FBAD 76AB 2BFC C981 E686 86E3 46D4

This SF.net email is sponsored by Sprint
What will you do first with EVO, the first 4G phone?
Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
Semediawiki-devel mailing list

WikiWorks MediaWiki Consulting http://wikiworks.com