For SRF-Ploticus users, 

You may want to update your Ploticus to v2.41. (http://ploticus.sourceforge.net)

There were several Ploticus bugs that we reported to Steve Grubb, Ploticus creator, and they have all been addressed.

SRF-Ploticus trunk has been updated as well to remove the workarounds around these bugs.

You can now use legends (turned on automatically with headers=show in prefabs) without causing Ploticus to abort.

Enjoy,
Joel