I’ve been struggling with this error for weeks now, and can’t seem to get any resolution.  I’m hoping that someone can give me an idea of what might be going on.

 

First, here’s my specs on our setup:

 

MediaWiki 1.17.2
PHP 5.2.11 (apache2handler)
MySQL 5.0.67
Apache running on Solaris 10.
User Merge and Delete (Version 1.6.1)
UserStats (Version v1.12.0
BreadCrumbs
Gnuplot
ScriptManager Extension (Version 1.6.0_1 [B16])
Secure HTML
ARCLibrary (Version 1.6.0_2 [B16])
DiscussionThreading (Version 1.3)
HaloACL (Version 1.6.0_19 [B16])

 

And a little history:

 

At first, I installed the Web Admin tool, and then used it to install HaloACL and it’s dependencies (ARCLibrary, ScriptManager).  The dependencies install fine, but when it gets to HaloACL, I get the following error, I’m assuming, from when it runs smwadmin.sh for the install:

 

Setting global permissions:
Setting permissions for group 'Knowledge architect':read,edit,manage,upload
Setting permissions for group 'Knowledge consumer':read,edit
Setting permissions for group 'user':read,edit
Setting permissions for group 'Knowledge provider':read,edit,upload
Setting permissions for group 'sysop':read,edit,manage,upload,administrate,technical,createaccount
Setting permissions for group 'bureaucrat':read,edit,manage,upload,administrate,technical,createaccountUnexpected non-MediaWiki exception encountered, of type "InstallationError"
exception 'InstallationError' in /var/apache2/htdocs/swiki/swiki/deployment/tools/smwadmin/DF_ResourceInstaller.php:66
Stack trace:
#0 /var/apache2/htdocs/swiki/swiki/deployment/tools/smwadmin/DF_Installer.php(741): ResourceInstaller->installOrUpdateWikidumps(Object(DeployDescriptor), '', 1)
#1 /var/apache2/htdocs/swiki/swiki/deployment/tools/smwadmin/smwadmin.php(375): Installer->initializePackages()
#2 {main}

 

Subsequent attempts at running smwadmin.sh –finalize give the same error.

 

The extension, however, DOES work, with a few funky problems with the “Save” button being disabled when using Internet Explorer.  So, I’m assuming that the installation isn’t complete.    The Save button has no problem in Firefox, and that’s what we’re telling our users to use for now until we get this problem resolved.

 

So, this week, while working on a development version of the Wiki installation, I accidentally removed the HaloACL directory on our production box, thinking I was on our development box.   Arrgh!  I’ve gotten the directory restored, but I basically had to start over and re-install the entire kit-n-kaboodle: Web Admin, HaloACL and dependencies.   NOW, when I bring up the Special page when logged in with the correct privs, The HaloACL link is simply GONE.    I re-installed once again, this time letting the Web Admin tool install ARCLibrary and ScriptManager, and then installing HaloACL manually.  Same result.  The link for the HaloACL extension isn’t in the Special list.

 

So, I’ll stop there, and see if anyone has any suggestions as to what to try next.  I’ve tried to install the new 1.7 version of everything, but that’s even worse – I’ll save that for another time.