Errors when using Archive database

BASE-user
Rhomboid
2008-10-14
2013-06-03
  • Rhomboid

    Rhomboid - 2008-10-14

    I've started using the CVS version because I've had all kinds of problems with the archive database since the 1.2.x series and I got tired of not being able to upgrade. I've tried setting up a blank database and using the included SQL script (mysql) to set up the tables and I've also even tried copying the non-archive Alert database to the Archive with the same results.

    The only perhaps "odd" thing I can think of is that my Alert and Archive databases are on different machines.

    This is the error I get currently when I go from the Archive home page to "Most frequent 5 unique alerts" and try to use the "Source" or "Destination" links or "Source Port" or "Destination Port" TCP/UDP links. I get the same error when trying to select any of the linked totals under "Source address" or "Dest. address" as well. These functions work fine on the Alert database, just not the Archive.

    /var/www/base-cvs/includes/base_cache.inc.php448: $ERROR: number_sensors_array is NOT an array!
    /var/www/base-cvs/includes/base_cache.inc.php456: $ERROR: number_sensors_array is either NULL or empty!

     
    • Rhomboid

      Rhomboid - 2008-10-14

      Oh, this is Apache 2, PHP 5.2 and MySQL 5.0.32 on Debian 4.0 (standard packages).

       
    • Juergen Leising

      Juergen Leising - 2008-10-16

      Hello Bryn,

      could you please set

      $debug_mode = 1;

      rerun your query and post the results here?

      Thanks.

      Bye, bye

      Juergen

       
    • Rhomboid

      Rhomboid - 2008-10-18

      When I enable debug mode and try to use the Archive database I simply get this:

      Session Registered
      Checking for DB abstraction lib in '/usr/share/php/adodb/adodb.inc.php'

      Warning: Cannot modify header information - headers already sent by (output started at /var/www/base-cvs/includes/base_state_common.inc.php:92) in /var/www/base-cvs/base_main.php on line 79

      Warning: Cannot modify header information - headers already sent by (output started at /var/www/base-cvs/includes/base_state_common.inc.php:92) in /var/www/base-cvs/base_common.php on line 1077

       
    • Rhomboid

      Rhomboid - 2008-10-27

      Follow-up: Reverted to 1.2.7 on same machine. Everything works again.

       
    • Rhomboid

      Rhomboid - 2009-06-12

      I managed to sort of fix this by setting up a second instance of BASE purely for the archive, pointing it at the archive db as its alert database. I use the main instance now to move alerts into the archive db but anytime I need to work with the archive db I use the separate archive BASE install.

      So something apparently changed in the last several versions of BASE that broke archive handling.

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks