jerry lowery - 2010-03-21

After updating to the latest version of PHP in debian, I get the below error message when using BASE.

Deprecated: Function ereg_replace() is deprecated in /usr/share/acidbase/includes/base_state_common.inc.php  on line 184

It appears ereg_replace is still used in BASE 1.4.5. From what I have read, preg_replace is now used but the syntax is not clear to me on how to fix the error. Any ideas?