My BASE only shows Index of Files/Folders

  • William Avila

    William Avila - 2009-04-14

    Hi all!

    I have a problem with BASE whenever I go to https://snort_ip_address/base. Instead of showing the BASE page, it only shows the index of files and folders inside /var/www/html/base.

    I got the following versions of components installed on my IDS machine:

    - Snort 2.8.3.
    - Adodb
    - BASE 1.3.5
    - PHP 5.2.9
    - Mysql 5.0

    Snort is running without any problem with alerts and traffic being logged in /var/log/snort.

    Could anyone kindly enlighten me what I could have possibly done wrong on my setup. Your thoughts would be greatly appreciated. Thanks in advance.

    • Bijayant Kumar

      Bijayant Kumar - 2009-04-14

      Apache should be compiled with PHP support and vice versa. If it is, then add index.html/php as a DirectoryIndex in your apache configuration.

      • Anonymous - 2009-04-14

        i recently had the same problem and it was solved by:

        <IfModule dir_module>
            DirectoryIndex index.html index.php

        instead of:

        <IfModule dir_module>
            DirectoryIndex index.html

        at conf/httpd.conf

    • William Avila

      William Avila - 2009-04-14

      Hi Bijayant!

      Thank you so much for your response.

      BTW, I installed it using yum on Fedora 9. Initially all other components (i.e. mysql, Apache, PHP, pcre) were installed using "yum -y install httpd" as instructed in the document I got from However, It seems that some little components that PHP needed (e.g., PEAR, gd, libxml-2) were not installed using yum,  so I then reinstalled PHP from source.

      Following your suggestion, I first appended "index.html/php" in DirectoryIndex of /etc/httpd/conf/httpd.conf to no avail. I then attempted to re-compile/install PHP with the --with-httpd option,  restarted the httpd service and opened https://snort_ip_address/base, but still got the same page of index of files and folders.

      I also tried using ./configure --with-apache and got this error:

      - "Invalid apache directory - unable to find http.h under /usr/local/apache"

      Aparently what's installed on my machine is "httpd" and not apache, so I didnt find the directory /usr/local/apache.

      How do you think should I proceed next?

      BTW, just so you know, this is my first attempt to use a Linux distro.

      Thanks again.

      • Bijayant Kumar

        Bijayant Kumar - 2009-04-14

        Hi William,

        I am not familiar with Fedora, as I use Gentoo. As you have installed all the packages, you should have the file /etc/httpd/conf.d/php.conf. In this file add
        DirectoryIndex index.php
        if not in the file.
        NOTE : Please note the difference here index.html/php :)

        Then restart your httpd service.

        Assuming all the above configuration is correct then in file /etc/base/base_conf.php

        $BASE_urlpath = "/base";

        Hope this helps.

    • William Avila

      William Avila - 2009-04-17

      I got everything finally running as expected now after a fresh install on another Linux box. I figured it will take longer to sort everything to get a clue about the issue than to just start over. Thank you guys for all your inputs, that also help me through.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks