BASE Pages Not Displaying

BASE-user
slippryj
2009-12-23
2013-06-03
  • slippryj

    slippryj - 2009-12-23

    Disclaimer: I'm pretty new to all this.

    I have a seemingly successful installation of snort. I am able to see it triggering rules/alerts when I run it on cli and it seems to be okay when I start the daemon.

    The problem is with my base. I can see base incrementing/catching the rules and alerts but when I click any link, I get a blank page in my browser. Base refreshes just fine but none of the links work.

    I've got this initial install set up as a virtual machine, which makes it easy to roll back to certain checkpoints. I have tried this install with php5.3.x and php5.2.x and I've tried changing all the permissions in the /var/www/html/ directory to 755 and 777.

     
  • Juergen Leising

    Juergen Leising - 2009-12-24

    Hi,

    which version of BASE do you use?

    And what can you see in /var/log/httpd/error_log or ssl_error_log or wherever your web server stores the error messages?

    Bye,

    Juergen

     
  • Andrew McDonald

    Andrew McDonald - 2010-01-18

    Hi All,
    I have a working snort Centos machine which logs fine to the MySQL database.I am using base version 1.4.4 which I installed on the Centos 5 machine. I have installed adodb fine as well, however I get a blank page in my browser whenevr I try to load the base index page.

    The error in my error logs report the follwing
    PHP Notice:  Undefined variable: BASE_installID in /var/www/html/base/base_conf.php on line 25
    PHP Fatal error:  Call to undefined function mysql_pconnect() in /var/www/adodb/drivers/adodb-mysql.inc.php on line 3
    62

    Any assistance would be greatly appreciated.

     
  • Kevin Johnson

    Kevin Johnson - 2010-01-18

    You have two problems with your set up.  The first is that your error_reporting level is too low.  Follow the README instructions for setting this correctly.  But the main issue, which is what is breaking your set up is that you do not have the php-mysql libraries installed correctly.  There is an RPOM that is named something like php-mysql-version.rpm.  This needs to be added and Apache restarted.

    Kevin

     
  • Andrew McDonald

    Andrew McDonald - 2010-01-18

    Thanks Kevin,

    I should realised it was a missing php RPM dependency.

    Regards,
    Andrew.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks