Can't create BASE AG tables

BASE-user
Ed M.
2005-01-07
2013-06-03
  • Ed M.

    Ed M. - 2005-01-07

    Hello everyone,

    I was wondering if I could get a hand with some problems I'm having getting my BASE installation to work. When unpack BASE into my html docs directory and run through the setup, I get to the point where I click the Create BASE AG button, but nothing happens. I've installed BASE and ACID many time, but never ran into this one. The only difference is that I previously built my Snort boxes on RH 9 and FC1 platforms, and now I want to do it on FC3.  Anyway, see below for some of the platform details:

    OS = FC3 - installed only with the Appache Web server that ships with the distribution. I installed the following RPM's to provide the MySQL database and PHP:
    - MySQL-server-4.1.8-0.i386.rpm
    - MySQL-client-4.1.8-0.i386.rpm
    - MySQL-devel-4.1.8-0.i386.rpm
    - MySQL-shared-4.1.8-0.i386.rpm
    - MySQL-server-compat-4.1.8-0.i386.rpm
    - php-5.0.2-8.i386.rpm
    - php-devel-5.0.2-8.i386.rpm
    - php-gd-5.0.2-8.i386.rpm
    - php-mysql-5.0.2-8.i386.rpm
    - php-pear-5.0.2-8.i386.rpm

    I have also installed ADODB and Jpgraph-1.14

    All the servers and php seem to be working OK. As a side note, I manually created the tables and both the ACID and BASE main pages come up and appear normal. But when I click a link to drill down to see events, it always brings up the search criteria page. I am getting Snort alerts because OpenAanval is working correctly on this installation and displaing alerts. I'm not sure where to go from here, so if any one has any ideas, I'm all ears!

    Thanks,
    Ed M.

     
    • Kevin Johnson

      Kevin Johnson - 2005-01-09

      Hi-

      Did you get any type of error message when you tried to build the tables through the UI?  Could you enable sqltrace in the base_conf.php file and mail it to me at base@secureideas.net

      Thanks
      Kevin

       
    • Asgarot

      Asgarot - 2005-01-12

      Hi
      I have the same problem with same FC3 installation and rpm package.

      Any idea on how to solve ?

       
    • Ed M.

      Ed M. - 2005-01-19

      Quick update:

      Still seeing the same problem with BASE 1.0.1. 

      Seems like its a php thing.  I'm not a scripting expert so I'm kind of spinning my wheels at this point.  OpenAanval seems to work just fine, so I've been doing my network monitoring with that for the time being.

      Ed M.

       
    • Kevin Johnson

      Kevin Johnson - 2005-01-20

      Thanks for the update.  I am getting a Fedora core 3 machine set up and will look at it. 

      It will probably be this weekend.
      Kevin

       
    • Ed M.

      Ed M. - 2005-01-21

      One more update:

      I have an FC3 installation that is running with BASE, however, I had to compile mysql from source. Also, I selected php as part of the web server install when I built the box rather than installing it later with rpms. So, this box looks as follows:

      php 4.3.10
      apache 2.0.52
      mysql 4.0.18

      One thing I noticed from running phpinfo() on both boxes is that the 4.3.10 box - the one thats working - was compiled with the flag --with-gd=shared while the php 5.0.3 box was not. Don't know if this means anything being as how I installed the php-gd-5.0.3 rpm for gd support.

      Another difference I noticed in the phpinfo() output is that the good installation - php 4.3.10 - shows the mysql client API version is 3.23.58 while the non-working installation showes 4.1.8. Again, I'm not sure this has anything to do with it, but this tid-bit may be of value.

      I also don't want to imply that php-4.3.10 works and php 5 support is not working because I did a 4.3.10 installation on the broken box from RPM after removing the php 5 install and it yeilded the same result.

      It almost seems like there's a package missing or something gets configured differently when php is installed at the time of the OS build vs. after the fact with RPMs.

      Oh, I also noticed that my working installation had php-odbc installed and the broken one did not. I installed the php-odbc RPM and nothing changed.

      Next, I configured mysql to create a general log file so I can see the login attempts when I go through the BASE setup. I can see that the setup script actually does successfully login to mysql. It then changes the database to the snort database as I would expect, runs a series (6) of SHOW TABLES commands and two SHOW INDEX FROM event commands. If I read the setup4 script correctly, this is all expected behavior.

      However, this is where it all falls apart. On the broken box it just sits there at this point. On the working box, it preceeds to run the CREATE TABLES commands as expected.

      Here's where my scripting limitations come in because I don't know what is supposed to trigger the initiation of the CREATE TABLES commands. It looks to me like clicking the Create BASE AG button should be the trigger, but I claim no expertise in the matter so if anyone has any thoughts, let me know.

      Thanks,
      Ed M.

       
    • Ed M.

      Ed M. - 2005-01-22

      OK, I think I'm getting closer. I rolled back the version of mysql from 4.1.x to 4.0.23 and now BASE is working properly. I think it has something to do with the version of libmysqlclient.so. MySQL 4.1 puts a file named libmysqlclient.so.14 out there which is sym-linked to libmysqlclient.so, and in all my working installations with MySQL 4.0.x, libmysqlclient.so is sym-linked to libmysqlclient.so.12.

      Problem now is that in order to get this to work, I had to also roll back my PHP version to 4.3.10, because 5.0.3 wants libmysqlclient.so.14.

      I'm happier now that my installation is working, but I'd like to be able to run MySQL 4.1.x and PHP 5.0.x. So, if anyone has any pointers on how to make such a configuration work, let me know.

      Thanks,
      Ed M.

       
      • Kevin Johnson

        Kevin Johnson - 2005-01-22

        Glad to hear you figured out what was wrong....  I am sure there is a way to make that work....

        Kevin

         

Log in to post a comment.