applying patches

  • Mike Roberts

    Mike Roberts - 2010-07-17

    Worked like a charm. 

  • Mike Roberts

    Mike Roberts - 2010-07-17

    I see another error now.  From looking at this thread : I think I have to
    " change the following line in base_graph_display.php
    -- ./base_graph_display.php.orig 2010-03-05 16:06:17.000000000 +0100
    +++ ./base_graph_display.php 2010-04-11 23:52:13.000000000 +0200
    @@ -114,7 +114,7 @@
    // Create the graph area, legends on bottom - Alejandro
    - $Graph =& new Image_Graph(array('driver'=>'gd',
    + $Graph = new Image_Graph(array('driver'=>'gd',

    If graphs are not displayed properly (php5.3) you have to fix all the pear stuff
    (replace ereg_… with preg_…, replace '=& new' with '= new' …)  "  According to the author of the post.  I don't know however how to apply a diff, and where / which file is the "peer stuff" he mentions above.  Can you help please?  The previous error message was fixed by the patch, and I had to reinstall mysql.  I can see the first window of the gui.  But once I click on one of the links, I get this error message:

    Fatal error: Call to undefined method ProtocolFieldCriteria::ProtocolFieldCriteria() in /var/www/base/includes/ on line 1113

  • Will Urbanski

    Will Urbanski - 2010-07-19

    Let me make sure i'm following you correctly. You were able to install the patch and that fixed the regular expression issue, but you are NOT able to see graphs still? If you paste the diff code above into a text file you can patch it in like a normal .patch file.

  • Mike Roberts

    Mike Roberts - 2010-07-20

    Yes.  I see the first screen with the summary of various protocols and their related alerts.  Once I click on any of the links like the percentage of icmp alerts, I get the following error message: Fatal error: Call to undefined method ProtocolFieldCriteria::ProtocolFieldCriteria() in /var/www/base/includes/  on line 1113
    Here is the url I am trying to go to:
    I also tried what you suggested regarding adding the lines above to a file and using the patch command, I then restarted apache, but I see the same error:
    root@thunder:/var/www/base# patch -p0 < patch
    root@thunder:/var/www/base# /etc/init.d/apache2 restart
    * Restarting web server apache2                                                 … waiting                                                            

  • Juergen Leising

    Juergen Leising - 2010-07-21

    Hello Mike,

    this should be fixed in the CVS version of BASE. Could you give it a try?

    For CVS access:

    The CVS version of BASE can be found under base-php4. Simply ignore that reference to version 4.

    Bye, bye



Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks