Triggered Signature links don't work.

BASE-user
2009-07-12
2013-06-03
  • steve jones

    steve jones - 2009-07-12

    None of the links work under the triggered signature section.
    It's just HTML code like this:

    <FONT SIZE=-1>[<A HREF="http://www.openssl.org/news/secadv_20060928.txt" TARGET="_ACID_ALERT_DESC">url</A>]</FONT>

    Is there anyway to fix this ?

    Thanks.

     
    • ef2007

      ef2007 - 2009-07-13

      Same issue for me: I'm running BASE 1.4.3 (gabi) (1.4.3.1).

       
    • steve jones

      steve jones - 2009-07-13

      Sorry I should have said what version I'm using BASE 1.4.3.1.

       
    • Juergen Leising

      Juergen Leising - 2009-07-28

      Hello,

      this should be fixed in CVS, now. Hints for how to download from CVS can be found at

      https://sourceforge.net/scm/?type=cvs&group_id=103348

      Bye, bye

      Juergen

       
    • steve jones

      steve jones - 2009-07-30

      Hi Juergen,

      Thanks for the response. I have upgraded to BASE 1.4.4 (dawn).
      The triggered signature section is working now. The only other thing is I'm still getting connection refused (61) on all local whois. It's not a big deal to me but I thought I would mention it.

      Thanks.

       
      • Juergen Leising

        Juergen Leising - 2009-07-30

        There is presumably no local whois server listening, is it?

        lsof -n -P -i :43

        Bye, bye

        Juergen

         
    • steve jones

      steve jones - 2009-07-31

      No I'm not running a whois server but the local whois was working before.
      Plus why wouldn't it just do a whois from the command line...would that not show the same results ?

      Thanks.

       
      • Juergen Leising

        Juergen Leising - 2009-07-31

        ah, sorry, my fault, I did not even realize that you were referring to that  link "local whois".  Well, that calls the function CallWhoisServer() in includes/base_net.inc.php.  And then the function GetWhoisRaw().  This function tries to open a connection to a remote whois server, and, well,  that has failed.  There is not much what we can do, I believe.

        However, a bit strange is, that even that no-response is being written to the cache...

        Bye, bye

        Juergen

         
      • Juergen Leising

        Juergen Leising - 2009-08-01

        Hello Steve,

        in the meantime I had a closer look at the code, and I must say, it is a bug. And a fixable one.  Therefore I have changed several things:

        - negative whois responses are not saved to cache, any more. So retries are now possible, again.
        - In includes/base_net.inc.php there were numeric IP addresses hardcoded.  I have moved these to the configuration file. So the users can change those addresses more easily.
        - includes/base_net.inc.php now has more recent search strings, so that a forward situation is being recognized.  In such a case a second query to some other whois server is triggered.

        Now, could you please download the CVS version of BASE as described here:

        https://sourceforge.net/scm/?type=cvs&group_id=103348

        and make some tests whether it works as expected?

        Bye, bye

        Juergen

         
    • steve jones

      steve jones - 2009-08-01

      Hello Juergen,

      Local whois works now. Everything seems to be in order.

      Thank you.

       
    • steve jones

      steve jones - 2009-08-01

      I might have spoken to soon.
      It's working with some IP's but not all.
      I'm still getting Connection refused (61) on some IP's.

       
    • steve jones

      steve jones - 2009-08-01

      Now it's my mistake, sorry.
      Everything works !!
      Disregard the last message about some IP's not working I mistakenly used the older config file.

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks