Seashore compilation failure: GIMPCore.h

Developers
2006-05-16
2013-06-05
  • Nobody/Anonymous

    I'm having difficulty compiling Seashore on a MacBook Pro:

    error: GIMPCore/GIMPCore.h: no such file or directory

    I can see this header in the GIMPCore framework and have tried removing the reference to the TIFF and GIMPCore frameworks, then adding them back in (after compiling them of course).

    I'm fairly new to Mac OS X development, but I'd still like to help out with Seashore, especially running on MacIntels :).

    thanks,

    Andy

     
    • Nobody/Anonymous

      btw. I tried explicitly adding the directory holding the GIMPCore.h header file in the Header Search Paths (inside the target settings >> build tab).  No  luck :(

       
      • Philippe Casgrain

        1. Make sure that you build all the subprojects (including GIMPCore.xcodeproj) before building Seashore.xcodeproj.

        2. Make sure that you have a common "Built Products" folder. It can be any folder; set it using Xcode->Preferences->Building->Place Built Products in... Customized location.

        Write back if this doesn't work.

         

Log in to post a comment.