Maybe drop the SDCC package (from Synaptic/Apt), then build?  Maybe the build is finding the installed SDCC (without PIC) to try to build libs.

On Sat, Jan 22, 2011 at 2:22 AM, Jochen Becker <> wrote:
Hello List,
I am trying to install sdcc on an Ubuntu 10.04 LTS workstation for
targets like PIC 16s and 18s. Unfortunately all my attempts have failed:
the most obvious first,
- Ubuntu package (worked, but no PIC support)

With sources downloaded from sourceforge:
- (failed at 3.3 Compiling the PIC
- (failed to
run created only empty files)
- (same as the two above)
- sdcc documentation, chapter 2.4.1 (cannot remember what went wrong)

Yes, I believe, I have followed the descriptions by the letter, and
Yes, I have changed to root/sudo for >make install< (actually I have
tried both ways), and Yes, I had gputils up and running before. >had<,
because by now, I have uninstalled everything in order to make a clean
Before going into more detail, is there any help available, which I have not found yet?

Many thanks in advance.


Special Offer-- Download ArcSight Logger for FREE (a $49 USD value)!
Finally, a world-class log management solution at an even better price-free!
Download using promo code Free_Logger_4_Dev2Dev. Offer expires
February 28th, so secure your free ArcSight Logger TODAY!
Sdcc-user mailing list