actually thank YOU, since you found a gputils bug which I fixed right now, see

Now the original lab2.asm also compiles without errors with gpasm from svn HEAD.


On 29. 03. 2013 22:56, Luis de Arquer wrote:
Thanks a lot Borut!

It assembled fine now! :) I only had to comment out the line

config ICPRT = OFF

because it was complaining it did not exist such a config bit for the 2455.



On Fri, Mar 29, 2013 at 7:43 PM, Borut Ražem <> wrote:
On 29. 03. 2013 19:52, Luis de Arquer wrote:

Thanks for all the responses.

Joel, I have started downloading Microchip libraries, but seeing what
Sebastien is saying I think I should leave that for now. Thanks anyway

I've got a USB CDC ACM firmware that compiles with latest sdcc,
I'll see if I can put it up on my webpage this weekend.

That would be great.

On Fri, Mar 29, 2013 at 5:32 PM, Borut Ražem <> wrote:

I'm confused: you tried to compile the c (sdcc) source code with gpasm?
Probably not. So where the erros came from: sdcc or gpasm? If from
gpasm: can you send me the generated asm file?

Sorry, you are right, I am mixing things up. The one I tried is a
lab2.asm port to gpasm that you can find here

(not sure what lab2 is)
The assembler seems to be finding issues with some macros.

See the gputils bug tracker
Attached you'll find the modified version
which compiles without errors both with MPASM(X) and gpasm.

Good luck,