Alexei,

Your tar needs to look like "tar -xvf -" not "tar -xv -".
For the second part, I believe you are not finding the library correctly.  Try running under Cygnus to see if it helps.

I have not worked on SDCC in a long time (too busy) so it is best to address these questions to the mail list.

Good luck.

Michael

á.ì. wrote:

Hello Michael!
I have downloaded the 'SDCC-2.2.0a.winbin.tar.gz' (i'm new to it) and have some problems. Here they are: 
1) I've learned from the doc that the typical command for unpacking this
would be:
      gunzip -c sdcc-2.2.0a.winbin.tar.gz | tar -xv -
but after i tried it i got the following message
      tar: -: Not found in archive
      tar: Error exit delayed from previous errors
On other hand when i break the previous command in two, everything became
Ok:
     gunzip sdcc-2.2.0a.winbin.tar.gz
     tar -xvf sdcc-2.2.0a.winbin.tar
What is the matter?

2) After i created a batch file do.bat, containing the following
        set path = .\
        sdcc c.cand run it (from the DOS prompt) in order to compile a simple test program C.C,i get the error message :( 
          ?ASlink-Warning-Undefined-Global '__sdcc_external_startup',                                                                                    referenced by module 'c'
What is the workaround?

Thank you,
 Best Regards, Alexei Lyubimov
mailto:alexeimail@mtu-net.ru